aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-07-12 01:16:10 +0800
committersobomax <sobomax@FreeBSD.org>2002-07-12 01:16:10 +0800
commitda74e1e2753beef93258c048d602476b4b4dfd7c (patch)
tree38d55d2134664c2fa5ec17aa6dadae38a1ec9e4f /print
parent355f300440d2bd9dae6636ba5c8bf4eacacc9567 (diff)
downloadfreebsd-ports-gnome-da74e1e2753beef93258c048d602476b4b4dfd7c.tar.gz
freebsd-ports-gnome-da74e1e2753beef93258c048d602476b4b4dfd7c.tar.zst
freebsd-ports-gnome-da74e1e2753beef93258c048d602476b4b4dfd7c.zip
Convert all core GNOME1 components and some of the most popular GNOME1
apps to bsd.gnomeng.mk. The goal is to make GNOME1 framework more modular, which will allow to use GNOME1 apps with GNOME2 desktop as well as considerably reduce langht of dependency chains for GNOME1 ports (for example after this commit AbiWord's dependency chain was reduced by 7 ports from 57 to only 50, while Gnumeric's - from 60 to 53 and so on). The most of the GNOME1 apps are still not converted, so that lot of work is still ahead. Please report any unusual problems to gnome@FreeBSD.org. Discussed with: marcus Reviewed by: marcus
Diffstat (limited to 'print')
-rw-r--r--print/gnome-print/Makefile10
-rw-r--r--print/gnome-print/pkg-plist2
-rw-r--r--print/gnomeprint/Makefile10
-rw-r--r--print/gnomeprint/pkg-plist2
4 files changed, 8 insertions, 16 deletions
diff --git a/print/gnome-print/Makefile b/print/gnome-print/Makefile
index 7eb9305f97f3..9c270e8e1a3a 100644
--- a/print/gnome-print/Makefile
+++ b/print/gnome-print/Makefile
@@ -25,18 +25,16 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_PERL5= yes
-USE_GNOMECTRL= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomehack gnomeprefix gnomehier gnomelibs gnomecanvas
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
post-install:
@${TOUCH} ${PREFIX}/etc/gnome/fonts/gnome-print-x11.fontmap
diff --git a/print/gnome-print/pkg-plist b/print/gnome-print/pkg-plist
index 4e2857d85f38..e05ba7c0333b 100644
--- a/print/gnome-print/pkg-plist
+++ b/print/gnome-print/pkg-plist
@@ -118,5 +118,3 @@ share/locale/zh_TW/LC_MESSAGES/gnome-print.mo
@dirrm share/gnome/fonts/afms
@dirrm include/gnome-1.0/libgnomeprint
@dirrm etc/gnome/fonts
-@dirrm etc/gnome
-@unexec /bin/rmdir %D/share/gnome/fonts 2>/dev/null || /usr/bin/true
diff --git a/print/gnomeprint/Makefile b/print/gnomeprint/Makefile
index 7eb9305f97f3..9c270e8e1a3a 100644
--- a/print/gnomeprint/Makefile
+++ b/print/gnomeprint/Makefile
@@ -25,18 +25,16 @@ USE_BZIP2= yes
USE_X_PREFIX= yes
USE_GMAKE= yes
USE_PERL5= yes
-USE_GNOMECTRL= yes
+USE_GNOMENG= yes
+USE_GNOME= gnomehack gnomeprefix gnomehier gnomelibs gnomecanvas
INSTALLS_SHLIB= yes
GNU_CONFIGURE= yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
LIBS="-L${LOCALBASE}/lib"
-pre-patch:
- @${PERL} -pi -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
+post-patch:
+ @${REINPLACE_CMD} -e 's|-lpthread|${PTHREAD_LIBS}|g ; \
s|DATADIRNAME=lib|DATADIRNAME=share|g' ${WRKSRC}/configure
- @find ${WRKSRC} -name "Makefile.in*" | xargs ${PERL} -pi -e \
- 's|\$\(datadir\)/gnome/|\$\(datadir\)/|g ; \
- s|\$\(datadir\)/locale|\$\(prefix\)/share/locale|g'
post-install:
@${TOUCH} ${PREFIX}/etc/gnome/fonts/gnome-print-x11.fontmap
diff --git a/print/gnomeprint/pkg-plist b/print/gnomeprint/pkg-plist
index 4e2857d85f38..e05ba7c0333b 100644
--- a/print/gnomeprint/pkg-plist
+++ b/print/gnomeprint/pkg-plist
@@ -118,5 +118,3 @@ share/locale/zh_TW/LC_MESSAGES/gnome-print.mo
@dirrm share/gnome/fonts/afms
@dirrm include/gnome-1.0/libgnomeprint
@dirrm etc/gnome/fonts
-@dirrm etc/gnome
-@unexec /bin/rmdir %D/share/gnome/fonts 2>/dev/null || /usr/bin/true