aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authortaoka <taoka@FreeBSD.org>2001-03-09 13:17:00 +0800
committertaoka <taoka@FreeBSD.org>2001-03-09 13:17:00 +0800
commitf17a2882b02653cece34ba8bfbffea30d4eefc76 (patch)
treecc9da62df060aa79eeb2f327c5ca0147868a74c0 /print
parent2a9e0c9563d0853f12d44ee8ca00d4451be0323c (diff)
downloadfreebsd-ports-gnome-f17a2882b02653cece34ba8bfbffea30d4eefc76.tar.gz
freebsd-ports-gnome-f17a2882b02653cece34ba8bfbffea30d4eefc76.tar.zst
freebsd-ports-gnome-f17a2882b02653cece34ba8bfbffea30d4eefc76.zip
Bug-fix (rpm command was dealed with non-rpm files)
Obtained from: bento
Diffstat (limited to 'print')
-rw-r--r--print/bjfiltercom/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/print/bjfiltercom/Makefile b/print/bjfiltercom/Makefile
index 38d7803388b8..3a8f45aea953 100644
--- a/print/bjfiltercom/Makefile
+++ b/print/bjfiltercom/Makefile
@@ -9,7 +9,7 @@ PORTNAME?= bjfiltercom
PORTVERSION?= 1.0
CATEGORIES= print linux
MASTER_SITES= ftp://www.canon-sales.co.jp/pub/driver/printer/BJ/linux/
-DISTFILES= ${PORTNAME}-${PORTVERSION}-0.i386.rpm
+DISTFILES= ${RPMFILES}
.if !defined(SLAVE_PORT)
DISTFILES+= ${DOC_DISTFILES}
.endif
@@ -43,6 +43,7 @@ NO_BUILD= yes
NO_FILTER_SHLIBS= yes
NO_MTREE= yes
+RPMFILES= ${PORTNAME}-${PORTVERSION}-0.i386.rpm
.if defined(SLAVE_PORT)
FILTER= ${FILESDIR}/filter
PAPERSIZE?= a4
@@ -61,7 +62,7 @@ do-build:
${FILTER} > ${WRKDIR}/filter${PRTYPE}
do-install:
- for R in ${DISTFILES}; do \
+ for R in ${RPMFILES}; do \
rpm -U ${RPMFLAGS} ${RPMDIR}/$$R; \
done
.for i in ${BIN_FILES}