aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2017-01-13 04:20:08 +0800
committertijl <tijl@FreeBSD.org>2017-01-13 04:20:08 +0800
commitf9d258ee36cb617e723dd4890a05d23c494fc5e6 (patch)
treed53eecc315af0499a25d3fbaef60b99471525105 /print
parent199f3b0c1e599e0cabab0406e066dd86cf42f3da (diff)
downloadfreebsd-ports-gnome-f9d258ee36cb617e723dd4890a05d23c494fc5e6.tar.gz
freebsd-ports-gnome-f9d258ee36cb617e723dd4890a05d23c494fc5e6.tar.zst
freebsd-ports-gnome-f9d258ee36cb617e723dd4890a05d23c494fc5e6.zip
Add support for HBPLv1 printers with patch from
https://www.cybercom.net/~dcoffin/hbpl/ Also fix patch-getweb.in: remove -o from FETCHOPTS because fetch is sometimes executed without output file. PR: 211754 Submitted by: Oliver Kett <freebsd@broken-wire.de>
Diffstat (limited to 'print')
-rw-r--r--print/foo2zjs/Makefile6
-rw-r--r--print/foo2zjs/distinfo2
-rw-r--r--print/foo2zjs/files/patch-getweb.in10
-rw-r--r--print/foo2zjs/pkg-plist16
4 files changed, 28 insertions, 6 deletions
diff --git a/print/foo2zjs/Makefile b/print/foo2zjs/Makefile
index 330dca014627..b495ddf6c272 100644
--- a/print/foo2zjs/Makefile
+++ b/print/foo2zjs/Makefile
@@ -3,10 +3,15 @@
PORTNAME= foo2zjs
PORTVERSION= 20161203
+PORTREVISION= 1
CATEGORIES= print
MASTER_SITES= LOCAL/bsam/${PORTNAME} \
ftp://ftp.wart.ru/pub/FreeBSD/ports/distfiles/
+# Obtained from https://www.cybercom.net/~dcoffin/hbpl/
+PATCH_SITES= LOCAL/tijl
+PATCHFILES= hbpl1-20160830.patch.xz:-p1
+
MAINTAINER= ports@FreeBSD.org
COMMENT= Driver for printers that use the ZjStream wire protocol
@@ -18,7 +23,6 @@ RUN_DEPENDS= ${LOCALBASE}/share/foomatic/db/oldprinterids:print/foomatic-db \
foomatic-rip:print/cups-filters \
gsed:textproc/gsed
-PROJECTHOST= bsdistfiles
USES= ghostscript gmake shebangfix
SHEBANG_FILES= msexpand printer-profile.sh
SUB_FILES= pkg-message ${DEVDCONF_FILE}
diff --git a/print/foo2zjs/distinfo b/print/foo2zjs/distinfo
index 7e1dbd35dfe6..41a45340520f 100644
--- a/print/foo2zjs/distinfo
+++ b/print/foo2zjs/distinfo
@@ -1,3 +1,5 @@
TIMESTAMP = 1481811015
SHA256 (foo2zjs-20161203.tar.gz) = 8608c9adfc86dc4ea721f234b0f3fcbe8d0393aea953d69e7f706a3dec3c9514
SIZE (foo2zjs-20161203.tar.gz) = 1791101
+SHA256 (hbpl1-20160830.patch.xz) = e4584029ff71d405a1723332220842a02a0682fd6d43a4690d12e3ce341ae6a7
+SIZE (hbpl1-20160830.patch.xz) = 20472
diff --git a/print/foo2zjs/files/patch-getweb.in b/print/foo2zjs/files/patch-getweb.in
index 6857a8e2fa6d..d5c52cf5c855 100644
--- a/print/foo2zjs/files/patch-getweb.in
+++ b/print/foo2zjs/files/patch-getweb.in
@@ -5,7 +5,7 @@
VERSION='$Id: getweb.in,v 1.112 2013/12/25 21:00:11 rick Exp $'
-WGETOPTS="--passive-ftp -q"
-+FETCHOPTS="-p -m -o"
++FETCHOPTS="-p -m"
usage() {
cat <<EOF
@@ -14,7 +14,7 @@
shift; shift
- wget $WGETOPTS -O $exefile "$url/$exefile" ||
-+ fetch $FETCHOPTS $exefile "$url/$exefile" ||
++ fetch $FETCHOPTS -o $exefile "$url/$exefile" ||
error "Couldn't download $url/$exefile"
unzip -oj $exefile "$@"
rm $exefile
@@ -23,7 +23,7 @@
what="$3"
- wget $WGETOPTS -O $file "$url/$file" ||
-+ fetch $FETCHOPTS $file "$url/$file" ||
++ fetch $FETCHOPTS -o $file "$url/$file" ||
error "Couldn't download $url/$file"
gunzip <$file | tar xvf - $what
rm $file
@@ -50,7 +50,7 @@
URL="$URL&.submit=Generate+PPD+file"
URL="$URL&show=1&.cgifields=shortgui&.cgifields=show"
- wget $WGETOPTS -O PPD/$printer.ppd "$URL" ||
-+ fetch $FETCHOPTS PPD/$printer.ppd "$URL" ||
++ fetch $FETCHOPTS -o PPD/$printer.ppd "$URL" ||
error "Couldn't dowload $URL"
done
;;
@@ -59,7 +59,7 @@
url=${URLZJS}
file=foo2zjs.tar.gz
- wget $WGETOPTS -O $file $url/$file ||
-+ fetch $FETCHOPTS $file $url/$file ||
++ fetch $FETCHOPTS -o $file $url/$file ||
error "Couldn't download $url/$exefile"
mv getweb getweb.old
HERE=`pwd`
diff --git a/print/foo2zjs/pkg-plist b/print/foo2zjs/pkg-plist
index 11d018bc9661..d917038e1dd7 100644
--- a/print/foo2zjs/pkg-plist
+++ b/print/foo2zjs/pkg-plist
@@ -1,4 +1,6 @@
bin/arm2hpdl
+bin/foo2hbpl1
+bin/foo2hbpl1-wrapper
bin/foo2hbpl2
bin/foo2hbpl2-wrapper
bin/foo2hiperc
@@ -33,6 +35,10 @@ bin/slxdecode
bin/xqxdecode
bin/zjsdecode
etc/devd/foo2zjs.conf
+foomatic/db/source/opt/foo2hbpl1-ColorMode.xml
+foomatic/db/source/opt/foo2hbpl1-ICM.xml
+foomatic/db/source/opt/foo2hbpl1-MediaType.xml
+foomatic/db/source/opt/foo2hbpl1-PageSize.xml
foomatic/db/source/opt/foo2hbpl2-ColorMode.xml
foomatic/db/source/opt/foo2hbpl2-ICM.xml
foomatic/db/source/opt/foo2hbpl2-MediaType.xml
@@ -119,12 +125,17 @@ foomatic/db/source/opt/foo2zjs-z2-MediaType.xml
foomatic/db/source/opt/foo2zjs-z2-PageSize.xml
foomatic/db/source/opt/foo2zjs-z3-MediaType.xml
foomatic/db/source/opt/foo2zjs-z3-PageSize.xml
+foomatic/db/source/printer/Dell-1250c.xml
foomatic/db/source/printer/Dell-1355.xml
+foomatic/db/source/printer/Dell-C1660.xml
+foomatic/db/source/printer/Dell-C1760.xml
foomatic/db/source/printer/Dell-C1765.xml
+foomatic/db/source/printer/Epson-AcuLaser_C1700.xml
foomatic/db/source/printer/Epson-AcuLaser_CX17NF.xml
foomatic/db/source/printer/Epson-AcuLaser_M1400.xml
foomatic/db/source/printer/Fuji_Xerox-DocuPrint_CM205.xml
foomatic/db/source/printer/Fuji_Xerox-DocuPrint_CM215.xml
+foomatic/db/source/printer/Fuji_Xerox-DocuPrint_CP105.xml
foomatic/db/source/printer/Fuji_Xerox-DocuPrint_M215.xml
foomatic/db/source/printer/Fuji_Xerox-DocuPrint_P205.xml
foomatic/db/source/printer/Generic-OAKT_Printer.xml
@@ -210,12 +221,17 @@ foomatic/db/source/printer/Xerox-Phaser_6115MFP.xml
foomatic/db/source/printer/Xerox-Phaser_6121MFP.xml
foomatic/db/source/printer/Xerox-WorkCentre_3045.xml
foomatic/db/source/printer/Xerox-WorkCentre_6015.xml
+share/cups/model/Dell-1250c.ppd.gz
share/cups/model/Dell-1355.ppd.gz
+share/cups/model/Dell-C1660.ppd.gz
+share/cups/model/Dell-C1760.ppd.gz
share/cups/model/Dell-C1765.ppd.gz
+share/cups/model/Epson-AcuLaser_C1700.ppd.gz
share/cups/model/Epson-AcuLaser_CX17NF.ppd.gz
share/cups/model/Epson-AcuLaser_M1400.ppd.gz
share/cups/model/Fuji_Xerox-DocuPrint_CM205.ppd.gz
share/cups/model/Fuji_Xerox-DocuPrint_CM215.ppd.gz
+share/cups/model/Fuji_Xerox-DocuPrint_CP105.ppd.gz
share/cups/model/Fuji_Xerox-DocuPrint_M215.ppd.gz
share/cups/model/Fuji_Xerox-DocuPrint_P205.ppd.gz
share/cups/model/Generic-OAKT_Printer.ppd.gz