aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2008-04-05 01:22:04 +0800
committerahze <ahze@FreeBSD.org>2008-04-05 01:22:04 +0800
commit22d3fb7c85cb0c6b3f03a5e5d8541beb59973c8d (patch)
tree5c001eccea37423e7c2e8085454f68bcbaf673ab /print
parent75ee5f68478ef3a66a3a1bcdb00dff3e746c7939 (diff)
downloadfreebsd-ports-gnome-22d3fb7c85cb0c6b3f03a5e5d8541beb59973c8d.tar.gz
freebsd-ports-gnome-22d3fb7c85cb0c6b3f03a5e5d8541beb59973c8d.tar.zst
freebsd-ports-gnome-22d3fb7c85cb0c6b3f03a5e5d8541beb59973c8d.zip
Error on pre-configure if ghostscript-gnu is installed and warn to use ghostscript-gpl instead
Requested by: mezz
Diffstat (limited to 'print')
-rw-r--r--print/libspectre/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/print/libspectre/Makefile b/print/libspectre/Makefile
index 088dbfddf853..8e674da7dd2f 100644
--- a/print/libspectre/Makefile
+++ b/print/libspectre/Makefile
@@ -21,4 +21,12 @@ USE_GNOME= gnomehack gnomeprefix ltverhack
USE_GHOSTSCRIPT=yes
CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" LDFLAGS="-L${LOCALBASE}/lib"
+pre-configure:
+ @if [ -n "`${PKG_INFO} -xI '^ghostscript-gnu-[0-9]*'`" ]; then \
+ ${ECHO_CMD} "${PKGNAME}: ghostscript-gnu installed, please deinstall ghostscript-gnu"; \
+ ${ECHO_CMD} "and use ghostscript-gpl. Make sure you don't have WITH_GHOSTSCRIPT_GNU"; \
+ ${ECHO_CMD} "or GHOSTSCRIPT_PORT defined."; \
+ ${FALSE}; \
+ fi
+
.include <bsd.port.mk>