aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authoranray <anray@FreeBSD.org>2006-01-25 02:54:29 +0800
committeranray <anray@FreeBSD.org>2006-01-25 02:54:29 +0800
commit2573bdd414c42b2f5ddafa0d41a5592182b73df5 (patch)
tree08788a20dd2b5ca9a0a0f59291d6e47f85f11ba3 /print
parent6f88a5609587909ab946da0a4f7cf4e1fcedc374 (diff)
downloadfreebsd-ports-gnome-2573bdd414c42b2f5ddafa0d41a5592182b73df5.tar.gz
freebsd-ports-gnome-2573bdd414c42b2f5ddafa0d41a5592182b73df5.tar.zst
freebsd-ports-gnome-2573bdd414c42b2f5ddafa0d41a5592182b73df5.zip
Fix build and unbreak port.
PR: ports/92277 Submitted by: rik
Diffstat (limited to 'print')
-rw-r--r--print/lilypond/Makefile6
-rw-r--r--print/lilypond/files/patch-mf:GNUMakefile2
-rw-r--r--print/lilypond/scripts/post-configure4
-rw-r--r--print/lilypond/scripts/post-patch4
4 files changed, 6 insertions, 10 deletions
diff --git a/print/lilypond/Makefile b/print/lilypond/Makefile
index cc6ed035e3b2..872bdcce21e4 100644
--- a/print/lilypond/Makefile
+++ b/print/lilypond/Makefile
@@ -57,10 +57,6 @@ CFLAGS+= ${CPPFLAGS}
.include <bsd.port.pre.mk>
ALL_TARGET= all
-.if ${OSVERSION} >= 502120
-BROKEN= "Does not compile on FreeBSD >= 5.x"
-.endif
-
.if ${OSVERSION} < 500000
USE_GCC= 3.4
.endif
@@ -83,7 +79,7 @@ pre-configure:
.if !defined(WITH_SELFBUILT_FONTS)
post-configure:
- cd ${WRKSRC} && ${GMAKE} -C mf get-pfa
+ cd ${WRKSRC} && ${GMAKE} -C mf get-pfa DISTDIR=${DISTDIR}
.endif
post-install:
diff --git a/print/lilypond/files/patch-mf:GNUMakefile b/print/lilypond/files/patch-mf:GNUMakefile
index be812ad1539d..0862b73e0345 100644
--- a/print/lilypond/files/patch-mf:GNUMakefile
+++ b/print/lilypond/files/patch-mf:GNUMakefile
@@ -10,7 +10,7 @@
@echo "For obtaining PFA fonts, either install mftrace "
@echo "(see http://www.xs4all.nl/~hanwen/mftrace/ ),"
- @echo "or try one of the following commands in this directory: "
-+ @echo "or try one of the following commands in /usr/ports/print/lilypond/work/lilypond-2.2.2"
++ @echo "or try one of the following commands in /usr/ports/print/lilypond/work/lilypond-$(TOPLEVEL_VERSION)"
@echo ""
- @echo " make get-pfa "
- @echo " make get-rpm-pfa "
diff --git a/print/lilypond/scripts/post-configure b/print/lilypond/scripts/post-configure
index 713c4d692b10..32ff6afe2fcf 100644
--- a/print/lilypond/scripts/post-configure
+++ b/print/lilypond/scripts/post-configure
@@ -7,8 +7,8 @@ cd ${WRKSRC} || exit 2
gmake conf=$CONF -C lily $outdir/lexer.cc || true
mv $file $file.orig
- sed -e 's/istream\*/std::istream*/g' \
- -e 's/ostream\*/std::ostream*/g' \
+ sed -e 's/[^:]istream\*/std::istream*/g' \
+ -e 's/[^:]ostream\*/std::ostream*/g' \
-e 's/class istream;/#include \<iostream\>/g' \
$file.orig > $file
echo "done"
diff --git a/print/lilypond/scripts/post-patch b/print/lilypond/scripts/post-patch
index aff5fb958c45..9b09186e2d60 100644
--- a/print/lilypond/scripts/post-patch
+++ b/print/lilypond/scripts/post-patch
@@ -13,8 +13,8 @@ echo -n "Copying and fixing $file... "
mkdir -p lily/$outdir
rm -f lily/$outdir/FlexLexer.h
sed \
- -e 's/istream/std::istream/' \
- -e 's/[^i]ostream/std::ostream/' \
+ -e 's/[^:]istream/std::istream/' \
+ -e 's/[^i:]ostream/std::ostream/' \
-e 's/iostream.h/iostream/' \
$file > lily/$outdir/FlexLexer.h
echo "done"