aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorbland <bland@FreeBSD.org>2003-10-01 09:26:23 +0800
committerbland <bland@FreeBSD.org>2003-10-01 09:26:23 +0800
commit3846d77e2f2335c2185c2b5f0139b26136a09b80 (patch)
tree0b248caab796acb373dab212fc5fc7d81ad000a2 /print
parentac6783e69d46a35b7c25744da33cafff11d2a037 (diff)
downloadfreebsd-ports-gnome-3846d77e2f2335c2185c2b5f0139b26136a09b80.tar.gz
freebsd-ports-gnome-3846d77e2f2335c2185c2b5f0139b26136a09b80.tar.zst
freebsd-ports-gnome-3846d77e2f2335c2185c2b5f0139b26136a09b80.zip
Due a number of negative feedback about lost font hinting
TTF bytecode interpreter is enabled back by default. There is a new option WITHOUT_TTF_BYTECODE_ENABLED wich makes others happy too.
Diffstat (limited to 'print')
-rw-r--r--print/freetype2/Makefile19
1 files changed, 19 insertions, 0 deletions
diff --git a/print/freetype2/Makefile b/print/freetype2/Makefile
index 7820f87076be..7dfda7a84e70 100644
--- a/print/freetype2/Makefile
+++ b/print/freetype2/Makefile
@@ -7,6 +7,7 @@
PORTNAME= freetype2
PORTVERSION= 2.1.5
+PORTREVISION= 1
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_SOURCEFORGE:S,%SUBDIR%,freetype,} \
http://sunsite.cnlab-switch.ch/ftp/mirror/freetype/%SUBDIR%/ \
@@ -31,6 +32,24 @@ LIBTOOLFILES= builds/unix/configure
CONFIGURE_ARGS= --disable-nls
CONFIGURE_WRKSRC= ${WRKSRC}/builds/unix
+.if !defined(WITHOUT_TTF_BYTECODE_ENABLED)
+CFLAGS+= -DTT_CONFIG_OPTION_BYTECODE_INTERPRETER
+.endif
+
+pre-everything::
+.if !defined(WITHOUT_TTF_BYTECODE_ENABLED)
+ @${ECHO_MSG}
+ @${ECHO_MSG} "You may want not to compile a bytecode interpreter into the"
+ @${ECHO_MSG} "TrueType driver. Without this you will only compile the code"
+ @${ECHO_MSG} "necessary to load TrueType glyphs without hinting."
+ @${ECHO_MSG}
+ @${ECHO_MSG} "Hit Ctrl-C now and use \"make WITHOUT_TTF_BYTECODE_ENABLED=yes\""
+ @${ECHO_MSG}
+ @${ECHO_MSG} "Note that there are important patent issues related to the"
+ @${ECHO_MSG} "use of the interpreter."
+ @${ECHO_MSG}
+.endif
+
pre-patch:
@${REINPLACE_CMD} -e 's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g' \
${WRKSRC}/builds/unix/install.mk