aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authormezz <mezz@FreeBSD.org>2008-12-25 02:47:29 +0800
committermezz <mezz@FreeBSD.org>2008-12-25 02:47:29 +0800
commit3c113c6e4bddbe6543a6b9d82596e0d4a990d44e (patch)
tree58bcade2e4f09f11e57d45c540031b5949237473 /print
parentf35e3066578a3d9d3c07a37615901483231397af (diff)
downloadfreebsd-ports-gnome-3c113c6e4bddbe6543a6b9d82596e0d4a990d44e.tar.gz
freebsd-ports-gnome-3c113c6e4bddbe6543a6b9d82596e0d4a990d44e.tar.zst
freebsd-ports-gnome-3c113c6e4bddbe6543a6b9d82596e0d4a990d44e.zip
- Update to 1.0.12.
- Correct the path of snmp (lib -> libexec). - Do not comment out the debugprint or it crashes when try to add printer from samba. Approved by: ahze (maintainer)
Diffstat (limited to 'print')
-rw-r--r--print/system-config-printer/Makefile3
-rw-r--r--print/system-config-printer/distinfo6
-rw-r--r--print/system-config-printer/files/patch-cupshelpers_cupshelpers.py9
-rw-r--r--print/system-config-printer/files/patch-system-config-printer.py2
4 files changed, 5 insertions, 15 deletions
diff --git a/print/system-config-printer/Makefile b/print/system-config-printer/Makefile
index 3587ca0db016..f978e62d3f61 100644
--- a/print/system-config-printer/Makefile
+++ b/print/system-config-printer/Makefile
@@ -7,8 +7,7 @@
#
PORTNAME= system-config-printer
-PORTVERSION= 1.0.11
-PORTREVISION= 1
+PORTVERSION= 1.0.12
CATEGORIES= print gnome
MASTER_SITES= http://cyberelk.net/tim/data/${PORTNAME}/${PORTVERSION:R}.x/
diff --git a/print/system-config-printer/distinfo b/print/system-config-printer/distinfo
index 5e06710795cc..5396c8e26d63 100644
--- a/print/system-config-printer/distinfo
+++ b/print/system-config-printer/distinfo
@@ -1,3 +1,3 @@
-MD5 (system-config-printer-1.0.11.tar.bz2) = 9e1557bb357c9f9c7b7bff4f12628d20
-SHA256 (system-config-printer-1.0.11.tar.bz2) = dcc9cbd378db8b9483ae4f724f18e72971ff9c4fe12510d362058693d9fa2c75
-SIZE (system-config-printer-1.0.11.tar.bz2) = 830109
+MD5 (system-config-printer-1.0.12.tar.bz2) = 5ba48202a4416d55dde55b4eb0d64ec2
+SHA256 (system-config-printer-1.0.12.tar.bz2) = b19dc3f0680a92020363071cf297c1c0bf4b04e300eeb2f483544076a4bb9502
+SIZE (system-config-printer-1.0.12.tar.bz2) = 833639
diff --git a/print/system-config-printer/files/patch-cupshelpers_cupshelpers.py b/print/system-config-printer/files/patch-cupshelpers_cupshelpers.py
index 53e62fba18ff..6624df0adb63 100644
--- a/print/system-config-printer/files/patch-cupshelpers_cupshelpers.py
+++ b/print/system-config-printer/files/patch-cupshelpers_cupshelpers.py
@@ -1,14 +1,5 @@
--- cupshelpers/cupshelpers.py.orig 2008-07-09 06:23:44.000000000 -0500
+++ cupshelpers/cupshelpers.py 2008-07-26 13:33:50.596144479 -0500
-@@ -20,7 +20,7 @@
-
- import cups, pprint, os, tempfile, re
- import locale
--from . import _debugprint
-+# from . import _debugprint
-
- class Printer:
- _flags_blacklist = ["options", "local"]
@@ -699,7 +699,7 @@
# First, a local function. How to check that something exists
diff --git a/print/system-config-printer/files/patch-system-config-printer.py b/print/system-config-printer/files/patch-system-config-printer.py
index 2a98aba10a16..784a0a8cea29 100644
--- a/print/system-config-printer/files/patch-system-config-printer.py
+++ b/print/system-config-printer/files/patch-system-config-printer.py
@@ -5,7 +5,7 @@
if host:
os.environ["HOST"] = host
- cmd = '/usr/lib/cups/backend/snmp "${HOST}"'
-+ cmd = '%%LOCALBASE%%/lib/cups/backend/snmp "${HOST}"'
++ cmd = '%%LOCALBASE%%/libexec/cups/backend/snmp "${HOST}"'
debugprint (host + ": " + cmd)
stdout = None
try: