aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authoramdmi3 <amdmi3@FreeBSD.org>2015-10-19 22:50:52 +0800
committeramdmi3 <amdmi3@FreeBSD.org>2015-10-19 22:50:52 +0800
commit6a98fceb0a6004a4c5a1fd86d54347f6a29f74c4 (patch)
tree72fd93ae39b43490b34dc8479465e07b453d126e /print
parente18413661fadcae47bb20ec0de548623410227ad (diff)
downloadfreebsd-ports-gnome-6a98fceb0a6004a4c5a1fd86d54347f6a29f74c4.tar.gz
freebsd-ports-gnome-6a98fceb0a6004a4c5a1fd86d54347f6a29f74c4.tar.zst
freebsd-ports-gnome-6a98fceb0a6004a4c5a1fd86d54347f6a29f74c4.zip
Improve shebangfix framework
- Support multiple values in *_OLD_CMD, i.e. we can now fix both "/usr/bin/python" and "/usr/bin/env python" at the same time - Default *_OLD_CMD values are now always appended, so you don't need to specify them in individual ports - Add lua support (depends on USES=lua) - Add more default values, such as "/usr/bin/env foo" for python, perl, bash, ruby and lua - Shebangfix now matches whole words, e.g. we will no longer (erroneously) replace "/usr/bin/perl5.005" with "${perl_CMD}5.005" (but "/usr/bin/perl -tt" is still (correctly) replaced with "${perl_CMD} -tt") Note that *_OLD_CMD items containing spaces must now be quoted (e.g. perl_OLD_CMD=/bin/perl /usr/bin/perl "/usr/bin/env perl") Update shebangfix usage according to new rules in many ports: - Remove *_OLD_CMD for patterns now replaced by default - Quote custom *_OLD_CMD which contain spaces Fix shebangfix usage in many ports (irrelevant to infrastructure change): - Remove redundant SHEBANG_LANG (no need to duplicate default langs) - Remove redundant *_CMD (such as python_CMD=${LOCALBASE}/bin/python${PYTHON_VER} when USES=python is present) - Never use *_OLD_CMD in REINPLACE_CMD matchers, these should always look for exact string Approved by: portmgr (bapt) Differential Revision: D3756
Diffstat (limited to 'print')
-rw-r--r--print/texlive-texmf/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/print/texlive-texmf/Makefile b/print/texlive-texmf/Makefile
index 339447b5eafa..afa7b8d833b3 100644
--- a/print/texlive-texmf/Makefile
+++ b/print/texlive-texmf/Makefile
@@ -273,11 +273,11 @@ do-install:
${TOUCH} ${STAGEDIR}${PREFIX}/${TEXMFDISTDIR}/source/.keep_me
post-install:
- @${REINPLACE_CMD} -i '' -e '1s|${bash_OLD_CMD}|${bash_CMD}|' \
+ @${REINPLACE_CMD} -i '' -e '1s|/bin/bash|${bash_CMD}|' \
${STAGEDIR}${PREFIX}/share/texmf-dist/scripts/logicpuzzle/createlpsudoku \
${STAGEDIR}${PREFIX}/share/texmf-dist/scripts/logicpuzzle/lpsmag \
${STAGEDIR}${PREFIX}/share/texmf-dist/scripts/shipunov/biokey2html.sh
- @${REINPLACE_CMD} -i '' -e '1s|${perl_OLD_CMD}|${perl_CMD}|' \
+ @${REINPLACE_CMD} -i '' -e '1s|/usr/bin/perl|${perl_CMD}|' \
${STAGEDIR}${PREFIX}/share/texmf-dist/scripts/mycv/mycv_split_contents.pl
.include <bsd.port.mk>