aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2007-03-29 16:57:52 +0800
committermiwi <miwi@FreeBSD.org>2007-03-29 16:57:52 +0800
commit953c16f7a36818c4659cd385f0ff898dffe0d481 (patch)
tree9ee79f6451995b576c5458886e2b7ae2e55f54d0 /print
parenteba53c2d08871e9c6e70163182a392abec26456c (diff)
downloadfreebsd-ports-gnome-953c16f7a36818c4659cd385f0ff898dffe0d481.tar.gz
freebsd-ports-gnome-953c16f7a36818c4659cd385f0ff898dffe0d481.tar.zst
freebsd-ports-gnome-953c16f7a36818c4659cd385f0ff898dffe0d481.zip
XPP is a graphical utility for managing printers and submitting print jobs.
It interfaces with CUPS on the backend and allows the user to configure double sided printing, active tray, color adjustment, etc. It supports the command line flags of lpr as well. You will first need to configure a printer via CUPS to use XPP. WWW: http://cups.sourceforge.net/xpp/ PR: ports/110780 Submitted by: Nate Lawson <njl at freebsd.org>
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/xpp/Makefile32
-rw-r--r--print/xpp/distinfo3
-rw-r--r--print/xpp/pkg-descr8
4 files changed, 44 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index 8b1d8a3cb83d..86a322d44895 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -298,6 +298,7 @@
SUBDIR += xfce4-print
SUBDIR += xmbibtex
SUBDIR += xmltex
+ SUBDIR += xpp
SUBDIR += xtexsh
SUBDIR += yatex
SUBDIR += yatex-mule
diff --git a/print/xpp/Makefile b/print/xpp/Makefile
new file mode 100644
index 000000000000..91ff6d137cff
--- /dev/null
+++ b/print/xpp/Makefile
@@ -0,0 +1,32 @@
+# New ports collection makefile for: xpp
+# Date created: 23 Mar 2007
+# Whom: Nate Lawson <njl@freebsd.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= xpp
+PORTVERSION= 1.5
+CATEGORIES= print
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= cups
+DISTNAME= ${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= njl@FreeBSD.org
+COMMENT= X11-based printer manager for CUPS
+
+LIB_DEPENDS= cups.2:${PORTSDIR}/print/cups-base \
+ fltk.1:${PORTSDIR}/x11-toolkits/fltk
+
+USE_BZIP2= yes
+USE_GMAKE= yes
+GNU_CONFIGURE= yes
+
+PLIST_FILES= bin/xpp
+
+post-configure:
+ @${REINPLACE_CMD} -e 's|$$(all_includes)|-I ${PREFIX}/include|' \
+ ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} -e 's|CFLAGS =|CFLAGS +=|' ${WRKSRC}/Makefile
+
+.include <bsd.port.mk>
diff --git a/print/xpp/distinfo b/print/xpp/distinfo
new file mode 100644
index 000000000000..c28e15174ff3
--- /dev/null
+++ b/print/xpp/distinfo
@@ -0,0 +1,3 @@
+MD5 (xpp-1.5.tar.bz2) = fd539258d2b1a554f01937047d44f78e
+SHA256 (xpp-1.5.tar.bz2) = e47cee4986f16a3449ab4e4925e781243a5104567bd5551e871d3e0338c894bc
+SIZE (xpp-1.5.tar.bz2) = 95482
diff --git a/print/xpp/pkg-descr b/print/xpp/pkg-descr
new file mode 100644
index 000000000000..36369751d0a6
--- /dev/null
+++ b/print/xpp/pkg-descr
@@ -0,0 +1,8 @@
+XPP is a graphical utility for managing printers and submitting print jobs.
+It interfaces with CUPS on the backend and allows the user to configure
+double sided printing, active tray, color adjustment, etc. It supports the
+command line flags of lpr as well.
+
+You will first need to configure a printer via CUPS to use XPP.
+
+WWW: http://cups.sourceforge.net/xpp/