aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2013-06-06 22:59:50 +0800
committerkwm <kwm@FreeBSD.org>2013-06-06 22:59:50 +0800
commit9e593583b391ab2288f1c4b0bcb95df2ae704d86 (patch)
treeec560174eb61e573b84f59e7bef7b7ab8377964c /print
parentb42e9bd121388f25eebcd5e7f44fd1cc45cc0692 (diff)
downloadfreebsd-ports-gnome-9e593583b391ab2288f1c4b0bcb95df2ae704d86.tar.gz
freebsd-ports-gnome-9e593583b391ab2288f1c4b0bcb95df2ae704d86.tar.zst
freebsd-ports-gnome-9e593583b391ab2288f1c4b0bcb95df2ae704d86.zip
Enable disabled support for cairo, graphite and icu support. It was pointed
out to me that there is a subtle build failure in future webkit releases and that libreoffice 4.1 depends on the icu support in harfbuzz. Pointed out by: olivierd@ (via priv mail) and ftigeot (on IRC)
Diffstat (limited to 'print')
-rw-r--r--print/harfbuzz/Makefile7
-rw-r--r--print/harfbuzz/files/patch-configure658
-rw-r--r--print/harfbuzz/pkg-plist3
3 files changed, 8 insertions, 660 deletions
diff --git a/print/harfbuzz/Makefile b/print/harfbuzz/Makefile
index 21cbdb32ce31..c8b07902d8e2 100644
--- a/print/harfbuzz/Makefile
+++ b/print/harfbuzz/Makefile
@@ -3,19 +3,22 @@
PORTNAME= harfbuzz
PORTVERSION= 0.9.16
+PORTREVISION= 1
CATEGORIES= print
MASTER_SITES= http://www.freedesktop.org/software/harfbuzz/release/
MAINTAINER= kwm@FreeBSD.org
COMMENT= OpenType text shaping engine
-LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2
+LIB_DEPENDS= freetype:${PORTSDIR}/print/freetype2 \
+ icudata:${PORTSDIR}/devel/icu \
+ graphite2:${PORTSDIR}/graphics/graphite2
USE_BZIP2= yes
USE_GMAKE= yes
USE_LDCONFIG= yes
USES= pathfix pkgconfig
-USE_GNOME= glib20 ltverhack
+USE_GNOME= cairo glib20 ltverhack
USE_AUTOTOOLS= libtool
.include <bsd.port.pre.mk>
diff --git a/print/harfbuzz/files/patch-configure b/print/harfbuzz/files/patch-configure
deleted file mode 100644
index 608490a965c0..000000000000
--- a/print/harfbuzz/files/patch-configure
+++ /dev/null
@@ -1,658 +0,0 @@
---- configure.orig 2013-04-21 11:02:00.000000000 +0000
-+++ configure 2013-04-21 11:07:06.000000000 +0000
-@@ -17019,655 +17019,31 @@
-
-
-
--pkg_failed=no
--{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for CAIRO" >&5
--$as_echo_n "checking for CAIRO... " >&6; }
--
--if test -n "$PKG_CONFIG"; then
-- if test -n "$CAIRO_CFLAGS"; then
-- pkg_cv_CAIRO_CFLAGS="$CAIRO_CFLAGS"
-- else
-- if test -n "$PKG_CONFIG" && \
-- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"cairo >= 1.8.0\""; } >&5
-- ($PKG_CONFIG --exists --print-errors "cairo >= 1.8.0") 2>&5
-- ac_status=$?
-- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
-- test $ac_status = 0; }; then
-- pkg_cv_CAIRO_CFLAGS=`$PKG_CONFIG --cflags "cairo >= 1.8.0" 2>/dev/null`
--else
-- pkg_failed=yes
--fi
-- fi
--else
-- pkg_failed=untried
--fi
--if test -n "$PKG_CONFIG"; then
-- if test -n "$CAIRO_LIBS"; then
-- pkg_cv_CAIRO_LIBS="$CAIRO_LIBS"
-- else
-- if test -n "$PKG_CONFIG" && \
-- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"cairo >= 1.8.0\""; } >&5
-- ($PKG_CONFIG --exists --print-errors "cairo >= 1.8.0") 2>&5
-- ac_status=$?
-- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
-- test $ac_status = 0; }; then
-- pkg_cv_CAIRO_LIBS=`$PKG_CONFIG --libs "cairo >= 1.8.0" 2>/dev/null`
--else
-- pkg_failed=yes
--fi
-- fi
--else
-- pkg_failed=untried
--fi
--
--
--
--if test $pkg_failed = yes; then
--
--if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
-- _pkg_short_errors_supported=yes
--else
-- _pkg_short_errors_supported=no
--fi
-- if test $_pkg_short_errors_supported = yes; then
-- CAIRO_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "cairo >= 1.8.0"`
-- else
-- CAIRO_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "cairo >= 1.8.0"`
-- fi
-- # Put the nasty error message in config.log where it belongs
-- echo "$CAIRO_PKG_ERRORS" >&5
--
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
--$as_echo "no" >&6; }
-- have_cairo=false
--elif test $pkg_failed = untried; then
-- have_cairo=false
--else
-- CAIRO_CFLAGS=$pkg_cv_CAIRO_CFLAGS
-- CAIRO_LIBS=$pkg_cv_CAIRO_LIBS
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
--$as_echo "yes" >&6; }
-- have_cairo=true
--fi
--if $have_cairo; then
--
--$as_echo "#define HAVE_CAIRO 1" >>confdefs.h
--
--fi
-- if $have_cairo; then
-- HAVE_CAIRO_TRUE=
-- HAVE_CAIRO_FALSE='#'
--else
- HAVE_CAIRO_TRUE='#'
- HAVE_CAIRO_FALSE=
--fi
--
-
-
--pkg_failed=no
--{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for CAIRO_FT" >&5
--$as_echo_n "checking for CAIRO_FT... " >&6; }
-
--if test -n "$PKG_CONFIG"; then
-- if test -n "$CAIRO_FT_CFLAGS"; then
-- pkg_cv_CAIRO_FT_CFLAGS="$CAIRO_FT_CFLAGS"
-- else
-- if test -n "$PKG_CONFIG" && \
-- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"cairo-ft\""; } >&5
-- ($PKG_CONFIG --exists --print-errors "cairo-ft") 2>&5
-- ac_status=$?
-- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
-- test $ac_status = 0; }; then
-- pkg_cv_CAIRO_FT_CFLAGS=`$PKG_CONFIG --cflags "cairo-ft" 2>/dev/null`
--else
-- pkg_failed=yes
--fi
-- fi
--else
-- pkg_failed=untried
--fi
--if test -n "$PKG_CONFIG"; then
-- if test -n "$CAIRO_FT_LIBS"; then
-- pkg_cv_CAIRO_FT_LIBS="$CAIRO_FT_LIBS"
-- else
-- if test -n "$PKG_CONFIG" && \
-- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"cairo-ft\""; } >&5
-- ($PKG_CONFIG --exists --print-errors "cairo-ft") 2>&5
-- ac_status=$?
-- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
-- test $ac_status = 0; }; then
-- pkg_cv_CAIRO_FT_LIBS=`$PKG_CONFIG --libs "cairo-ft" 2>/dev/null`
--else
-- pkg_failed=yes
--fi
-- fi
--else
-- pkg_failed=untried
--fi
--
--
--
--if test $pkg_failed = yes; then
--
--if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
-- _pkg_short_errors_supported=yes
--else
-- _pkg_short_errors_supported=no
--fi
-- if test $_pkg_short_errors_supported = yes; then
-- CAIRO_FT_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "cairo-ft"`
-- else
-- CAIRO_FT_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "cairo-ft"`
-- fi
-- # Put the nasty error message in config.log where it belongs
-- echo "$CAIRO_FT_PKG_ERRORS" >&5
--
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
--$as_echo "no" >&6; }
-- have_cairo_ft=false
--elif test $pkg_failed = untried; then
-- have_cairo_ft=false
--else
-- CAIRO_FT_CFLAGS=$pkg_cv_CAIRO_FT_CFLAGS
-- CAIRO_FT_LIBS=$pkg_cv_CAIRO_FT_LIBS
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
--$as_echo "yes" >&6; }
-- have_cairo_ft=true
--fi
--if $have_cairo_ft; then
--
--$as_echo "#define HAVE_CAIRO_FT 1" >>confdefs.h
--
--fi
-- if $have_cairo_ft; then
-- HAVE_CAIRO_FT_TRUE=
-- HAVE_CAIRO_FT_FALSE='#'
--else
- HAVE_CAIRO_FT_TRUE='#'
- HAVE_CAIRO_FT_FALSE=
--fi
--
--
--
--
--pkg_failed=no
--{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for ICU" >&5
--$as_echo_n "checking for ICU... " >&6; }
--
--if test -n "$PKG_CONFIG"; then
-- if test -n "$ICU_CFLAGS"; then
-- pkg_cv_ICU_CFLAGS="$ICU_CFLAGS"
-- else
-- if test -n "$PKG_CONFIG" && \
-- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"icu-uc\""; } >&5
-- ($PKG_CONFIG --exists --print-errors "icu-uc") 2>&5
-- ac_status=$?
-- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
-- test $ac_status = 0; }; then
-- pkg_cv_ICU_CFLAGS=`$PKG_CONFIG --cflags "icu-uc" 2>/dev/null`
--else
-- pkg_failed=yes
--fi
-- fi
--else
-- pkg_failed=untried
--fi
--if test -n "$PKG_CONFIG"; then
-- if test -n "$ICU_LIBS"; then
-- pkg_cv_ICU_LIBS="$ICU_LIBS"
-- else
-- if test -n "$PKG_CONFIG" && \
-- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"icu-uc\""; } >&5
-- ($PKG_CONFIG --exists --print-errors "icu-uc") 2>&5
-- ac_status=$?
-- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
-- test $ac_status = 0; }; then
-- pkg_cv_ICU_LIBS=`$PKG_CONFIG --libs "icu-uc" 2>/dev/null`
--else
-- pkg_failed=yes
--fi
-- fi
--else
-- pkg_failed=untried
--fi
--
--
--
--if test $pkg_failed = yes; then
--
--if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
-- _pkg_short_errors_supported=yes
--else
-- _pkg_short_errors_supported=no
--fi
-- if test $_pkg_short_errors_supported = yes; then
-- ICU_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "icu-uc"`
-- else
-- ICU_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "icu-uc"`
-- fi
-- # Put the nasty error message in config.log where it belongs
-- echo "$ICU_PKG_ERRORS" >&5
--
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
--$as_echo "no" >&6; }
-- have_icu=false
--elif test $pkg_failed = untried; then
-- have_icu=false
--else
-- ICU_CFLAGS=$pkg_cv_ICU_CFLAGS
-- ICU_LIBS=$pkg_cv_ICU_LIBS
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
--$as_echo "yes" >&6; }
-- have_icu=true
--fi
--if test "$have_icu" != "true"; then
-- if test -n "$ac_tool_prefix"; then
-- # Extract the first word of "${ac_tool_prefix}icu-config", so it can be a program name with args.
--set dummy ${ac_tool_prefix}icu-config; ac_word=$2
--{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
--$as_echo_n "checking for $ac_word... " >&6; }
--if ${ac_cv_prog_ICU_CONFIG+:} false; then :
-- $as_echo_n "(cached) " >&6
--else
-- if test -n "$ICU_CONFIG"; then
-- ac_cv_prog_ICU_CONFIG="$ICU_CONFIG" # Let the user override the test.
--else
--as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
--for as_dir in $PATH
--do
-- IFS=$as_save_IFS
-- test -z "$as_dir" && as_dir=.
-- for ac_exec_ext in '' $ac_executable_extensions; do
-- if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
-- ac_cv_prog_ICU_CONFIG="${ac_tool_prefix}icu-config"
-- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
-- break 2
-- fi
--done
-- done
--IFS=$as_save_IFS
--
--fi
--fi
--ICU_CONFIG=$ac_cv_prog_ICU_CONFIG
--if test -n "$ICU_CONFIG"; then
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ICU_CONFIG" >&5
--$as_echo "$ICU_CONFIG" >&6; }
--else
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
--$as_echo "no" >&6; }
--fi
--
--
--fi
--if test -z "$ac_cv_prog_ICU_CONFIG"; then
-- ac_ct_ICU_CONFIG=$ICU_CONFIG
-- # Extract the first word of "icu-config", so it can be a program name with args.
--set dummy icu-config; ac_word=$2
--{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
--$as_echo_n "checking for $ac_word... " >&6; }
--if ${ac_cv_prog_ac_ct_ICU_CONFIG+:} false; then :
-- $as_echo_n "(cached) " >&6
--else
-- if test -n "$ac_ct_ICU_CONFIG"; then
-- ac_cv_prog_ac_ct_ICU_CONFIG="$ac_ct_ICU_CONFIG" # Let the user override the test.
--else
--as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
--for as_dir in $PATH
--do
-- IFS=$as_save_IFS
-- test -z "$as_dir" && as_dir=.
-- for ac_exec_ext in '' $ac_executable_extensions; do
-- if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
-- ac_cv_prog_ac_ct_ICU_CONFIG="icu-config"
-- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
-- break 2
-- fi
--done
-- done
--IFS=$as_save_IFS
--
--fi
--fi
--ac_ct_ICU_CONFIG=$ac_cv_prog_ac_ct_ICU_CONFIG
--if test -n "$ac_ct_ICU_CONFIG"; then
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_ct_ICU_CONFIG" >&5
--$as_echo "$ac_ct_ICU_CONFIG" >&6; }
--else
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
--$as_echo "no" >&6; }
--fi
--
-- if test "x$ac_ct_ICU_CONFIG" = x; then
-- ICU_CONFIG="no"
-- else
-- case $cross_compiling:$ac_tool_warned in
--yes:)
--{ $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: using cross tools not prefixed with host triplet" >&5
--$as_echo "$as_me: WARNING: using cross tools not prefixed with host triplet" >&2;}
--ac_tool_warned=yes ;;
--esac
-- ICU_CONFIG=$ac_ct_ICU_CONFIG
-- fi
--else
-- ICU_CONFIG="$ac_cv_prog_ICU_CONFIG"
--fi
--
-- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for ICU by using icu-config fallback" >&5
--$as_echo_n "checking for ICU by using icu-config fallback... " >&6; }
-- if test "$ICU_CONFIG" != "no" && "$ICU_CONFIG" --version >/dev/null; then
-- have_icu=true
-- # We don't use --cflags as this gives us a lot of things that we don't
-- # necessarily want, like debugging and optimization flags
-- # See man (1) icu-config for more info.
-- ICU_CFLAGS=`$ICU_CONFIG --cppflags`
-- ICU_LIBS=`$ICU_CONFIG --ldflags-libsonly`
-
-
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
--$as_echo "yes" >&6; }
-- else
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
--$as_echo "no" >&6; }
-- fi
--fi
-
--if $have_icu; then
-- CXXFLAGS="$CXXFLAGS `$PKG_CONFIG --variable=CXXFLAGS icu-uc`"
-
--$as_echo "#define HAVE_ICU 1" >>confdefs.h
--
--fi
-- if $have_icu; then
-- HAVE_ICU_TRUE=
-- HAVE_ICU_FALSE='#'
--else
- HAVE_ICU_TRUE='#'
- HAVE_ICU_FALSE=
--fi
--
--
--
--
--pkg_failed=no
--{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for ICU_LE" >&5
--$as_echo_n "checking for ICU_LE... " >&6; }
--
--if test -n "$PKG_CONFIG"; then
-- if test -n "$ICU_LE_CFLAGS"; then
-- pkg_cv_ICU_LE_CFLAGS="$ICU_LE_CFLAGS"
-- else
-- if test -n "$PKG_CONFIG" && \
-- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"icu-le icu-uc\""; } >&5
-- ($PKG_CONFIG --exists --print-errors "icu-le icu-uc") 2>&5
-- ac_status=$?
-- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
-- test $ac_status = 0; }; then
-- pkg_cv_ICU_LE_CFLAGS=`$PKG_CONFIG --cflags "icu-le icu-uc" 2>/dev/null`
--else
-- pkg_failed=yes
--fi
-- fi
--else
-- pkg_failed=untried
--fi
--if test -n "$PKG_CONFIG"; then
-- if test -n "$ICU_LE_LIBS"; then
-- pkg_cv_ICU_LE_LIBS="$ICU_LE_LIBS"
-- else
-- if test -n "$PKG_CONFIG" && \
-- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"icu-le icu-uc\""; } >&5
-- ($PKG_CONFIG --exists --print-errors "icu-le icu-uc") 2>&5
-- ac_status=$?
-- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
-- test $ac_status = 0; }; then
-- pkg_cv_ICU_LE_LIBS=`$PKG_CONFIG --libs "icu-le icu-uc" 2>/dev/null`
--else
-- pkg_failed=yes
--fi
-- fi
--else
-- pkg_failed=untried
--fi
--
-
-
--if test $pkg_failed = yes; then
-
--if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
-- _pkg_short_errors_supported=yes
--else
-- _pkg_short_errors_supported=no
--fi
-- if test $_pkg_short_errors_supported = yes; then
-- ICU_LE_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "icu-le icu-uc"`
-- else
-- ICU_LE_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "icu-le icu-uc"`
-- fi
-- # Put the nasty error message in config.log where it belongs
-- echo "$ICU_LE_PKG_ERRORS" >&5
-
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
--$as_echo "no" >&6; }
-- have_icu_le=false
--elif test $pkg_failed = untried; then
-- have_icu_le=false
--else
-- ICU_LE_CFLAGS=$pkg_cv_ICU_LE_CFLAGS
-- ICU_LE_LIBS=$pkg_cv_ICU_LE_LIBS
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
--$as_echo "yes" >&6; }
-- have_icu_le=true
--fi
--if test "$have_icu_le" != "true"; then
-- if test -n "$ac_tool_prefix"; then
-- # Extract the first word of "${ac_tool_prefix}icu-config", so it can be a program name with args.
--set dummy ${ac_tool_prefix}icu-config; ac_word=$2
--{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
--$as_echo_n "checking for $ac_word... " >&6; }
--if ${ac_cv_prog_ICU_CONFIG+:} false; then :
-- $as_echo_n "(cached) " >&6
--else
-- if test -n "$ICU_CONFIG"; then
-- ac_cv_prog_ICU_CONFIG="$ICU_CONFIG" # Let the user override the test.
--else
--as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
--for as_dir in $PATH
--do
-- IFS=$as_save_IFS
-- test -z "$as_dir" && as_dir=.
-- for ac_exec_ext in '' $ac_executable_extensions; do
-- if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
-- ac_cv_prog_ICU_CONFIG="${ac_tool_prefix}icu-config"
-- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
-- break 2
-- fi
--done
-- done
--IFS=$as_save_IFS
--
--fi
--fi
--ICU_CONFIG=$ac_cv_prog_ICU_CONFIG
--if test -n "$ICU_CONFIG"; then
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ICU_CONFIG" >&5
--$as_echo "$ICU_CONFIG" >&6; }
--else
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
--$as_echo "no" >&6; }
--fi
--
--
--fi
--if test -z "$ac_cv_prog_ICU_CONFIG"; then
-- ac_ct_ICU_CONFIG=$ICU_CONFIG
-- # Extract the first word of "icu-config", so it can be a program name with args.
--set dummy icu-config; ac_word=$2
--{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for $ac_word" >&5
--$as_echo_n "checking for $ac_word... " >&6; }
--if ${ac_cv_prog_ac_ct_ICU_CONFIG+:} false; then :
-- $as_echo_n "(cached) " >&6
--else
-- if test -n "$ac_ct_ICU_CONFIG"; then
-- ac_cv_prog_ac_ct_ICU_CONFIG="$ac_ct_ICU_CONFIG" # Let the user override the test.
--else
--as_save_IFS=$IFS; IFS=$PATH_SEPARATOR
--for as_dir in $PATH
--do
-- IFS=$as_save_IFS
-- test -z "$as_dir" && as_dir=.
-- for ac_exec_ext in '' $ac_executable_extensions; do
-- if { test -f "$as_dir/$ac_word$ac_exec_ext" && $as_test_x "$as_dir/$ac_word$ac_exec_ext"; }; then
-- ac_cv_prog_ac_ct_ICU_CONFIG="icu-config"
-- $as_echo "$as_me:${as_lineno-$LINENO}: found $as_dir/$ac_word$ac_exec_ext" >&5
-- break 2
-- fi
--done
-- done
--IFS=$as_save_IFS
--
--fi
--fi
--ac_ct_ICU_CONFIG=$ac_cv_prog_ac_ct_ICU_CONFIG
--if test -n "$ac_ct_ICU_CONFIG"; then
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: $ac_ct_ICU_CONFIG" >&5
--$as_echo "$ac_ct_ICU_CONFIG" >&6; }
--else
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
--$as_echo "no" >&6; }
--fi
--
-- if test "x$ac_ct_ICU_CONFIG" = x; then
-- ICU_CONFIG="no"
-- else
-- case $cross_compiling:$ac_tool_warned in
--yes:)
--{ $as_echo "$as_me:${as_lineno-$LINENO}: WARNING: using cross tools not prefixed with host triplet" >&5
--$as_echo "$as_me: WARNING: using cross tools not prefixed with host triplet" >&2;}
--ac_tool_warned=yes ;;
--esac
-- ICU_CONFIG=$ac_ct_ICU_CONFIG
-- fi
--else
-- ICU_CONFIG="$ac_cv_prog_ICU_CONFIG"
--fi
--
-- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for ICU_LE by using icu-config fallback" >&5
--$as_echo_n "checking for ICU_LE by using icu-config fallback... " >&6; }
-- if test "$ICU_CONFIG" != "no" && "$ICU_CONFIG" --version >/dev/null; then
-- have_icu_le=true
-- # We don't use --cflags as this gives us a lot of things that we don't
-- # necessarily want, like debugging and optimization flags
-- # See man (1) icu-config for more info.
-- ICU_LE_CFLAGS=`$ICU_CONFIG --cppflags`
-- ICU_LE_LIBS=`$ICU_CONFIG --ldflags-libsonly --ldflags-layout`
--
--
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
--$as_echo "yes" >&6; }
-- else
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
--$as_echo "no" >&6; }
-- fi
--fi
--if $have_icu_le; then
--
--$as_echo "#define HAVE_ICU_LE 1" >>confdefs.h
--
--fi
-- if $have_icu_le; then
-- HAVE_ICU_LE_TRUE=
-- HAVE_ICU_LE_FALSE='#'
--else
- HAVE_ICU_LE_TRUE='#'
- HAVE_ICU_LE_FALSE=
--fi
--
-
-
-
--pkg_failed=no
--{ $as_echo "$as_me:${as_lineno-$LINENO}: checking for GRAPHITE2" >&5
--$as_echo_n "checking for GRAPHITE2... " >&6; }
-
--if test -n "$PKG_CONFIG"; then
-- if test -n "$GRAPHITE2_CFLAGS"; then
-- pkg_cv_GRAPHITE2_CFLAGS="$GRAPHITE2_CFLAGS"
-- else
-- if test -n "$PKG_CONFIG" && \
-- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"graphite2\""; } >&5
-- ($PKG_CONFIG --exists --print-errors "graphite2") 2>&5
-- ac_status=$?
-- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
-- test $ac_status = 0; }; then
-- pkg_cv_GRAPHITE2_CFLAGS=`$PKG_CONFIG --cflags "graphite2" 2>/dev/null`
--else
-- pkg_failed=yes
--fi
-- fi
--else
-- pkg_failed=untried
--fi
--if test -n "$PKG_CONFIG"; then
-- if test -n "$GRAPHITE2_LIBS"; then
-- pkg_cv_GRAPHITE2_LIBS="$GRAPHITE2_LIBS"
-- else
-- if test -n "$PKG_CONFIG" && \
-- { { $as_echo "$as_me:${as_lineno-$LINENO}: \$PKG_CONFIG --exists --print-errors \"graphite2\""; } >&5
-- ($PKG_CONFIG --exists --print-errors "graphite2") 2>&5
-- ac_status=$?
-- $as_echo "$as_me:${as_lineno-$LINENO}: \$? = $ac_status" >&5
-- test $ac_status = 0; }; then
-- pkg_cv_GRAPHITE2_LIBS=`$PKG_CONFIG --libs "graphite2" 2>/dev/null`
--else
-- pkg_failed=yes
--fi
-- fi
--else
-- pkg_failed=untried
--fi
--
--
--
--if test $pkg_failed = yes; then
--
--if $PKG_CONFIG --atleast-pkgconfig-version 0.20; then
-- _pkg_short_errors_supported=yes
--else
-- _pkg_short_errors_supported=no
--fi
-- if test $_pkg_short_errors_supported = yes; then
-- GRAPHITE2_PKG_ERRORS=`$PKG_CONFIG --short-errors --errors-to-stdout --print-errors "graphite2"`
-- else
-- GRAPHITE2_PKG_ERRORS=`$PKG_CONFIG --errors-to-stdout --print-errors "graphite2"`
-- fi
-- # Put the nasty error message in config.log where it belongs
-- echo "$GRAPHITE2_PKG_ERRORS" >&5
--
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
--$as_echo "no" >&6; }
-- have_graphite=false
--elif test $pkg_failed = untried; then
-- have_graphite=false
--else
-- GRAPHITE2_CFLAGS=$pkg_cv_GRAPHITE2_CFLAGS
-- GRAPHITE2_LIBS=$pkg_cv_GRAPHITE2_LIBS
-- { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
--$as_echo "yes" >&6; }
-- have_graphite=true
--fi
--if $have_graphite; then
--
--$as_echo "#define HAVE_GRAPHITE2 1" >>confdefs.h
--
--fi
-- if $have_graphite; then
-- HAVE_GRAPHITE2_TRUE=
-- HAVE_GRAPHITE2_FALSE='#'
--else
- HAVE_GRAPHITE2_TRUE='#'
- HAVE_GRAPHITE2_FALSE=
--fi
-
-
-
diff --git a/print/harfbuzz/pkg-plist b/print/harfbuzz/pkg-plist
index 8f3d80f69da1..13f04ecf1ce1 100644
--- a/print/harfbuzz/pkg-plist
+++ b/print/harfbuzz/pkg-plist
@@ -1,5 +1,6 @@
bin/hb-ot-shape-closure
bin/hb-shape
+bin/hb-view
include/harfbuzz/hb-blob.h
include/harfbuzz/hb-buffer.h
include/harfbuzz/hb-common.h
@@ -7,6 +8,8 @@ include/harfbuzz/hb-font.h
include/harfbuzz/hb-ft.h
include/harfbuzz/hb-glib.h
include/harfbuzz/hb-gobject.h
+include/harfbuzz/hb-graphite2.h
+include/harfbuzz/hb-icu.h
include/harfbuzz/hb-ot-layout.h
include/harfbuzz/hb-ot-tag.h
include/harfbuzz/hb-ot.h