aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2016-08-24 16:20:31 +0800
committertcberner <tcberner@FreeBSD.org>2016-08-24 16:20:31 +0800
commita5fddeafcdb2cab1016827038e317a262dad4857 (patch)
treeb9dc00f333e96550a5732b38b9c9444035e4339c /print
parent3832b190ef3ea2bbefdd61450bff8af422a2e9ae (diff)
downloadfreebsd-ports-gnome-a5fddeafcdb2cab1016827038e317a262dad4857.tar.gz
freebsd-ports-gnome-a5fddeafcdb2cab1016827038e317a262dad4857.tar.zst
freebsd-ports-gnome-a5fddeafcdb2cab1016827038e317a262dad4857.zip
Replace Mk/bsd.kde4.mk by Mk/Uses/kde.mk in preparation for KDE Frameworks and
Plasma5 ports At the moment KDE ports use bsd.kde4.mk to handle their dependencies. When working on the ports for KDE Frameworks and Plasma5 it seemed to be more reasonable to create a new kde.mk instead of adding an bsd.kde5.mk. The kde.mk in this review is a stripped down version of the one we are using in the KDE Test repositories plasma5 branch [1] to only contain the parts relevant to the current KDE4 ports in the portstree [2]. Changes to the KDE Ports needed by this: Replace USE_KDE4 by USE_KDE [3] Add USES=kde:4 [4] [1] http://src.mouf.net/area51/view/branches/plasma5/KDE/Mk/Uses/kde.mk [2] The version in the plasma5 branch also handles frameworks/plasma5 and handles MASTER_SITES via a KDE_DIST variable similar to bsd.qt.mk for Qt Ports -- I chose to leave this out for now, as the diff is already large enough. [3] I chose USE_KDE instead of USE_KDE4, USE_KDE5, USE_KDEX as the version we want is already specified as argument to kde:<arg> [4] For KDE Frameworks and Plasma5 ports this would be kde:5 PR: 210667 Approved by: portmgr, mat (mentor), rakuco (mentor) Reviewed by: mat, rakuco Differential Revision: https://reviews.freebsd.org/D6961
Diffstat (limited to 'print')
-rw-r--r--print/frescobaldi/Makefile4
-rw-r--r--print/kde4-print-manager/Makefile4
-rw-r--r--print/kover/Makefile4
3 files changed, 6 insertions, 6 deletions
diff --git a/print/frescobaldi/Makefile b/print/frescobaldi/Makefile
index f9e8651960bd..a9e0b2a65274 100644
--- a/print/frescobaldi/Makefile
+++ b/print/frescobaldi/Makefile
@@ -16,9 +16,9 @@ LICENSE_COMB= dual
RUN_DEPENDS= lilypond:print/lilypond \
${PYTHON_PKGNAMEPREFIX}poppler-qt4>=0:graphics/py-poppler-qt4
-USES= gettext python
+USES= gettext kde:4 python
INSTALLS_ICONS= yes
-USE_KDE4= kdelibs pykde4_build pykde4_run
+USE_KDE= kdelibs pykde4_build pykde4_run
USE_PYTHON= distutils autoplist
post-patch:
diff --git a/print/kde4-print-manager/Makefile b/print/kde4-print-manager/Makefile
index 400b66d55c70..9d758127fb26 100644
--- a/print/kde4-print-manager/Makefile
+++ b/print/kde4-print-manager/Makefile
@@ -12,8 +12,8 @@ COMMENT= Printer manager for KDE 4
LIB_DEPENDS= libcups.so:print/cups
-USES= cmake:outsource tar:xz
-USE_KDE4= kdelibs automoc4
+USES= cmake:outsource kde:4 tar:xz
+USE_KDE= kdelibs automoc4
USE_QT4= designer network \
qmake_build moc_build uic_build rcc_build
diff --git a/print/kover/Makefile b/print/kover/Makefile
index 73e696ab80fb..941d19118427 100644
--- a/print/kover/Makefile
+++ b/print/kover/Makefile
@@ -16,11 +16,11 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libcddb.so:audio/libcddb \
libcdio.so:sysutils/libcdio
-USE_KDE4= automoc4 kdelibs
+USES= cmake gettext kde:4 perl5 pkgconfig shared-mime-info tar:bzip2
+USE_KDE= automoc4 kdelibs
USE_QT4= corelib dbus gui network svg xml \
qmake_build uic_build rcc_build
USE_PERL5= build
-USES= cmake gettext perl5 pkgconfig shared-mime-info tar:bzip2
post-patch:
@${REINPLACE_CMD} -e \