aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorgreen <green@FreeBSD.org>2004-02-26 02:43:30 +0800
committergreen <green@FreeBSD.org>2004-02-26 02:43:30 +0800
commitf4595eb4c54c546245c51bee63524e547e1b6d40 (patch)
treee9ce78acf40224a9dc02aa9f0c3e0159167041be /print
parent87436c0f79380b2367e81ae10de23c92a850e448 (diff)
downloadfreebsd-ports-gnome-f4595eb4c54c546245c51bee63524e547e1b6d40.tar.gz
freebsd-ports-gnome-f4595eb4c54c546245c51bee63524e547e1b6d40.tar.zst
freebsd-ports-gnome-f4595eb4c54c546245c51bee63524e547e1b6d40.zip
(Purportedly) unbreak installation as per some of the responses in the
PR. I don't see it on my -CURRENT system, but this doesn't break it, either. PR: 62405
Diffstat (limited to 'print')
-rw-r--r--print/lyx-devel/Makefile4
-rw-r--r--print/lyx-devel/files/patch-lib::Makefile.am15
-rw-r--r--print/lyx/Makefile4
-rw-r--r--print/lyx/files/patch-lib::Makefile.am15
-rw-r--r--print/lyx14/Makefile4
-rw-r--r--print/lyx14/files/patch-lib::Makefile.am15
-rw-r--r--print/lyx15/Makefile4
-rw-r--r--print/lyx15/files/patch-lib::Makefile.am15
-rw-r--r--print/lyx16/Makefile4
-rw-r--r--print/lyx16/files/patch-lib::Makefile.am15
10 files changed, 75 insertions, 20 deletions
diff --git a/print/lyx-devel/Makefile b/print/lyx-devel/Makefile
index 42bff52c5127..bb129cac0586 100644
--- a/print/lyx-devel/Makefile
+++ b/print/lyx-devel/Makefile
@@ -21,10 +21,6 @@ BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
latex:${PORTSDIR}/print/teTeX
-BROKEN= "Does not install"
-DEPRECATED= ${BROKEN}
-EXPIRATION_DATE=2004-04-16
-
USE_BZIP2= yes
USE_GETTEXT= yes
USE_PERL5= yes
diff --git a/print/lyx-devel/files/patch-lib::Makefile.am b/print/lyx-devel/files/patch-lib::Makefile.am
new file mode 100644
index 000000000000..af7f86f7831e
--- /dev/null
+++ b/print/lyx-devel/files/patch-lib::Makefile.am
@@ -0,0 +1,15 @@
+--- lib/Makefile.am.orig Wed Sep 17 15:13:05 2003
++++ lib/Makefile.am Wed Feb 18 18:24:39 2004
+@@ -58,8 +58,10 @@
+ ln -f -s `kpsewhich $$i` $(DESTDIR)$(pkgdatadir)/xfonts/$$i ; \
+ done ; \
+ $(INSTALL_DATA) xfonts/fonts.dir $(DESTDIR)$(pkgdatadir)/xfonts/fonts.dir ; \
+- $(INSTALL_DATA) xfonts/fonts.scale $(DESTDIR)$(pkgdatadir)/xfonts/fonts.scale
+- test -f xfonts/PSres.upr && $(INSTALL_DATA) xfonts/PSres.upr $(DESTDIR)$(pkgdatadir)/xfonts/PSres.upr
++ $(INSTALL_DATA) xfonts/fonts.scale $(DESTDIR)$(pkgdatadir)/xfonts/fonts.scale ;
++ if test -f xfonts/PSres.upr ; then
++ $(INSTALL_DATA) xfonts/PSres.upr $(DESTDIR)$(pkgdatadir)/xfonts/PSres.upr ;
++ fi
+
+ uninstall-xfonts:
+ rm -rf $(DESTDIR)$(pkgdatadir)/xfonts
diff --git a/print/lyx/Makefile b/print/lyx/Makefile
index 42bff52c5127..bb129cac0586 100644
--- a/print/lyx/Makefile
+++ b/print/lyx/Makefile
@@ -21,10 +21,6 @@ BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
latex:${PORTSDIR}/print/teTeX
-BROKEN= "Does not install"
-DEPRECATED= ${BROKEN}
-EXPIRATION_DATE=2004-04-16
-
USE_BZIP2= yes
USE_GETTEXT= yes
USE_PERL5= yes
diff --git a/print/lyx/files/patch-lib::Makefile.am b/print/lyx/files/patch-lib::Makefile.am
new file mode 100644
index 000000000000..af7f86f7831e
--- /dev/null
+++ b/print/lyx/files/patch-lib::Makefile.am
@@ -0,0 +1,15 @@
+--- lib/Makefile.am.orig Wed Sep 17 15:13:05 2003
++++ lib/Makefile.am Wed Feb 18 18:24:39 2004
+@@ -58,8 +58,10 @@
+ ln -f -s `kpsewhich $$i` $(DESTDIR)$(pkgdatadir)/xfonts/$$i ; \
+ done ; \
+ $(INSTALL_DATA) xfonts/fonts.dir $(DESTDIR)$(pkgdatadir)/xfonts/fonts.dir ; \
+- $(INSTALL_DATA) xfonts/fonts.scale $(DESTDIR)$(pkgdatadir)/xfonts/fonts.scale
+- test -f xfonts/PSres.upr && $(INSTALL_DATA) xfonts/PSres.upr $(DESTDIR)$(pkgdatadir)/xfonts/PSres.upr
++ $(INSTALL_DATA) xfonts/fonts.scale $(DESTDIR)$(pkgdatadir)/xfonts/fonts.scale ;
++ if test -f xfonts/PSres.upr ; then
++ $(INSTALL_DATA) xfonts/PSres.upr $(DESTDIR)$(pkgdatadir)/xfonts/PSres.upr ;
++ fi
+
+ uninstall-xfonts:
+ rm -rf $(DESTDIR)$(pkgdatadir)/xfonts
diff --git a/print/lyx14/Makefile b/print/lyx14/Makefile
index 42bff52c5127..bb129cac0586 100644
--- a/print/lyx14/Makefile
+++ b/print/lyx14/Makefile
@@ -21,10 +21,6 @@ BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
latex:${PORTSDIR}/print/teTeX
-BROKEN= "Does not install"
-DEPRECATED= ${BROKEN}
-EXPIRATION_DATE=2004-04-16
-
USE_BZIP2= yes
USE_GETTEXT= yes
USE_PERL5= yes
diff --git a/print/lyx14/files/patch-lib::Makefile.am b/print/lyx14/files/patch-lib::Makefile.am
new file mode 100644
index 000000000000..af7f86f7831e
--- /dev/null
+++ b/print/lyx14/files/patch-lib::Makefile.am
@@ -0,0 +1,15 @@
+--- lib/Makefile.am.orig Wed Sep 17 15:13:05 2003
++++ lib/Makefile.am Wed Feb 18 18:24:39 2004
+@@ -58,8 +58,10 @@
+ ln -f -s `kpsewhich $$i` $(DESTDIR)$(pkgdatadir)/xfonts/$$i ; \
+ done ; \
+ $(INSTALL_DATA) xfonts/fonts.dir $(DESTDIR)$(pkgdatadir)/xfonts/fonts.dir ; \
+- $(INSTALL_DATA) xfonts/fonts.scale $(DESTDIR)$(pkgdatadir)/xfonts/fonts.scale
+- test -f xfonts/PSres.upr && $(INSTALL_DATA) xfonts/PSres.upr $(DESTDIR)$(pkgdatadir)/xfonts/PSres.upr
++ $(INSTALL_DATA) xfonts/fonts.scale $(DESTDIR)$(pkgdatadir)/xfonts/fonts.scale ;
++ if test -f xfonts/PSres.upr ; then
++ $(INSTALL_DATA) xfonts/PSres.upr $(DESTDIR)$(pkgdatadir)/xfonts/PSres.upr ;
++ fi
+
+ uninstall-xfonts:
+ rm -rf $(DESTDIR)$(pkgdatadir)/xfonts
diff --git a/print/lyx15/Makefile b/print/lyx15/Makefile
index 42bff52c5127..bb129cac0586 100644
--- a/print/lyx15/Makefile
+++ b/print/lyx15/Makefile
@@ -21,10 +21,6 @@ BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
latex:${PORTSDIR}/print/teTeX
-BROKEN= "Does not install"
-DEPRECATED= ${BROKEN}
-EXPIRATION_DATE=2004-04-16
-
USE_BZIP2= yes
USE_GETTEXT= yes
USE_PERL5= yes
diff --git a/print/lyx15/files/patch-lib::Makefile.am b/print/lyx15/files/patch-lib::Makefile.am
new file mode 100644
index 000000000000..af7f86f7831e
--- /dev/null
+++ b/print/lyx15/files/patch-lib::Makefile.am
@@ -0,0 +1,15 @@
+--- lib/Makefile.am.orig Wed Sep 17 15:13:05 2003
++++ lib/Makefile.am Wed Feb 18 18:24:39 2004
+@@ -58,8 +58,10 @@
+ ln -f -s `kpsewhich $$i` $(DESTDIR)$(pkgdatadir)/xfonts/$$i ; \
+ done ; \
+ $(INSTALL_DATA) xfonts/fonts.dir $(DESTDIR)$(pkgdatadir)/xfonts/fonts.dir ; \
+- $(INSTALL_DATA) xfonts/fonts.scale $(DESTDIR)$(pkgdatadir)/xfonts/fonts.scale
+- test -f xfonts/PSres.upr && $(INSTALL_DATA) xfonts/PSres.upr $(DESTDIR)$(pkgdatadir)/xfonts/PSres.upr
++ $(INSTALL_DATA) xfonts/fonts.scale $(DESTDIR)$(pkgdatadir)/xfonts/fonts.scale ;
++ if test -f xfonts/PSres.upr ; then
++ $(INSTALL_DATA) xfonts/PSres.upr $(DESTDIR)$(pkgdatadir)/xfonts/PSres.upr ;
++ fi
+
+ uninstall-xfonts:
+ rm -rf $(DESTDIR)$(pkgdatadir)/xfonts
diff --git a/print/lyx16/Makefile b/print/lyx16/Makefile
index 42bff52c5127..bb129cac0586 100644
--- a/print/lyx16/Makefile
+++ b/print/lyx16/Makefile
@@ -21,10 +21,6 @@ BUILD_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
RUN_DEPENDS= gm4:${PORTSDIR}/devel/m4 \
latex:${PORTSDIR}/print/teTeX
-BROKEN= "Does not install"
-DEPRECATED= ${BROKEN}
-EXPIRATION_DATE=2004-04-16
-
USE_BZIP2= yes
USE_GETTEXT= yes
USE_PERL5= yes
diff --git a/print/lyx16/files/patch-lib::Makefile.am b/print/lyx16/files/patch-lib::Makefile.am
new file mode 100644
index 000000000000..af7f86f7831e
--- /dev/null
+++ b/print/lyx16/files/patch-lib::Makefile.am
@@ -0,0 +1,15 @@
+--- lib/Makefile.am.orig Wed Sep 17 15:13:05 2003
++++ lib/Makefile.am Wed Feb 18 18:24:39 2004
+@@ -58,8 +58,10 @@
+ ln -f -s `kpsewhich $$i` $(DESTDIR)$(pkgdatadir)/xfonts/$$i ; \
+ done ; \
+ $(INSTALL_DATA) xfonts/fonts.dir $(DESTDIR)$(pkgdatadir)/xfonts/fonts.dir ; \
+- $(INSTALL_DATA) xfonts/fonts.scale $(DESTDIR)$(pkgdatadir)/xfonts/fonts.scale
+- test -f xfonts/PSres.upr && $(INSTALL_DATA) xfonts/PSres.upr $(DESTDIR)$(pkgdatadir)/xfonts/PSres.upr
++ $(INSTALL_DATA) xfonts/fonts.scale $(DESTDIR)$(pkgdatadir)/xfonts/fonts.scale ;
++ if test -f xfonts/PSres.upr ; then
++ $(INSTALL_DATA) xfonts/PSres.upr $(DESTDIR)$(pkgdatadir)/xfonts/PSres.upr ;
++ fi
+
+ uninstall-xfonts:
+ rm -rf $(DESTDIR)$(pkgdatadir)/xfonts