aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2009-03-10 01:15:43 +0800
committerstas <stas@FreeBSD.org>2009-03-10 01:15:43 +0800
commit08bfa7c4aa027efa35afd531304e476e4f713b80 (patch)
tree31b7120f0eb5ff46ed252641018a5ff19ff41fc3 /print
parent982434000a36499258eff52f7032254355edca7a (diff)
downloadfreebsd-ports-gnome-08bfa7c4aa027efa35afd531304e476e4f713b80.tar.gz
freebsd-ports-gnome-08bfa7c4aa027efa35afd531304e476e4f713b80.tar.zst
freebsd-ports-gnome-08bfa7c4aa027efa35afd531304e476e4f713b80.zip
- Chase libusb20 rename in r189585.
- Mark sane-backends broken on current due to changes in USB stack. Reviewed by: thompsa (old version), miwi Tested by: miwi
Diffstat (limited to 'print')
-rw-r--r--print/hplip/Makefile5
-rw-r--r--print/hplip3/Makefile5
2 files changed, 8 insertions, 2 deletions
diff --git a/print/hplip/Makefile b/print/hplip/Makefile
index 78f07fc5d5e3..6078d44e9e0b 100644
--- a/print/hplip/Makefile
+++ b/print/hplip/Makefile
@@ -18,7 +18,6 @@ COMMENT= Drivers and utilities for HP Printers and All-in-One devices
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
sane.1:${PORTSDIR}/graphics/sane-backends \
cups.2:${PORTSDIR}/print/cups-base \
- usb:${PORTSDIR}/devel/libusb \
netsnmp.16:${PORTSDIR}/net-mgmt/net-snmp
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/reportlab/__init__.py:${PORTSDIR}/print/py-reportlab2 \
@@ -54,6 +53,10 @@ PLIST_SUB+= PORTVERSION=${PORTVERSION} IJSVER=2.7.4
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb:${PORTSDIR}/devel/libusb
+.endif
+
.if !defined(WITHOUT_GUI) || exists(${LOCALBASE}/bin/pylupdate)
RUN_DEPENDS+= pylupdate:${PORTSDIR}/x11-toolkits/py-qt
CONFIGURE_ARGS+= --enable-gui-build
diff --git a/print/hplip3/Makefile b/print/hplip3/Makefile
index 78f07fc5d5e3..6078d44e9e0b 100644
--- a/print/hplip3/Makefile
+++ b/print/hplip3/Makefile
@@ -18,7 +18,6 @@ COMMENT= Drivers and utilities for HP Printers and All-in-One devices
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
sane.1:${PORTSDIR}/graphics/sane-backends \
cups.2:${PORTSDIR}/print/cups-base \
- usb:${PORTSDIR}/devel/libusb \
netsnmp.16:${PORTSDIR}/net-mgmt/net-snmp
RUN_DEPENDS= ${PYTHON_SITELIBDIR}/reportlab/__init__.py:${PORTSDIR}/print/py-reportlab2 \
@@ -54,6 +53,10 @@ PLIST_SUB+= PORTVERSION=${PORTVERSION} IJSVER=2.7.4
.include <bsd.port.pre.mk>
+.if ${OSVERSION} < 800069
+LIB_DEPENDS+= usb:${PORTSDIR}/devel/libusb
+.endif
+
.if !defined(WITHOUT_GUI) || exists(${LOCALBASE}/bin/pylupdate)
RUN_DEPENDS+= pylupdate:${PORTSDIR}/x11-toolkits/py-qt
CONFIGURE_ARGS+= --enable-gui-build