aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2015-09-08 07:36:52 +0800
committerhrs <hrs@FreeBSD.org>2015-09-08 07:36:52 +0800
commit279f643d914ff0deb6760b5e7578c1511296c7e6 (patch)
tree14b458d70b380b8b48b5287f108408b14a46619f /print
parent0ea10ba6874f0d5ec37c6ea1355d74575b243143 (diff)
downloadfreebsd-ports-gnome-279f643d914ff0deb6760b5e7578c1511296c7e6.tar.gz
freebsd-ports-gnome-279f643d914ff0deb6760b5e7578c1511296c7e6.tar.zst
freebsd-ports-gnome-279f643d914ff0deb6760b5e7578c1511296c7e6.zip
- Split xpdfopen package from texlive-base. This is because it is the only
package depending on X11 library in it. - Remove unnecessary libttf.so dependency [*]. PR: 202910 [*]
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/texlive-base/Makefile16
-rw-r--r--print/texlive-base/pkg-plist4
-rw-r--r--print/xpdfopen/Makefile31
-rw-r--r--print/xpdfopen/distinfo4
-rw-r--r--print/xpdfopen/pkg-descr2
6 files changed, 47 insertions, 11 deletions
diff --git a/print/Makefile b/print/Makefile
index 580c3db59a09..0a220d33c57a 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -260,6 +260,7 @@
SUBDIR += utopia
SUBDIR += xfce4-print
SUBDIR += xmbibtex
+ SUBDIR += xpdfopen
SUBDIR += xpp
SUBDIR += xtexsh
SUBDIR += yatex
diff --git a/print/texlive-base/Makefile b/print/texlive-base/Makefile
index 2296cf8f53ab..161e7700cfeb 100644
--- a/print/texlive-base/Makefile
+++ b/print/texlive-base/Makefile
@@ -2,7 +2,7 @@
PORTNAME= texlive
PORTVERSION= 20150521
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= print
MASTER_SITES= TEX_CTAN/systems/texlive/Source/
PKGNAMESUFFIX= -base
@@ -20,7 +20,6 @@ LIB_DEPENDS= libicuio.so:${PORTSDIR}/devel/icu \
libgraphite2.so:${PORTSDIR}/graphics/graphite2 \
libfreetype.so:${PORTSDIR}/print/freetype2 \
libharfbuzz.so:${PORTSDIR}/print/harfbuzz \
- libttf.so:${PORTSDIR}/print/freetype \
libpng.so:${PORTSDIR}/graphics/png \
libzzip.so:${PORTSDIR}/devel/zziplib \
libpoppler.so:${PORTSDIR}/graphics/poppler \
@@ -31,7 +30,6 @@ CONFLICTS_INSTALL= texlive-texmf-201[234]*
USE_TEX= web2c kpathsea ptexenc tlmgr texhash-bootstrap
USES= ghostscript pkgconfig perl5 shebangfix tar:xz
USE_PERL5= run
-USE_XORG= x11 xmu
# during build phase gnu configure is run a lot
MAKE_ENV+= CONFIG_SITE=${CONFIG_SITE}
EXCLUDE_FILES= ${DISTNAME}/texk/web2c \
@@ -41,7 +39,8 @@ EXCLUDE_FILES= ${DISTNAME}/texk/web2c \
${DISTNAME}/texk/dvipdfm-x \
${DISTNAME}/texk/dvipsk \
${DISTNAME}/libs \
- ${DISTNAME}/utils/t1utils
+ ${DISTNAME}/utils/t1utils \
+ ${DISTNAME}/utils/xpdfopen
EXTRACT_AFTER_ARGS= ${EXCLUDE_FILES:S,^,--exclude ,}
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --disable-native-texlive-build \
@@ -52,11 +51,9 @@ CONFIGURE_ARGS= --disable-native-texlive-build \
--disable-dvipdfmx \
--disable-dvipdfm-x \
--disable-xdvipdfmx \
+ --disable-xpdfopen \
--enable-build-in-source-tree \
--datarootdir=${LOCALBASE}/share \
- --with-system-freetype \
- --with-freetype-includes=${LOCALBASE}/include/freetype1/freetype \
- --with-freetype-libdir=${LOCALBASE}/lib \
--with-system-freetype2 \
--with-freetype2-includes=${LOCALBASE}/include/freetype2 \
--with-freetype2-libdir=${LOCALBASE}/lib \
@@ -112,6 +109,11 @@ SHEBANG_FILES= texk/texlive/linked_scripts/accfonts/mkt1font \
INFO= dvipng tlbuild
+OPTIONS_DEFINE= X11
+OPTIONS_DEFAULT=X11
+
+X11_USE= TEX=xpdfopen:run
+
post-patch:
cd ${WRKSRC}/texk/texlive && \
${REINPLACE_CMD} -e 's,%%PREFIX%%,${PREFIX},' \
diff --git a/print/texlive-base/pkg-plist b/print/texlive-base/pkg-plist
index 1d141ade4361..a7817fb36ef7 100644
--- a/print/texlive-base/pkg-plist
+++ b/print/texlive-base/pkg-plist
@@ -159,7 +159,6 @@ bin/pdf90
bin/pdfannotextractor
bin/pdfatfi
bin/pdfbook
-bin/pdfclose
bin/pdfcrop
bin/pdfflip
bin/pdfjam
@@ -168,7 +167,6 @@ bin/pdfjam-slides3up
bin/pdfjam-slides6up
bin/pdfjoin
bin/pdfnup
-bin/pdfopen
bin/pdfpun
bin/pedigree
bin/perltex
@@ -299,8 +297,6 @@ man/man1/mmpfb.1.gz
man/man1/msxlint.1.gz
man/man1/otfinfo.1.gz
man/man1/otftotfm.1.gz
-man/man1/pdfclose.1.gz
-man/man1/pdfopen.1.gz
man/man1/pfb2pfa.1.gz
man/man1/pk2bm.1.gz
man/man1/pmxab.1.gz
diff --git a/print/xpdfopen/Makefile b/print/xpdfopen/Makefile
new file mode 100644
index 000000000000..a34a675c86a8
--- /dev/null
+++ b/print/xpdfopen/Makefile
@@ -0,0 +1,31 @@
+# $FreeBSD$
+
+PORTNAME= xpdfopen
+PORTVERSION= 0.86
+CATEGORIES= print
+MASTER_SITES= ftp://tug.org/historic/systems/texlive/2015/
+DISTNAME= texlive-${DISTVERSION_TEXLIVE_SOURCE}-source
+DIST_SUBDIR= TeX
+
+MAINTAINER= hrs@FreeBSD.org
+COMMENT= Command line utility for PDF viewers
+
+CONFLICTS= texlive-base-20150521_[1-4]
+
+USES= tar:xz
+USE_XORG= x11 xmu
+EXTRACT_AFTER_ARGS= ${EXTRACT_FILES:S,^,${DISTNAME}/,}
+EXTRACT_FILES= build-aux \
+ utils/xpdfopen
+DISTVERSION_TEXLIVE_SOURCE= 20150521
+WRKSRC= ${WRKDIR}/${DISTNAME}/utils/xpdfopen
+GNU_CONFIGURE= yes
+CFLAGS+= -I${LOCALBASE}/include
+LDFLAGS+= -L${LOCALBASE}/lib
+
+PLIST_FILES= bin/pdfclose \
+ bin/pdfopen \
+ man/man1/pdfclose.1.gz \
+ man/man1/pdfopen.1.gz
+
+.include <bsd.port.mk>
diff --git a/print/xpdfopen/distinfo b/print/xpdfopen/distinfo
new file mode 100644
index 000000000000..bf8979f82957
--- /dev/null
+++ b/print/xpdfopen/distinfo
@@ -0,0 +1,4 @@
+SHA256 (TeX/texlive-20150521-source.tar.xz) = ed9bcd7bdce899c3c27c16a8c5c3017c4f09e1d7fd097038351b72497e9d4669
+SIZE (TeX/texlive-20150521-source.tar.xz) = 45459552
+SHA256 (TeX/texlive-20150523-texmf.tar.xz) = 1efb2b55cbf7ef9a5d2093b31110191d3caac8d4668b413ad63e996e1ebb70a8
+SIZE (TeX/texlive-20150523-texmf.tar.xz) = 1892010092
diff --git a/print/xpdfopen/pkg-descr b/print/xpdfopen/pkg-descr
new file mode 100644
index 000000000000..e24dfd0a12b0
--- /dev/null
+++ b/print/xpdfopen/pkg-descr
@@ -0,0 +1,2 @@
+This is a X11 implementation of Fabrice Popineau's pdfclose/
+pdfopen commands to control Acrobat Reader, xpdf and evince.