aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authortcberner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
committertcberner <tcberner@FreeBSD.org>2018-06-29 01:39:53 +0800
commit2a8bcfc8ea71d4438b926a8adc477de360863145 (patch)
tree7b9785f1f0c244da1f5b69a2a610e3f37eb786a8 /print
parent62341874a942de5989d54a3ba471cb8719d251ee (diff)
downloadfreebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.tar.gz
freebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.tar.zst
freebsd-ports-gnome-2a8bcfc8ea71d4438b926a8adc477de360863145.zip
Replace bsd.qt.mk by Uses/qt.mk and Uses/qt-dist.mk
From now on, ports that depend on Qt4 will have to set USES= qt:4 USE_QT= foo bar ports depending on Qt5 will use USES= qt:5 USE_QT= foo bar PR: 229225 Exp-run by: antoine Reviewed by: mat Approved by: portmgr (antoine) Differential Revision: →https://reviews.freebsd.org/D15540
Diffstat (limited to 'print')
-rw-r--r--print/kover/Makefile4
-rw-r--r--print/kpdftool/Makefile4
-rw-r--r--print/lyx/Makefile4
-rw-r--r--print/print-manager-kde4/Makefile4
-rw-r--r--print/print-manager/Makefile4
-rw-r--r--print/py-qt5-printsupport/Makefile4
-rw-r--r--print/qpdfview/Makefile6
-rw-r--r--print/qt5-printsupport/Makefile4
-rw-r--r--print/scribus/Makefile4
9 files changed, 20 insertions, 18 deletions
diff --git a/print/kover/Makefile b/print/kover/Makefile
index a796a26732d9..76f559d44a21 100644
--- a/print/kover/Makefile
+++ b/print/kover/Makefile
@@ -16,9 +16,9 @@ LICENSE_FILE= ${WRKSRC}/COPYING
LIB_DEPENDS= libcddb.so:audio/libcddb \
libcdio.so:sysutils/libcdio
-USES= cmake gettext kde:4 perl5 pkgconfig shared-mime-info tar:bzip2
+USES= cmake gettext kde:4 perl5 pkgconfig qt:4 shared-mime-info tar:bzip2
USE_KDE= automoc4 kdelibs
-USE_QT4= corelib dbus gui network svg xml \
+USE_QT= corelib dbus gui network svg xml \
qmake_build uic_build rcc_build
USE_PERL5= build
diff --git a/print/kpdftool/Makefile b/print/kpdftool/Makefile
index 3797dac8a649..bef62e65c473 100644
--- a/print/kpdftool/Makefile
+++ b/print/kpdftool/Makefile
@@ -13,8 +13,8 @@ COMMENT= Simple utility to manipulate PS and PDF files
RUN_DEPENDS= convert:graphics/ImageMagick
-USE_QT4= qt3support moc_build porting_build uic3_build
-USES= ghostscript:run qmake zip
+USE_QT= qt3support moc_build porting_build uic3_build
+USES= ghostscript:run qmake qt:4 zip
DESKTOP_ENTRIES= "KPDFTool" "${COMMENT}" "kpdftool" \
"kpdftool" "Qt;Utility;" true
diff --git a/print/lyx/Makefile b/print/lyx/Makefile
index 406e000efd8c..b36219ed6e43 100644
--- a/print/lyx/Makefile
+++ b/print/lyx/Makefile
@@ -21,8 +21,8 @@ MAJOR_VERSION= 2.3
MINOR_VERSION= 0
USES= desktop-file-utils gmake iconv pkgconfig perl5 \
- python:2.7 shebangfix tar:xz
-USE_QT5= core concurrent gui svg widgets buildtools_build qmake_build
+ python:2.7 qt:5 shebangfix tar:xz
+USE_QT= core concurrent gui svg widgets buildtools_build qmake_build
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --without-included-boost \
--without-included-mythes \
diff --git a/print/print-manager-kde4/Makefile b/print/print-manager-kde4/Makefile
index 680068c3b93a..5655312b722e 100644
--- a/print/print-manager-kde4/Makefile
+++ b/print/print-manager-kde4/Makefile
@@ -11,9 +11,9 @@ COMMENT= Printer manager for KDE 4
LIB_DEPENDS= libcups.so:print/cups
RUN_DEPENDS= ${LOCALBASE}/share/cups/data/testprint:print/cups-filters
-USES= cmake:outsource kde:4 tar:xz
+USES= cmake:outsource kde:4 qt:4 tar:xz
USE_KDE= kdelibs automoc4
-USE_QT4= designer network \
+USE_QT= designer network \
qmake_build moc_build uic_build rcc_build
post-patch:
diff --git a/print/print-manager/Makefile b/print/print-manager/Makefile
index 752c2affc414..a6f2c33ec8b1 100644
--- a/print/print-manager/Makefile
+++ b/print/print-manager/Makefile
@@ -9,12 +9,12 @@ COMMENT= Printer manager for KDE
LIB_DEPENDS= libcups.so:print/cups
-USES= cmake:outsource gettext kde:5 tar:xz
+USES= cmake:outsource gettext kde:5 qt:5 tar:xz
USE_KDE= auth codecs completion config configwidgets coreaddons \
dbusaddons ecm i18n iconthemes itemviews jobwidgets kcmutils \
kio notifications plasma-framework service widgetsaddons \
windowsystem
-USE_QT5= core dbus gui network qml quick widgets xml \
+USE_QT= core dbus gui network qml quick widgets xml \
buildtools_build qmake_build
.include <bsd.port.mk>
diff --git a/print/py-qt5-printsupport/Makefile b/print/py-qt5-printsupport/Makefile
index d0ab1f5eadee..222194250914 100644
--- a/print/py-qt5-printsupport/Makefile
+++ b/print/py-qt5-printsupport/Makefile
@@ -10,11 +10,11 @@ COMMENT= Python bindings for the Qt5 toolkit, QtPrintSupport module
CONFIGURE_ARGS= --enable QtPrintSupport
PYQT_DIST= yes
-USES= python pyqt:5
+USES= python pyqt:5 qt:5
USE_GL= gl
USE_PYQT= sip_build core_run widgets_run
USE_PYTHON= flavors
-USE_QT5= core gui printsupport widgets qmake_build
+USE_QT= core gui printsupport widgets qmake_build
OPTIONS_DEFINE= API DEBUG
OPTIONS_DEFAULT=API
diff --git a/print/qpdfview/Makefile b/print/qpdfview/Makefile
index dc5c8369c2af..0323addc1c4b 100644
--- a/print/qpdfview/Makefile
+++ b/print/qpdfview/Makefile
@@ -34,10 +34,12 @@ CUPS_LIB_DEPENDS= libcups.so:print/cups
DJVU_LIB_DEPENDS= libdjvulibre.so:graphics/djvulibre
DJVU_QMAKE_OFF= "CONFIG+=without_djvu"
-QT4_USE= qt4=dbus,gui,imageformats,linguisttools,moc_build,rcc_build,sql,sql-sqlite3,svg,xml
+QT4_USES= qt:4
+QT4_USE= qt=dbus,gui,imageformats,linguisttools,moc_build,rcc_build,sql,sql-sqlite3,svg,xml
QT4_LIB_DEPENDS= libpoppler-qt4.so:graphics/poppler-qt4
-QT5_USE= qt5=buildtools_build,concurrent,imageformats,linguisttools,printsupport,sql,sql-sqlite3,svg,xml
+QT5_USES= qt:5
+QT5_USE= qt=buildtools_build,concurrent,imageformats,linguisttools,printsupport,sql,sql-sqlite3,svg,xml
QT5_LIB_DEPENDS= libpoppler-qt5.so:graphics/poppler-qt5
PS_LIB_DEPENDS= libspectre.so:print/libspectre
diff --git a/print/qt5-printsupport/Makefile b/print/qt5-printsupport/Makefile
index 924f001d2668..935ddbf304d1 100644
--- a/print/qt5-printsupport/Makefile
+++ b/print/qt5-printsupport/Makefile
@@ -8,8 +8,8 @@ PKGNAMEPREFIX= qt5-
MAINTAINER= kde@FreeBSD.org
COMMENT= Qt print support module
-USE_QT5= core gui widgets qmake_build buildtools_build
-QT_DIST= base
+USES= qmake:no_env qt-dist:5,base
+USE_QT= core gui widgets qmake_build buildtools_build
HAS_CONFIGURE= yes
USE_LDCONFIG= ${PREFIX}/${QT_LIBDIR_REL}
diff --git a/print/scribus/Makefile b/print/scribus/Makefile
index 21037c732cc7..da188f87d80b 100644
--- a/print/scribus/Makefile
+++ b/print/scribus/Makefile
@@ -30,8 +30,8 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}tkinter>0:x11-toolkits/py-tkinter@${PY_FLAVO
${PYTHON_PKGNAMEPREFIX}pillow>=0:graphics/py-pillow@${PY_FLAVOR}
USES= cmake:outsource desktop-file-utils ghostscript:run jpeg \
- pkgconfig python:2.7 shared-mime-info tar:xz
-USE_QT4= corelib gui linguist_build moc_build qmake_build rcc_build uic_build xml network
+ pkgconfig python:2.7 qt:4 shared-mime-info tar:xz
+USE_QT= corelib gui linguist_build moc_build qmake_build rcc_build uic_build xml network
USE_GNOME= libartlgpl2 libxml2
USE_LDCONFIG= yes