aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authoredwin <edwin@FreeBSD.org>2008-06-17 05:23:59 +0800
committeredwin <edwin@FreeBSD.org>2008-06-17 05:23:59 +0800
commit4b0f362908b7f326f8f301d1425280fe81d1587f (patch)
treee01e92366a10427623c491956c4b2ddbbbe0eefb /print
parentbe881c5756d6bf9b58bf2705ae2493d50a0784d9 (diff)
downloadfreebsd-ports-gnome-4b0f362908b7f326f8f301d1425280fe81d1587f.tar.gz
freebsd-ports-gnome-4b0f362908b7f326f8f301d1425280fe81d1587f.tar.zst
freebsd-ports-gnome-4b0f362908b7f326f8f301d1425280fe81d1587f.zip
[NEW PORT] print/latex-aa: LaTeX class for submission to "Astronomy and Astrophysics"
LaTeX2e class for submission to the scientific journal Astronomy and Astrophysics. In order to ensure the smoothest transition for both authors and publishers, Springer-Verlag has kindly granted EDP Sciences the permission to use the LaTeX macro package that they developed for A&A Main journal. Only minor changes have been incorporated between the Springer class (1999) and the EDP Sciences class for the new journal. WWW: http://www.edpsciences.org/ PR: ports/123652 Submitted by: Koji Yokota <yokota@res.otaru-uc.ac.jp>
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/latex-aa/Makefile50
-rw-r--r--print/latex-aa/distinfo3
-rw-r--r--print/latex-aa/pkg-descr12
-rw-r--r--print/latex-aa/pkg-plist11
5 files changed, 77 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index fff1882f16b9..6484e8b5b80d 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -132,6 +132,7 @@
SUBDIR += kover
SUBDIR += kpdftool
SUBDIR += latex
+ SUBDIR += latex-aa
SUBDIR += latex-arydshln
SUBDIR += latex-auto-greek
SUBDIR += latex-beamer
diff --git a/print/latex-aa/Makefile b/print/latex-aa/Makefile
new file mode 100644
index 000000000000..14b629d086d2
--- /dev/null
+++ b/print/latex-aa/Makefile
@@ -0,0 +1,50 @@
+# New ports collection makefile for: print/latex-aa
+# Date created: 13 November 2007
+# Whom: Koji Yokota (yokota@res.otaru-uc.ac.jp)
+#
+# $FreeBSD$
+#
+
+PORTNAME= latex-aa
+PORTVERSION= 6.1
+CATEGORIES= print astro science
+MASTER_SITES= ftp://ftp.edpsciences.org/pub/aa/
+DISTNAME= aa-package
+DIST_SUBDIR= latex
+
+MAINTAINER= yokota@res.otaru-uc.ac.jp
+COMMENT= LaTeX class for submission to "Astronomy and Astrophysics"
+
+BUILD_DEPENDS= ${LOCALBASE}/share/texmf:${PORTSDIR}/print/teTeX-texmf \
+ latex:${PORTSDIR}/print/teTeX-base \
+ dvips:${PORTSDIR}/print/dvipsk-tetex
+
+NO_BUILD= yes
+NO_WRKSUBDIR= yes
+
+USE_GHOSTSCRIPT_BUILD= yes
+TEXMFDIR= share/texmf
+AADIR= tex/latex/aa
+AABIBDIR= bibtex/bst/aa
+AADOCSDIR= doc/latex/aa
+DOCFILES= aa.dem aa.dvi aa.pdf aadoc.pdf readme.html readme.txt
+MKTEXLSR= ${LOCALBASE}/bin/mktexlsr
+
+pre-install:
+ ( cd ${WRKSRC}/${DISTNAME} && \
+ latex aa.dem && latex aa.dem && dvips aa.dvi && ps2pdf aa.ps )
+
+do-install:
+ ( cd ${WRKSRC}/${DISTNAME} && \
+ ${COPYTREE_SHARE} "aa.cls" ${PREFIX}/${TEXMFDIR}/${AADIR} )
+ ( cd ${WRKSRC}/${DISTNAME}/bibtex/ && \
+ ${COPYTREE_SHARE} "aa.bst" ${PREFIX}/${TEXMFDIR}/${AABIBDIR} )
+.if !defined(NOPORTDOCS)
+ ( cd ${WRKSRC}/${DISTNAME} && \
+ ${COPYTREE_SHARE} "${DOCFILES}" ${PREFIX}/${TEXMFDIR}/${AADOCSDIR} )
+.endif
+
+post-install:
+ ${MKTEXLSR} ${PREFIX}/${TEXMFDIR}
+
+.include <bsd.port.mk>
diff --git a/print/latex-aa/distinfo b/print/latex-aa/distinfo
new file mode 100644
index 000000000000..c3e730452045
--- /dev/null
+++ b/print/latex-aa/distinfo
@@ -0,0 +1,3 @@
+MD5 (latex/aa-package.tar.gz) = c7bcf5b78b0b38d5eceb59e3101b752f
+SHA256 (latex/aa-package.tar.gz) = 1b45c177bac2b5680183d4b6db6f7c7fdf96e5bdec104adeef990436de3be3f5
+SIZE (latex/aa-package.tar.gz) = 345774
diff --git a/print/latex-aa/pkg-descr b/print/latex-aa/pkg-descr
new file mode 100644
index 000000000000..1823a6d4c428
--- /dev/null
+++ b/print/latex-aa/pkg-descr
@@ -0,0 +1,12 @@
+LaTeX2e class for submission to the scientific journal Astronomy and
+Astrophysics.
+
+In order to ensure the smoothest transition for both authors and
+publishers, Springer-Verlag has kindly granted EDP Sciences the
+permission to use the LaTeX macro package that they developed for A&A
+Main journal.
+
+Only minor changes have been incorporated between the Springer class
+(1999) and the EDP Sciences class for the new journal.
+
+WWW: http://www.edpsciences.org/
diff --git a/print/latex-aa/pkg-plist b/print/latex-aa/pkg-plist
new file mode 100644
index 000000000000..556e63b034f5
--- /dev/null
+++ b/print/latex-aa/pkg-plist
@@ -0,0 +1,11 @@
+%%PORTDOCS%%share/texmf/doc/latex/aa/aa.dem
+%%PORTDOCS%%share/texmf/doc/latex/aa/aa.dvi
+%%PORTDOCS%%share/texmf/doc/latex/aa/aa.pdf
+%%PORTDOCS%%share/texmf/doc/latex/aa/aadoc.pdf
+%%PORTDOCS%%share/texmf/doc/latex/aa/readme.html
+%%PORTDOCS%%share/texmf/doc/latex/aa/readme.txt
+share/texmf/tex/latex/aa/aa.cls
+share/texmf/bibtex/bst/aa/aa.bst
+@dirrm share/texmf/tex/latex/aa
+@dirrm share/texmf/bibtex/bst/aa
+%%PORTDOCS%%@dirrm share/texmf/doc/latex/aa