aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-09-10 21:14:50 +0800
committermat <mat@FreeBSD.org>2018-09-10 21:14:50 +0800
commit6baece3b7ae06d93445a0e0ecf02e59541a92a95 (patch)
treeeaf052562fa1ad9b232918eb5e617ac1df0dd725 /print
parentc6f82ca14271d2d9433ac4938a2188b9b6d092c1 (diff)
downloadfreebsd-ports-gnome-6baece3b7ae06d93445a0e0ecf02e59541a92a95.tar.gz
freebsd-ports-gnome-6baece3b7ae06d93445a0e0ecf02e59541a92a95.tar.zst
freebsd-ports-gnome-6baece3b7ae06d93445a0e0ecf02e59541a92a95.zip
Add DOCS options to ports that should have one.
Also various fixes related to said option. PR: 230864 Submitted by: mat exp-runs by: antoine
Diffstat (limited to 'print')
-rw-r--r--print/linux-c7-cups-libs/Makefile2
-rw-r--r--print/linux-c7-harfbuzz/Makefile2
-rw-r--r--print/muttprint/Makefile2
-rw-r--r--print/pdflib/Makefile2
-rw-r--r--print/pdfstitch/Makefile2
-rw-r--r--print/print-manager/Makefile2
6 files changed, 10 insertions, 2 deletions
diff --git a/print/linux-c7-cups-libs/Makefile b/print/linux-c7-cups-libs/Makefile
index 29e053c31aa4..9fd458087c49 100644
--- a/print/linux-c7-cups-libs/Makefile
+++ b/print/linux-c7-cups-libs/Makefile
@@ -22,4 +22,6 @@ USE_LDCONFIG= yes
USE_LINUX= avahi-libs openssl
USE_LINUX_RPM= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/print/linux-c7-harfbuzz/Makefile b/print/linux-c7-harfbuzz/Makefile
index ca26434b0280..6c76554216ad 100644
--- a/print/linux-c7-harfbuzz/Makefile
+++ b/print/linux-c7-harfbuzz/Makefile
@@ -14,4 +14,6 @@ USE_LDCONFIG= yes
USE_LINUX= graphite2
USE_LINUX_RPM= yes
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>
diff --git a/print/muttprint/Makefile b/print/muttprint/Makefile
index 407f6102fb5b..19ff530e11a4 100644
--- a/print/muttprint/Makefile
+++ b/print/muttprint/Makefile
@@ -26,7 +26,7 @@ USE_TEX= latex dvipsk
NO_BUILD= yes
REINPLACE_ARGS= -i ""
-OPTIONS_DEFINE= CUPS X11
+OPTIONS_DEFINE= CUPS X11 DOCS
OPTIONS_DEFAULT= X11
X11_DESC= graphics/ImageMagick[-nox11] dependency
diff --git a/print/pdflib/Makefile b/print/pdflib/Makefile
index 1efb64137991..14bb85c69cc5 100644
--- a/print/pdflib/Makefile
+++ b/print/pdflib/Makefile
@@ -13,7 +13,7 @@ COMMENT= C library for dynamically generating PDF
RESTRICTED= Many odd restrictions on usage and distribution
-OPTIONS_DEFINE= PERL JAVA
+OPTIONS_DEFINE= PERL JAVA DOCS
PERL_DESC= Build perl bindings
JAVA_DESC= Build Java bindings
diff --git a/print/pdfstitch/Makefile b/print/pdfstitch/Makefile
index de8a2bc0f449..c90e8e1acea8 100644
--- a/print/pdfstitch/Makefile
+++ b/print/pdfstitch/Makefile
@@ -23,6 +23,8 @@ GH_ACCOUNT= sur5r
NO_ARCH= yes
NO_BUILD= yes
+OPTIONS_DEFINE= DOCS
+
do-install:
${INSTALL_SCRIPT} ${WRKSRC}/pdfstitch ${STAGEDIR}${PREFIX}/bin/pdfstitch
${MKDIR} ${STAGEDIR}${DOCSDIR}
diff --git a/print/print-manager/Makefile b/print/print-manager/Makefile
index a6f2c33ec8b1..af5de6217b4c 100644
--- a/print/print-manager/Makefile
+++ b/print/print-manager/Makefile
@@ -17,4 +17,6 @@ USE_KDE= auth codecs completion config configwidgets coreaddons \
USE_QT= core dbus gui network qml quick widgets xml \
buildtools_build qmake_build
+OPTIONS_DEFINE= DOCS
+
.include <bsd.port.mk>