aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorgahr <gahr@FreeBSD.org>2014-10-13 21:48:05 +0800
committergahr <gahr@FreeBSD.org>2014-10-13 21:48:05 +0800
commit6eefcdd6d62d4dcdd0601825daad31a5dae49bdb (patch)
tree0d36e20e11afe173f7351cd37b5981ee74f79d17 /print
parent33e18ad5671a43f637f033adf320705b3be739aa (diff)
downloadfreebsd-ports-gnome-6eefcdd6d62d4dcdd0601825daad31a5dae49bdb.tar.gz
freebsd-ports-gnome-6eefcdd6d62d4dcdd0601825daad31a5dae49bdb.tar.zst
freebsd-ports-gnome-6eefcdd6d62d4dcdd0601825daad31a5dae49bdb.zip
- Some demos need to be linked against libm.so
Approved by: maintainer
Diffstat (limited to 'print')
-rw-r--r--print/libharu/files/patch-demo_CMakeLists.txt22
1 files changed, 20 insertions, 2 deletions
diff --git a/print/libharu/files/patch-demo_CMakeLists.txt b/print/libharu/files/patch-demo_CMakeLists.txt
index 7a1e3f425763..cb142a8ed4fb 100644
--- a/print/libharu/files/patch-demo_CMakeLists.txt
+++ b/print/libharu/files/patch-demo_CMakeLists.txt
@@ -1,5 +1,23 @@
---- demo/CMakeLists.txt.orig 2013-11-18 14:51:59.000000000 +0100
-+++ demo/CMakeLists.txt 2013-11-18 14:52:21.000000000 +0100
+--- demo/CMakeLists.txt.orig 2013-10-30 14:11:59.000000000 +0100
++++ demo/CMakeLists.txt 2014-10-13 10:52:19.000000000 +0200
+@@ -61,7 +61,7 @@
+ # =======================================================================
+ foreach(demo ${demos_NAMES})
+ add_executable(${demo} ${demo}.c)
+- target_link_libraries(${demo} ${_LIBHPDF_LIB})
++ target_link_libraries(${demo} ${_LIBHPDF_LIB} m)
+ if(DEMO_C_FLAGS)
+ set_target_properties(${demo} PROPERTIES COMPILE_FLAGS ${DEMO_C_FLAGS})
+ endif(DEMO_C_FLAGS)
+@@ -70,7 +70,7 @@
+ # some demos need grid_sheet.c compiled in
+ foreach(demo ${demos_with_grid_NAMES})
+ add_executable(${demo} ${demo}.c grid_sheet.c)
+- target_link_libraries(${demo} ${_LIBHPDF_LIB})
++ target_link_libraries(${demo} ${_LIBHPDF_LIB} m)
+ if(DEMO_C_FLAGS)
+ set_target_properties(${demo} PROPERTIES COMPILE_FLAGS ${DEMO_C_FLAGS})
+ endif(DEMO_C_FLAGS)
@@ -75,6 +75,7 @@
set_target_properties(${demo} PROPERTIES COMPILE_FLAGS ${DEMO_C_FLAGS})
endif(DEMO_C_FLAGS)
/cgit.cgi/freebsd-ports-gnome/commit/www/WebMagick?h=gnome-3.24&id=e04bea8a0d4c3eccb7ac0cac6ce25deffd95fa10'>- Bump Magick++, MagickWand or MagickCore dependencymm2010-03-291-2/+2 * - update to 1.4.1dinoex2010-03-281-1/+1 * - update to jpeg-8dinoex2010-02-051-1/+1 * Update to the latest snapshot from the project CVSache2009-08-242-5/+14 * - Switch SourceForge ports to the new File Release System: categories startin...amdmi32009-08-221-1/+1 * - bump all port that indirectly depends on libjpeg and have not yet been bump...dinoex2009-07-311-1/+1 * - Update ImageMagick to 6.4.9.2mm2009-02-11