aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorstas <stas@FreeBSD.org>2008-04-06 16:58:21 +0800
committerstas <stas@FreeBSD.org>2008-04-06 16:58:21 +0800
commit6fbde8aaf51fc0bcaf991519b739b0592c98f740 (patch)
tree280ebf175af2693f172cb9dc5674fa73fb5992d3 /print
parentf29755f74021d623e3671b29c948ead5c3e33715 (diff)
downloadfreebsd-ports-gnome-6fbde8aaf51fc0bcaf991519b739b0592c98f740.tar.gz
freebsd-ports-gnome-6fbde8aaf51fc0bcaf991519b739b0592c98f740.tar.zst
freebsd-ports-gnome-6fbde8aaf51fc0bcaf991519b739b0592c98f740.zip
- Add ruby 1.9 support
- Implement new knobs for gems and rake (these are included in ruby 1.9 distribution already). Also move gem bits from ruby-gems/Makefile.common to bsd.ruby.mk[1]. Now to depend on gems or rake you should define USE_RUBYGEMS/USE_RAKE accordingly. Also RAKE_BIN variable is provided for pointing to the right rake executable. - Rewrite RUBY_SCHEBANG in awk to eliminate build dependency on ruby. Discussed with: Jonathan Weiss <jw@innerewut.de> [1] (gems maintainer) Tested by: ports@
Diffstat (limited to 'print')
-rw-r--r--print/rubygem-color/Makefile7
-rw-r--r--print/rubygem-colortools/Makefile6
-rw-r--r--print/rubygem-pdfwriter/Makefile6
3 files changed, 10 insertions, 9 deletions
diff --git a/print/rubygem-color/Makefile b/print/rubygem-color/Makefile
index b8bb80235141..3dce6bb0d2e6 100644
--- a/print/rubygem-color/Makefile
+++ b/print/rubygem-color/Makefile
@@ -18,6 +18,7 @@ BUILD_DEPENDS= rubygem-archive-tar-minitar>=0.5.1:${PORTSDIR}/archivers/rubygem-
rubygem-hoe>=1.3.0:${PORTSDIR}/devel/rubygem-hoe
RUN_DEPENDS= ${BUILD_DEPENDS}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+USE_RUBY= yes
+USE_RUBYGEMS= yes
+
+.include <bsd.port.mk>
diff --git a/print/rubygem-colortools/Makefile b/print/rubygem-colortools/Makefile
index 142ece2b0383..3dac4fe36dd8 100644
--- a/print/rubygem-colortools/Makefile
+++ b/print/rubygem-colortools/Makefile
@@ -14,8 +14,8 @@ DISTNAME= color-tools-${PORTVERSION}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Provides colour space definition and manpiulation
+USE_RUBY= yes
+USE_RUBYGEMS= yes
GEM_NAME= ${DISTNAME}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/print/rubygem-pdfwriter/Makefile b/print/rubygem-pdfwriter/Makefile
index 3ec0df1671e4..d09653146e68 100644
--- a/print/rubygem-pdfwriter/Makefile
+++ b/print/rubygem-pdfwriter/Makefile
@@ -18,8 +18,8 @@ BUILD_DEPENDS= rubygem-color>=1.4.0:${PORTSDIR}/print/rubygem-color \
rubygem-transactionsimple>=1.4.0:${PORTSDIR}/devel/rubygem-transactionsimple
RUN_DEPENDS= ${BUILD_DEPENDS}
+USE_RUBY= yes
+USE_RUBYGEMS= yes
GEM_NAME= ${DISTNAME}
-.include <bsd.port.pre.mk>
-.include "${PORTSDIR}/devel/ruby-gems/Makefile.common"
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>