aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorkwm <kwm@FreeBSD.org>2015-08-03 00:06:16 +0800
committerkwm <kwm@FreeBSD.org>2015-08-03 00:06:16 +0800
commit8f94d278a507c65b7105b66ec382fccd45bb1066 (patch)
tree285caa0f6748288fdb1ce4fa217f5dfb7cfb3f1b /print
parent0830c2a1aef98627ad8af305c2e68e21f7b5a74c (diff)
downloadfreebsd-ports-gnome-8f94d278a507c65b7105b66ec382fccd45bb1066.tar.gz
freebsd-ports-gnome-8f94d278a507c65b7105b66ec382fccd45bb1066.tar.zst
freebsd-ports-gnome-8f94d278a507c65b7105b66ec382fccd45bb1066.zip
Update poppler to 0.34.0. [1]
Chase all users of shlib version change of libpoppler.so. PR: 201477 [1] Submitted by: olivierd@ [1]
Diffstat (limited to 'print')
-rw-r--r--print/cups-filters/Makefile1
-rw-r--r--print/cups-filters/files/patch-poppler-0.3448
-rw-r--r--print/deforaos-pdfviewer/Makefile2
-rw-r--r--print/pdfcube/Makefile2
-rw-r--r--print/qpdfview/Makefile1
-rw-r--r--print/tex-luatex/Makefile2
-rw-r--r--print/tex-xetex/Makefile2
-rw-r--r--print/texlive-base/Makefile2
8 files changed, 55 insertions, 5 deletions
diff --git a/print/cups-filters/Makefile b/print/cups-filters/Makefile
index ba20a2a7df96..01672677fc90 100644
--- a/print/cups-filters/Makefile
+++ b/print/cups-filters/Makefile
@@ -2,6 +2,7 @@
PORTNAME= cups-filters
PORTVERSION= 1.0.71
+PORTREVISION= 1
CATEGORIES= print
MASTER_SITES= http://www.openprinting.org/download/cups-filters/
diff --git a/print/cups-filters/files/patch-poppler-0.34 b/print/cups-filters/files/patch-poppler-0.34
new file mode 100644
index 000000000000..6a116015657f
--- /dev/null
+++ b/print/cups-filters/files/patch-poppler-0.34
@@ -0,0 +1,48 @@
+# http://bzr.linuxfoundation.org/loggerhead/openprinting/cups-filters/revision/7371
+
+ CHANGES IN V1.0.72
+
++ - pdftoopvp: Adaptations to API changes on Poppler 0.34.0, note that
++ this patch disables color management in this filter. Thanks to
++ Vincent le Garrec and Andreas K. Huettel for the patch (Bug #1301,
++ Gentoo bug #554782).
+ - libcupsfilters, bannertopdf, foomatic-rip, gstoraster, pdftoijs,
+ sys5ippprinter, pdftoopvp, pdftops, pdftoraster, rastertoescpx,
+ urftopdf, texttopdf: Miscellaneous fixes for build compatibility with
+
+=== modified file 'filter/pdftoopvp/OPVPOutputDev.cxx'
+--- filter/pdftoopvp/OPVPOutputDev.cxx 2015-02-18 03:17:28 +0000
++++ filter/pdftoopvp/OPVPOutputDev.cxx 2015-07-14 19:22:49 +0000
+@@ -1811,10 +1811,14 @@
+ #if POPPLER_VERSION_MAJOR <= 0 && (POPPLER_VERSION_MINOR <= 20 || (POPPLER_VERSION_MINOR == 21 && POPPLER_VERSION_MICRO <= 2))
+ maskSplash->drawImage(&imageSrc, &imgMaskData,
+ splashModeMono8, gFalse, maskWidth, maskHeight, mat);
+-#else
++#elif POPPLER_VERSION_MAJOR <= 0 && POPPLER_VERSION_MINOR <= 33
+ maskSplash->drawImage(&imageSrc, &imgMaskData,
+ splashModeMono8, gFalse, maskWidth, maskHeight,
+ mat,gFalse);
++#else
++ maskSplash->drawImage(&imageSrc, 0, &imgMaskData,
++ splashModeMono8, gFalse, maskWidth, maskHeight,
++ mat,gFalse);
+ #endif
+ delete imgMaskData.imgStr;
+ maskStr->close();
+
+=== modified file 'filter/pdftoopvp/oprs/OPRS.cxx'
+--- filter/pdftoopvp/oprs/OPRS.cxx 2013-01-09 10:42:32 +0000
++++ filter/pdftoopvp/oprs/OPRS.cxx 2015-07-14 19:22:49 +0000
+@@ -240,8 +240,10 @@
+ if (rasterMode) {
+ #if POPPLER_VERSION_MAJOR <= 0 && (POPPLER_VERSION_MINOR <= 20 || (POPPLER_VERSION_MINOR == 21 && POPPLER_VERSION_MICRO <= 2))
+ return splash->drawImage(src,srcData,srcMode,srcAlpha,w,h,mat);
+-#else
++#elif POPPLER_VERSION_MAJOR <= 0 && POPPLER_VERSION_MINOR <= 33
+ return splash->drawImage(src,srcData,srcMode,srcAlpha,w,h,mat,gFalse);
++#else
++ return splash->drawImage(src,0,srcData,srcMode,srcAlpha,w,h,mat,gFalse);
+ #endif
+ } else {
+ return opvpSplash->drawImage(src,srcData,srcMode,srcAlpha,w,h,mat);
+
diff --git a/print/deforaos-pdfviewer/Makefile b/print/deforaos-pdfviewer/Makefile
index 04efbe4b683d..084584524ad7 100644
--- a/print/deforaos-pdfviewer/Makefile
+++ b/print/deforaos-pdfviewer/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pdfviewer
PORTVERSION= 0.0.1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= print
MASTER_SITES= http://www.defora.org/os/download/download/3686/
PKGNAMEPREFIX= deforaos-
diff --git a/print/pdfcube/Makefile b/print/pdfcube/Makefile
index 23b93250c691..541d857624cb 100644
--- a/print/pdfcube/Makefile
+++ b/print/pdfcube/Makefile
@@ -3,7 +3,7 @@
PORTNAME= pdfcube
PORTVERSION= 0.0.5
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= print
MASTER_SITES= http://code.100allora.it/releases/pdfcube/
diff --git a/print/qpdfview/Makefile b/print/qpdfview/Makefile
index 0cd20552fc16..3565394720dc 100644
--- a/print/qpdfview/Makefile
+++ b/print/qpdfview/Makefile
@@ -3,6 +3,7 @@
PORTNAME= qpdfview
PORTVERSION= 0.4.14
+PORTREVISION= 1
CATEGORIES= print
MASTER_SITES= https://launchpad.net/qpdfview/trunk/0.4.14/+download/
diff --git a/print/tex-luatex/Makefile b/print/tex-luatex/Makefile
index da510ce02658..5d25ff3b0237 100644
--- a/print/tex-luatex/Makefile
+++ b/print/tex-luatex/Makefile
@@ -2,7 +2,7 @@
PORTNAME= luatex
PORTVERSION= 0.80.0
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= print
MASTER_SITES= ftp://tug.org/historic/systems/texlive/2015/
PKGNAMEPREFIX= tex-
diff --git a/print/tex-xetex/Makefile b/print/tex-xetex/Makefile
index 86c00de43886..4e8641667049 100644
--- a/print/tex-xetex/Makefile
+++ b/print/tex-xetex/Makefile
@@ -2,7 +2,7 @@
PORTNAME= xetex
PORTVERSION= 0.99992
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= print
MASTER_SITES= ftp://tug.org/historic/systems/texlive/2015/
PKGNAMEPREFIX= tex-
diff --git a/print/texlive-base/Makefile b/print/texlive-base/Makefile
index 8afc19e10445..7c11dc05582d 100644
--- a/print/texlive-base/Makefile
+++ b/print/texlive-base/Makefile
@@ -2,7 +2,7 @@
PORTNAME= texlive
PORTVERSION= 20150521
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= print
MASTER_SITES= TEX_CTAN/systems/texlive/Source/
PKGNAMESUFFIX= -base