aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2009-10-27 14:32:08 +0800
committerhrs <hrs@FreeBSD.org>2009-10-27 14:32:08 +0800
commitb97a86166cb74668526acb7aa5f7eb47685679f3 (patch)
treec1ed33301038515705b35cf07d446af9acf3f938 /print
parentf55d773a297bbdaedd4031e0e3ad58149dddfb70 (diff)
downloadfreebsd-ports-gnome-b97a86166cb74668526acb7aa5f7eb47685679f3.tar.gz
freebsd-ports-gnome-b97a86166cb74668526acb7aa5f7eb47685679f3.tar.zst
freebsd-ports-gnome-b97a86166cb74668526acb7aa5f7eb47685679f3.zip
Fix A3 paper handling in the LIPS (Canon LBP series) driver.
Diffstat (limited to 'print')
-rw-r--r--print/ghostscript8/Makefile2
-rw-r--r--print/ghostscript8/files/patch-lips:gdevlips.c18
-rw-r--r--print/ghostscript8/files/patch-lips:gdevlips.h17
3 files changed, 36 insertions, 1 deletions
diff --git a/print/ghostscript8/Makefile b/print/ghostscript8/Makefile
index c2386f9a6fda..4c2b2bd2105a 100644
--- a/print/ghostscript8/Makefile
+++ b/print/ghostscript8/Makefile
@@ -7,7 +7,7 @@
PORTNAME= ghostscript8
PORTVERSION= 8.64
-PORTREVISION= 6
+PORTREVISION= 7
CATEGORIES= print
MASTER_SITES= SF/ghostscript/GPL%20Ghostscript/${PORTVERSION}:gs_srcs \
ftp://mirror.cs.wisc.edu/pub/mirrors/ghost/GPL/gs${PORTVERSION:S/.//}/:gs_srcs \
diff --git a/print/ghostscript8/files/patch-lips:gdevlips.c b/print/ghostscript8/files/patch-lips:gdevlips.c
new file mode 100644
index 000000000000..95f8b06f4841
--- /dev/null
+++ b/print/ghostscript8/files/patch-lips:gdevlips.c
@@ -0,0 +1,18 @@
+--- contrib/lips4/gdevlips.c.orig Thu Nov 2 12:09:18 2000
++++ contrib/lips4/gdevlips.c Tue Jan 13 01:23:47 2004
+@@ -62,7 +62,15 @@
+ height = tmp;
+ }
+ for (pt = lips_paper_table; pt->num_unit < 80; pt++)
++/* add by shige 11/06 2003 */
++#ifdef USE_LIPS_SIZE_ERROR
++ if(pt->width+LIPS_SIZE_ERROR_VALUE>=width
++ && pt->width-LIPS_SIZE_ERROR_VALUE<=width
++ && pt->height+LIPS_SIZE_ERROR_VALUE>=height
++ && pt->height-LIPS_SIZE_ERROR_VALUE<=height)
++#else
+ if (pt->width == width && pt->height == height)
++#endif
+ break;
+
+ return pt->num_unit + landscape;
diff --git a/print/ghostscript8/files/patch-lips:gdevlips.h b/print/ghostscript8/files/patch-lips:gdevlips.h
new file mode 100644
index 000000000000..b3520ba1ac33
--- /dev/null
+++ b/print/ghostscript8/files/patch-lips:gdevlips.h
@@ -0,0 +1,17 @@
+--- contrib/lips4/gdevlips.h.orig Thu Nov 2 12:09:18 2000
++++ contrib/lips4/gdevlips.h Tue Jan 13 01:23:47 2004
+@@ -188,6 +188,14 @@
+ bool faceup;\
+ char mediaType[LIPS_MEDIACHAR_MAX];
+
++/* added by shige 11/06 2003 */
++#define USE_LIPS_SIZE_ERROR
++#define LIPS_SIZE_ERROR_VALUE 2
++
++/* added by shige 11/09 2003 */
++#define LIPS_HEIGHT_MAX_720 11906
++#define LIPS_WIDTH_MAX_720 8419
++
+ int lips_media_selection(int width, int height);
+ int lips_packbits_encode(byte * inBuff, byte * outBuff, int Length);
+ int lips_mode3format_encode(byte * inBuff, byte * outBuff, int Length);