aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2018-09-10 21:11:23 +0800
committermat <mat@FreeBSD.org>2018-09-10 21:11:23 +0800
commitc6f82ca14271d2d9433ac4938a2188b9b6d092c1 (patch)
treeb47b12c2614f4db455f6a6733adce11a1cbba4b5 /print
parentb5f636d426adfd976e881a414696f678f16edcb8 (diff)
downloadfreebsd-ports-gnome-c6f82ca14271d2d9433ac4938a2188b9b6d092c1.tar.gz
freebsd-ports-gnome-c6f82ca14271d2d9433ac4938a2188b9b6d092c1.tar.zst
freebsd-ports-gnome-c6f82ca14271d2d9433ac4938a2188b9b6d092c1.zip
After an include, PLIST_SUB must be appended to, not overwritten.
If it is overwritten, many values will be clobbered, and pain will ensue. PR: 230864 Submitted by: mat exp-runs by: antoine
Diffstat (limited to 'print')
-rw-r--r--print/pdflib/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/print/pdflib/Makefile b/print/pdflib/Makefile
index cef8d4a71b49..1efb64137991 100644
--- a/print/pdflib/Makefile
+++ b/print/pdflib/Makefile
@@ -29,11 +29,11 @@ PERL_USES= perl5
.include <bsd.port.pre.mk>
.if ${PORT_OPTIONS:MPERL}
-PLIST_SUB= PERL=""
+PLIST_SUB+= PERL=""
CONFIGURE_ARGS+=--with-perl=${PERL}
.else
CONFIGURE_ARGS+=--with-perl=no
-PLIST_SUB= PERL="@comment "
+PLIST_SUB+= PERL="@comment "
.endif
.if ${PORT_OPTIONS:MJAVA}