aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2014-06-04 03:32:33 +0800
committerhrs <hrs@FreeBSD.org>2014-06-04 03:32:33 +0800
commitfd1cde5b11f5a13fcd00c3b837da401c1253cf13 (patch)
treeb1760818e3211ad4ae84b1d38907e642ea6991b7 /print
parent24c5685c050fc76a000a37c523461fa9b7f63529 (diff)
downloadfreebsd-ports-gnome-fd1cde5b11f5a13fcd00c3b837da401c1253cf13.tar.gz
freebsd-ports-gnome-fd1cde5b11f5a13fcd00c3b837da401c1253cf13.tar.zst
freebsd-ports-gnome-fd1cde5b11f5a13fcd00c3b837da401c1253cf13.zip
- STAGEDIR support.
- Simplify PORT_OPTIONS handling. - Fix pkg-plist and remove extra mktexlsr(1). - Fix pkg-message.
Diffstat (limited to 'print')
-rw-r--r--print/auctex/Makefile28
-rw-r--r--print/auctex/files/pkg-message.in (renamed from print/auctex/pkg-message)7
-rw-r--r--print/auctex/pkg-plist6
3 files changed, 16 insertions, 25 deletions
diff --git a/print/auctex/Makefile b/print/auctex/Makefile
index 3bb9390779a3..261f17d1f83c 100644
--- a/print/auctex/Makefile
+++ b/print/auctex/Makefile
@@ -3,7 +3,7 @@
PORTNAME= auctex
PORTVERSION= 11.87
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= print elisp
MASTER_SITES= ${MASTER_SITE_GNU}
MASTER_SITE_SUBDIR= ${PORTNAME}
@@ -14,34 +14,26 @@ COMMENT= Integrated environment for writing LaTeX using GNU Emacs
LICENSE= GPLv3
+NOT_FOR_ARCHS= ia64
USE_TEX= latex
USE_GHOSTSCRIPT=yes
+USE_EMACS= yes
GNU_CONFIGURE= yes
CONFIGURE_ARGS= --with-lispdir=${PREFIX}/${LISPDIR} \
--with-auto-dir=${PREFIX}/${LISPDIR}/auctex/auto \
--with-texmf-dir=${PREFIX}/${TEXMFDIR}
-.if defined(NOPORTDOCS)
-MAKE_ENV= WITHOUT_AUCTEX_DOCSDIR=yes
-.else
+DOCS_CONFIGURE_ON= --docdir=${DOCSDIR}
+DOCS_CONFIGURE_OFF= WITHOUT_AUCTEX_DOCSDIR=yes
PORTDOCS= tex-ref.pdf
-.endif
-
-USE_EMACS= yes
+INFO= auctex preview-latex
LISPDIR= ${EMACS_VERSION_SITE_LISPDIR}
-
PLIST_SUB+= LISPDIR=${LISPDIR} \
TEXMFDIR=${TEXMFDIR} \
MKTEXLSR=${MKTEXLSR}
-INFO= auctex preview-latex
-
-TEXMFDIR= share/texmf
-MKTEXLSR= ${LOCALBASE}/bin/mktexlsr
-
-NOT_FOR_ARCHS= ia64
+SUB_FILES= pkg-message
+PKGMESSAGE= ${WRKDIR}/pkg-message
-NO_STAGE= yes
-post-install:
- ${MKTEXLSR} ${PREFIX}/${TEXMFDIR}
- @${CAT} ${PKGMESSAGE}
+OPTIONS_DEFINE= DOCS
+OPTIONS_DEFAULT=DOCS
.include <bsd.port.mk>
diff --git a/print/auctex/pkg-message b/print/auctex/files/pkg-message.in
index 14df730c521b..b1d48843ada9 100644
--- a/print/auctex/pkg-message
+++ b/print/auctex/files/pkg-message.in
@@ -1,10 +1,9 @@
-
Customizing
===========
- Next, you should edit the file
-`${PREFIX}/share/emacs/site-lisp/tex-site.el' to fit your local site.
+ You should edit the file
+`%%PREFIX%%/share/emacs/site-lisp/tex-site.el' to fit your local site.
You do this by looking at the customization section in the beginning
-of `${PREFIX}/share/emacs/site-lisp/auctex/tex.el' and copy the
+of `%%PREFIX%%/share/emacs/site-lisp/auctex/tex.el' and copy the
definitions that are wrong for your site to `tex-site.el'. Do *not*
edit `tex.el' directly, or you will have to do all the work over again
when you upgrade AUC TeX. AUC TeX will not overwrite your old
diff --git a/print/auctex/pkg-plist b/print/auctex/pkg-plist
index b4b5829dee06..3298686152a0 100644
--- a/print/auctex/pkg-plist
+++ b/print/auctex/pkg-plist
@@ -321,7 +321,7 @@
%%TEXMFDIR%%/tex/latex/preview/prshowlabels.def
%%TEXMFDIR%%/tex/latex/preview/prtightpage.def
%%TEXMFDIR%%/tex/latex/preview/prtracingall.def
+@dirrmtry %%TEXMFDIR%%/tex/latex/preview
%%TEXMFDIR%%/doc/latex/styles/preview.dvi
-@dirrm %%TEXMFDIR%%/doc/latex/styles
-@exec %%MKTEXLSR%% %D/%%TEXMFDIR%%
-@unexec %%MKTEXLSR%% %D/%%TEXMFDIR%%
+@dirrmtry %%TEXMFDIR%%/doc/latex/styles
+@dirrmtry %%TEXMFDIR%%/doc/latex