aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authortijl <tijl@FreeBSD.org>2019-01-16 19:13:44 +0800
committertijl <tijl@FreeBSD.org>2019-01-16 19:13:44 +0800
commit0c123abc65c17a023a06fa03c2da7624f5a40a03 (patch)
tree127ae6686665fd0ff97a7bd5f27449299929734e /print
parente64e67d7f17dd66dc29ae5c5ea52dd16964f47bd (diff)
downloadfreebsd-ports-gnome-0c123abc65c17a023a06fa03c2da7624f5a40a03.tar.gz
freebsd-ports-gnome-0c123abc65c17a023a06fa03c2da7624f5a40a03.tar.zst
freebsd-ports-gnome-0c123abc65c17a023a06fa03c2da7624f5a40a03.zip
Fix Qt5 symbol version scripts to put the catch-all clause first. When
a symbol matches multiple clauses the last one takes precedence. If the catch-all is last it captures everything. In the case of Qt5 libraries this caused all symbols to have a Qt_5 label while some should have Qt_5_PRIVATE_API. This only affects lld because GNU ld always gives the catch-all lowest priority. Older versions of Qt5Webengine exported some memory allocation symbols from the bundled Chromium. Version 5.9 stopped exporting these [1] but the symbols were kept as weak wrappers for the standard allocation functions to maintain binary compatibility. [2][3] The problem is that the call to the standard function in these weak wrappers is only resolved to the standard function if there's a call to this standard function in other parts of Qt5Webengine, because only then is there a non-weak symbol that takes precedence over the weak one. If there's no such non-weak symbol the call in the weak wrapper resolves to the weak wrapper itself creating an infinite call loop that overflows the stack and causes a crash. Some of the allocation functions are variants of C++ new and delete and it probably depends on the compiler whether these variants are used in other parts of Qt5Webengine. Remove the weak wrappers (make them Linux specific). This isn't binary compatible but we are already breaking that with the changes to the symbol versions. [1] https://github.com/qt/qtwebengine/commit/5c2cbfccf9aafb547b0b30914c4056abd25942a4 [2] https://github.com/qt/qtwebengine/commit/2ed5054e3a800fa97c2c9e920ba1e6ea4b6ef2a5 [3] https://github.com/qt/qtwebengine/commit/009f5ebb4bd6e50188671e0815a5dae6afe39db5 Bump all ports that depend on Qt5. PR: 234070 Exp-run by: antoine Approved by: kde (adridg)
Diffstat (limited to 'print')
-rw-r--r--print/frescobaldi/Makefile1
-rw-r--r--print/hplip-plugin/Makefile1
-rw-r--r--print/hplip/Makefile2
-rw-r--r--print/lyx/Makefile1
-rw-r--r--print/print-manager/Makefile1
-rw-r--r--print/py-qt5-printsupport/Makefile1
-rw-r--r--print/qpdfview/Makefile2
-rw-r--r--print/qt5-printsupport/Makefile2
-rw-r--r--print/scribus-devel/Makefile2
9 files changed, 9 insertions, 4 deletions
diff --git a/print/frescobaldi/Makefile b/print/frescobaldi/Makefile
index becc7a7f3f18..9cc8fc7484aa 100644
--- a/print/frescobaldi/Makefile
+++ b/print/frescobaldi/Makefile
@@ -4,6 +4,7 @@
PORTNAME= frescobaldi
DISTVERSIONPREFIX= v
DISTVERSION= 3.0.0
+PORTREVISION= 1
CATEGORIES= print kde
MAINTAINER= m.ne@gmx.net
diff --git a/print/hplip-plugin/Makefile b/print/hplip-plugin/Makefile
index 7e06a62e1597..94def5daec4d 100644
--- a/print/hplip-plugin/Makefile
+++ b/print/hplip-plugin/Makefile
@@ -3,6 +3,7 @@
PORTNAME= hplip-plugin
PORTVERSION= 3.17.11
+PORTREVISION= 1
CATEGORIES= print
MASTER_SITES= https://www.openprinting.org/download/printdriver/auxfiles/HP/plugins/
DISTNAME= hplip-${DISTVERSION}-plugin
diff --git a/print/hplip/Makefile b/print/hplip/Makefile
index 989bcc3c483e..fd42bf25cb59 100644
--- a/print/hplip/Makefile
+++ b/print/hplip/Makefile
@@ -3,7 +3,7 @@
PORTNAME= hplip
PORTVERSION= 3.17.11
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= print
MASTER_SITES= SF
diff --git a/print/lyx/Makefile b/print/lyx/Makefile
index bcda4d687c18..3aba26b9365a 100644
--- a/print/lyx/Makefile
+++ b/print/lyx/Makefile
@@ -3,6 +3,7 @@
PORTNAME= lyx
PORTVERSION= ${MAJOR_VERSION}.${MINOR_VERSION}
+PORTREVISION= 1
CATEGORIES= print editors
MASTER_SITES= ftp://ftp.lyx.org/pub/lyx/stable/${MAJOR_VERSION}.x/ \
http://www-ftp.lip6.fr/ftp/pub/lyx/stable/${MAJOR_VERSION}.x/ \
diff --git a/print/print-manager/Makefile b/print/print-manager/Makefile
index 2797264f9601..954d4170319b 100644
--- a/print/print-manager/Makefile
+++ b/print/print-manager/Makefile
@@ -2,6 +2,7 @@
PORTNAME= print-manager
DISTVERSION= ${KDE_APPLICATIONS_VERSION}
+PORTREVISION= 1
CATEGORIES= print kde kde-applications
MAINTAINER= kde@FreeBSD.org
diff --git a/print/py-qt5-printsupport/Makefile b/print/py-qt5-printsupport/Makefile
index 44a475b1e3f0..d863e1e242c7 100644
--- a/print/py-qt5-printsupport/Makefile
+++ b/print/py-qt5-printsupport/Makefile
@@ -1,6 +1,7 @@
# $FreeBSD$
PORTNAME= printsupport
+PORTREVISION= 1
CATEGORIES= print python
MAINTAINER= kde@FreeBSD.org
diff --git a/print/qpdfview/Makefile b/print/qpdfview/Makefile
index b9a28af8d716..d28d1a4a5e0f 100644
--- a/print/qpdfview/Makefile
+++ b/print/qpdfview/Makefile
@@ -3,7 +3,7 @@
PORTNAME= qpdfview
DISTVERSION= 0.4.17beta1
-PORTREVISION= 4
+PORTREVISION= 5
CATEGORIES= print
MASTER_SITES= https://launchpadlibrarian.net/294276875/ \
https://launchpad.net/${PORTNAME}/trunk/${DISTVERSION}/+download/
diff --git a/print/qt5-printsupport/Makefile b/print/qt5-printsupport/Makefile
index ec140b4699b1..04537b1cfaf7 100644
--- a/print/qt5-printsupport/Makefile
+++ b/print/qt5-printsupport/Makefile
@@ -2,7 +2,7 @@
PORTNAME= printsupport
DISTVERSION= ${QT5_VERSION}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= print
PKGNAMEPREFIX= qt5-
diff --git a/print/scribus-devel/Makefile b/print/scribus-devel/Makefile
index 6a102b261470..133e1402380c 100644
--- a/print/scribus-devel/Makefile
+++ b/print/scribus-devel/Makefile
@@ -3,7 +3,7 @@
PORTNAME= scribus
PORTVERSION= 1.5.4
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= print editors
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}${PKGNAMESUFFIX}/${PORTVERSION}/ \
http://www.scribus.net/downloads/${PORTVERSION}/