aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorrakuco <rakuco@FreeBSD.org>2015-12-14 05:56:50 +0800
committerrakuco <rakuco@FreeBSD.org>2015-12-14 05:56:50 +0800
commit425ab2f470108aa2b2e552dfed54e18a676fdd64 (patch)
treec8ea48f297bee52a8d84f4ec84da2d9fa23078a5 /print
parentc9f665c0b4d537f42b2c6ec9d10e14303cc2afea (diff)
downloadfreebsd-ports-gnome-425ab2f470108aa2b2e552dfed54e18a676fdd64.tar.gz
freebsd-ports-gnome-425ab2f470108aa2b2e552dfed54e18a676fdd64.tar.zst
freebsd-ports-gnome-425ab2f470108aa2b2e552dfed54e18a676fdd64.zip
At very long last land PyQt5 5.5.1 ports.
Add the required bits to Uses/pyqt.mk along with all the PyQt5 ports. Thankfully this commit is mostly adding new ports, as the hard work was already done in r403297 and r403662. Huge kudos to Tobias Berner <tcberner@gmail.com> and, most importantly, Guido Falsi (madpilot@) for their initial work on these ports (see D2910 in Phabricator for an earlier version of the PyQt5 patch set). PR: 204672
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/py-qt5-printsupport/Makefile27
-rw-r--r--print/py-qt5-printsupport/pkg-descr4
-rw-r--r--print/py-qt5-printsupport/pkg-plist12
4 files changed, 44 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index 8ea4e03a45e7..5d605ea81d8a 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -198,6 +198,7 @@
SUBDIR += py-preppy
SUBDIR += py-pycups
SUBDIR += py-pyscript
+ SUBDIR += py-qt5-printsupport
SUBDIR += py-relatorio
SUBDIR += py-reportlab
SUBDIR += py-reportlab1
diff --git a/print/py-qt5-printsupport/Makefile b/print/py-qt5-printsupport/Makefile
new file mode 100644
index 000000000000..951ee7ef926d
--- /dev/null
+++ b/print/py-qt5-printsupport/Makefile
@@ -0,0 +1,27 @@
+# $FreeBSD$
+
+PORTNAME= printsupport
+CATEGORIES= print python
+
+MAINTAINER= kde@FreeBSD.org
+COMMENT= Python bindings for the Qt5 toolkit, QtPrintSupport module
+
+CONFIGURE_ARGS= --enable QtPrintSupport
+PYQT_DIST= yes
+
+USES= python pyqt:5
+USE_GL= gl
+USE_PYQT= sip_build core_run widgets_run
+USE_QT5= core gui printsupport widgets qmake_build
+
+OPTIONS_DEFINE= API DEBUG
+OPTIONS_DEFAULT=API
+OPTIONS_SUB= yes
+
+API_DESC= Install QtPrintsupport API for QScintilla2
+API_CONFIGURE_ON= --qsci-api --qsci-api-destdir=${QSCIDIR}
+API_CONFIGURE_OFF= --no-qsci-api
+API_LIB_DEPENDS= libqscintilla2-qt5.so:${PORTSDIR}/devel/qscintilla2-qt5
+DEBUG_CONFIGURE_ON= --debug --trace
+
+.include <bsd.port.mk>
diff --git a/print/py-qt5-printsupport/pkg-descr b/print/py-qt5-printsupport/pkg-descr
new file mode 100644
index 000000000000..a07d2acf7f0f
--- /dev/null
+++ b/print/py-qt5-printsupport/pkg-descr
@@ -0,0 +1,4 @@
+PyQt5 is a set of Python bindings for Digia's Qt5 application framework.
+This package provides the QtPrintSupport module.
+
+WWW: http://www.riverbankcomputing.co.uk/software/pyqt/
diff --git a/print/py-qt5-printsupport/pkg-plist b/print/py-qt5-printsupport/pkg-plist
new file mode 100644
index 000000000000..c3fd4d68cfd1
--- /dev/null
+++ b/print/py-qt5-printsupport/pkg-plist
@@ -0,0 +1,12 @@
+%%PYTHON_SITELIBDIR%%/PyQt5/QtPrintSupport.so
+%%PYQT_SIPDIR%%/QtPrintSupport/QtPrintSupportmod.sip
+%%PYQT_SIPDIR%%/QtPrintSupport/qabstractprintdialog.sip
+%%PYQT_SIPDIR%%/QtPrintSupport/qpagesetupdialog.sip
+%%PYQT_SIPDIR%%/QtPrintSupport/qprintdialog.sip
+%%PYQT_SIPDIR%%/QtPrintSupport/qprintengine.sip
+%%PYQT_SIPDIR%%/QtPrintSupport/qprinter.sip
+%%PYQT_SIPDIR%%/QtPrintSupport/qprinterinfo.sip
+%%PYQT_SIPDIR%%/QtPrintSupport/qprintpreviewdialog.sip
+%%PYQT_SIPDIR%%/QtPrintSupport/qprintpreviewwidget.sip
+%%PYQT_SIPDIR%%/QtPrintSupport/qpyprintsupport_qlist.sip
+%%API%%share/qt5/qsci/api/python/QtPrintSupport.api