aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorcy <cy@FreeBSD.org>2011-12-04 14:25:20 +0800
committercy <cy@FreeBSD.org>2011-12-04 14:25:20 +0800
commit845c8e36afdcbafb75853d5c1e1c9339068bc1ea (patch)
treeb4b5ece6d276eabeb6369ec447233631d72af07d /print
parent631c6c87201b6c962591f7361aca6efb0c09cddd (diff)
downloadfreebsd-ports-gnome-845c8e36afdcbafb75853d5c1e1c9339068bc1ea.tar.gz
freebsd-ports-gnome-845c8e36afdcbafb75853d5c1e1c9339068bc1ea.tar.zst
freebsd-ports-gnome-845c8e36afdcbafb75853d5c1e1c9339068bc1ea.zip
Fix build with fltk-1.3.0.
Feature safe: yes
Diffstat (limited to 'print')
-rw-r--r--print/xpp/Makefile2
-rw-r--r--print/xpp/files/patch-mainwindow.fl11
-rw-r--r--print/xpp/files/patch-xpp.cxx20
-rw-r--r--print/xpp/files/patch-xppmain.cxx11
4 files changed, 43 insertions, 1 deletions
diff --git a/print/xpp/Makefile b/print/xpp/Makefile
index 472085530c1c..130360c3974b 100644
--- a/print/xpp/Makefile
+++ b/print/xpp/Makefile
@@ -7,7 +7,7 @@
PORTNAME= xpp
PORTVERSION= 1.5
-PORTREVISION= 7
+PORTREVISION= 8
CATEGORIES= print
MASTER_SITES= SF/cups/${PORTNAME}/${PORTVERSION}
diff --git a/print/xpp/files/patch-mainwindow.fl b/print/xpp/files/patch-mainwindow.fl
new file mode 100644
index 000000000000..3815f84069ae
--- /dev/null
+++ b/print/xpp/files/patch-mainwindow.fl
@@ -0,0 +1,11 @@
+--- mainwindow.fl.orig 2004-12-06 19:24:46.000000000 -0800
++++ mainwindow.fl 2011-12-03 21:58:36.860575904 -0800
+@@ -70,7 +70,7 @@
+ fileList->value(print->filelist);
+ }}
+ private xywh {440 75 65 25} down_box DOWN_BOX shortcut 0x80062 align 16
+- code0 {\#include <FL/fl_file_chooser.H>}
++ code0 {\#include <FL/Fl_File_Chooser.H>}
+ code1 {\#include "xpp.h"}
+ }
+ Fl_Scroll printerList {
diff --git a/print/xpp/files/patch-xpp.cxx b/print/xpp/files/patch-xpp.cxx
new file mode 100644
index 000000000000..2d1c5c875711
--- /dev/null
+++ b/print/xpp/files/patch-xpp.cxx
@@ -0,0 +1,20 @@
+--- xpp.cxx.orig 2004-12-06 11:00:04.000000000 -0800
++++ xpp.cxx 2011-12-03 22:11:00.788941301 -0800
+@@ -2500,7 +2500,7 @@
+ // Redraw the destination menu in the main window
+
+ printerPack->parent()->redraw();
+- printerPack->draw();
++ printerPack->redraw();
+
+ }
+
+@@ -2674,7 +2674,7 @@
+ // Redraw the destination menu in the main window
+
+ printerPack->parent()->redraw();
+- printerPack->draw();
++ printerPack->redraw();
+
+ return(dest_index);
+ }
diff --git a/print/xpp/files/patch-xppmain.cxx b/print/xpp/files/patch-xppmain.cxx
new file mode 100644
index 000000000000..326f205192d9
--- /dev/null
+++ b/print/xpp/files/patch-xppmain.cxx
@@ -0,0 +1,11 @@
+--- xppmain.cxx.orig 2004-11-30 17:28:01.000000000 -0800
++++ xppmain.cxx 2011-12-03 22:13:39.744180523 -0800
+@@ -32,7 +32,7 @@
+ */
+
+ #include "mainwindow.h"
+-#include <Fl/Fl_Shared_Image.h>
++#include <FL/Fl_Shared_Image.H>
+
+ /*
+ * 'main()' - Do all what xpp should do