aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authormi <mi@FreeBSD.org>2007-12-29 04:40:03 +0800
committermi <mi@FreeBSD.org>2007-12-29 04:40:03 +0800
commita6e844803246dbdbb6d6c72fc46374b9c57ccc06 (patch)
tree5ac2606654dfc157ab9a1caf72ea4c5c969c5f99 /print
parentbe0864a4fafd967ee61023775172e6f7c0437e05 (diff)
downloadfreebsd-ports-gnome-a6e844803246dbdbb6d6c72fc46374b9c57ccc06.tar.gz
freebsd-ports-gnome-a6e844803246dbdbb6d6c72fc46374b9c57ccc06.tar.zst
freebsd-ports-gnome-a6e844803246dbdbb6d6c72fc46374b9c57ccc06.zip
Update from 1.5.1 to 1.5.3. Fix problems, when both Qt3 and Qt4 are
present at build-time. Completely disable the bundled-in libtintl. Handle libiconv correctly. Use all available CPUs during build. Approved by: maintainer PR: ports/118784 Submitted by: Koji Yokota, self
Diffstat (limited to 'print')
-rw-r--r--print/lyx15/Makefile36
-rw-r--r--print/lyx15/distinfo9
2 files changed, 26 insertions, 19 deletions
diff --git a/print/lyx15/Makefile b/print/lyx15/Makefile
index 760aee67e2dd..9f4eb539891d 100644
--- a/print/lyx15/Makefile
+++ b/print/lyx15/Makefile
@@ -6,7 +6,7 @@
#
PORTNAME= lyx
-PORTVERSION= 1.5.1
+PORTVERSION= 1.5.3
CATEGORIES= print
MASTER_SITES= ftp://ftp.lyx.org/pub/lyx/stable/ \
ftp://ftp.planetmirror.com/pub/lyx/stable/ \
@@ -22,6 +22,7 @@ COMMENT= Document processor interfaced with LaTeX (nearly WYSIWYG) (stable)
BUILD_DEPENDS= latex:${PORTSDIR}/print/teTeX
RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX \
+ ${LOCALBASE}/share/texmf/tex/latex/prettyref/prettyref.sty:${PORTSDIR}/print/latex-prettyref \
${X11BASE}/lib/X11/fonts/texcm-ttf/cmex10.ttf:${PORTSDIR}/x11-fonts/texcm-ttf
LIB_DEPENDS= boost_regex:${PORTSDIR}/devel/boost
@@ -31,10 +32,9 @@ CONFIGURE_ENV+= LDFLAGS=${PTHREAD_LIBS}
OPTIONS= ASPELL "Utilize ASPELL library" on \
AIKSAUR "Build Aiksaurus support (English thesaurus)" on \
- NLS "Native language support" On \
- INCGT "Use the included Gettext library" off
+ NLS "Native language support" On
-ALL_TARGET= all check
+ALL_TARGET= -j`${SYSCTL} -n hw.ncpu`
USE_BZIP2= yes
USE_GNOME= gnometarget lthack
USE_PERL5= yes
@@ -46,18 +46,22 @@ QT_COMPONENTS= gui corelib moc uic
CONFLICTS= lyx-1.4.*
-EXTRACT_AFTER_ARGS=| ${TAR} -xf - --exclude ${PORTNAME}-${PORTVERSION}/intl/*.[ch] --exclude ${PORTNAME}-${PORTVERSION}/boost
-CONFIGURE_ARGS= --with-extra-lib="${LOCALBASE}/lib" \
- --with-extra-inc="${LOCALBASE}/include/Qt* ${LOCALBASE}/include" \
+EXTRACT_AFTER_ARGS=| ${TAR} -xf - --exclude ${PORTNAME}-${PORTVERSION}/intl/*.[ch] \
+ --exclude ${PORTNAME}-${PORTVERSION}/boost --exclude ${PORTNAME}-${PORTVERSION}/intl
+CONFIGURE_ARGS= --with-frontend=qt4 \
--without-included-boost \
- --with-frontend=qt4
+ --without-included-gettext \
+ --with-libiconv-prefix=${LOCALBASE}
+
MAKE_ARGS= ACLOCAL="${TRUE}" AUTOCONF="${TRUE}" AUTOMAKE="${TRUE}" \
AUTOHEADER="${TRUE}"
MAN1= lyx.1 tex2lyx.1 lyxclient.1
post-patch:
# Removing mention of the bundled boost
- ${REINPLACE_CMD} -e 's, boost/[^ ]*Makefile,,g' ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e 's, boost/[^ ]*Makefile,,g' -e 's, intl/Makefile,,g' \
+ ${WRKSRC}/configure
+ ${REINPLACE_CMD} -e 's, intl , ,' ${WRKSRC}/Makefile.in
${REINPLACE_CMD} -e 's,detail/nullstream,utils/nullstream,' \
${WRKSRC}/src/pch.h ${WRKSRC}/src/support/pch.h \
${WRKSRC}/src/support/debugstream.h
@@ -76,6 +80,10 @@ post-configure:
# Removing explicit linking with -lc
${REINPLACE_CMD} -e 's,-lc ,,' ${WRKSRC}/*/Makefile
+post-build check test:
+ # Running vendor's self-tests:
+ ${GMAKE} -C ${WRKSRC} check
+
.include <bsd.port.pre.mk>
.if exists(${X11BASE}/bin/makepsres)
@@ -100,15 +108,17 @@ CONFIGURE_ARGS+=--without-aspell --without-pspell
.endif
.if !defined(WITHOUT_NLS)
-.if defined(WITH_INCGT)
-CONFIGURE_ARGS+= --with-included-gettext
-.else
USE_GETTEXT= yes
PLIST_SUB+= NLS=""
-.endif
.else
CONFIGURE_ARGS+= --disable-nls
PLIST_SUB+= NLS="@comment "
.endif
+# includes of qt4 must be found earlier than those of qt3
+CONFIGURE_ENV+= QT4_CORE_CFLAGS="-DQT_SHARED -I${LOCALBASE}/include/QtCore \
+ -I${LOCALBASE}/include" \
+ QT4_FRONTEND_CFLAGS="-DQT_SHARED -I${LOCALBASE}/include/QtCore \
+ -I${LOCALBASE}/include/QtGui -I${LOCALBASE}/include"
+
.include <bsd.port.post.mk>
diff --git a/print/lyx15/distinfo b/print/lyx15/distinfo
index bc5f0a65da16..1dc0eb0942fd 100644
--- a/print/lyx15/distinfo
+++ b/print/lyx15/distinfo
@@ -1,6 +1,3 @@
-MD5 (lyx-1.5.1.tar.gz) = 7a06523d99c27ba5a0baebc5664024ba
-SHA256 (lyx-1.5.1.tar.gz) = 9f1000ee9473becb9cc46acdf6517d8182a5f679c18ff623df436d172c068e3a
-SIZE (lyx-1.5.1.tar.gz) = 10115219
-MD5 (lyx-1.5.1.tar.bz2) = 0ae3b9ccb2aa74776be4af8c199dbbe9
-SHA256 (lyx-1.5.1.tar.bz2) = d720ff082ed29d385c52e7ad370499d23275e595e9d7a321b383609f68acf23e
-SIZE (lyx-1.5.1.tar.bz2) = 7823886
+MD5 (lyx-1.5.3.tar.bz2) = 4fe013248713bb126877c317cad57238
+SHA256 (lyx-1.5.3.tar.bz2) = 5b6d051f243e5595bf8fb56a57ece1b77049d4745bfc3473e2f120b933a41de0
+SIZE (lyx-1.5.3.tar.bz2) = 8743035