aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authortobik <tobik@FreeBSD.org>2019-11-08 21:22:59 +0800
committertobik <tobik@FreeBSD.org>2019-11-08 21:22:59 +0800
commitaf2bdda5acf9f0a191292a93f90a99c0610e696e (patch)
treea54ba2abe21387f8861f7fa1983abd60b09b9a5f /print
parente2c9a2e5b6a9392f0c576710c0dbe3ec21f7a93c (diff)
downloadfreebsd-ports-gnome-af2bdda5acf9f0a191292a93f90a99c0610e696e.tar.gz
freebsd-ports-gnome-af2bdda5acf9f0a191292a93f90a99c0610e696e.tar.zst
freebsd-ports-gnome-af2bdda5acf9f0a191292a93f90a99c0610e696e.zip
print, science: Add missing USES=gnome
Diffstat (limited to 'print')
-rw-r--r--print/abcm2ps/Makefile2
-rw-r--r--print/cups-pk-helper/Makefile2
-rw-r--r--print/deforaos-pdfviewer/Makefile2
-rw-r--r--print/foomatic-db-engine/Makefile2
-rw-r--r--print/libgnomecups/Makefile2
-rw-r--r--print/libgnomeprint/Makefile2
-rw-r--r--print/libgnomeprintmm/Makefile3
-rw-r--r--print/libspectre/Makefile2
-rw-r--r--print/lilypond-devel/Makefile4
-rw-r--r--print/paps/Makefile2
-rw-r--r--print/system-config-printer/Makefile4
11 files changed, 14 insertions, 13 deletions
diff --git a/print/abcm2ps/Makefile b/print/abcm2ps/Makefile
index 88371f628b01..2fc841fce06d 100644
--- a/print/abcm2ps/Makefile
+++ b/print/abcm2ps/Makefile
@@ -11,7 +11,7 @@ COMMENT= Converts ABC to music sheet in PostScript format
LICENSE= GPLv2
-USES= cpe gettext-runtime
+USES= cpe gettext-runtime gnome
MAKE_ARGS= CC="${CC}" CFLAGS="${CFLAGS}"
CPE_VENDOR= moinejf
GNU_CONFIGURE= yes
diff --git a/print/cups-pk-helper/Makefile b/print/cups-pk-helper/Makefile
index adb2907e5c77..7f512614fd45 100644
--- a/print/cups-pk-helper/Makefile
+++ b/print/cups-pk-helper/Makefile
@@ -16,7 +16,7 @@ LIB_DEPENDS= libcups.so:print/cups \
libpolkit-gobject-1.so:sysutils/polkit
USE_GNOME= glib20 intltool
-USES= cpe gettext localbase gmake pkgconfig tar:xz
+USES= cpe gettext gmake gnome localbase pkgconfig tar:xz
CPE_VENDOR= cups-pk-helper_project
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
diff --git a/print/deforaos-pdfviewer/Makefile b/print/deforaos-pdfviewer/Makefile
index c3092f2306a4..4124bbe1d85c 100644
--- a/print/deforaos-pdfviewer/Makefile
+++ b/print/deforaos-pdfviewer/Makefile
@@ -21,7 +21,7 @@ LIB_DEPENDS= libSystem.so:devel/deforaos-libsystem \
libfreetype.so:print/freetype2
MAKE_ARGS+= PREFIX=${PREFIX}
-USES= desktop-file-utils pkgconfig
+USES= desktop-file-utils gnome pkgconfig
USE_GNOME= gtk20 gdkpixbuf2 cairo
MAKE_ENV+= MANDIR=${STAGEDIR}${MANPREFIX}/man
diff --git a/print/foomatic-db-engine/Makefile b/print/foomatic-db-engine/Makefile
index dd6a52b00920..a51be7792f9f 100644
--- a/print/foomatic-db-engine/Makefile
+++ b/print/foomatic-db-engine/Makefile
@@ -14,7 +14,7 @@ LICENSE= GPLv2
LIB_DEPENDS= libcurl.so:ftp/curl
-USES= gmake perl5
+USES= gmake gnome perl5
USE_GNOME= libxml2
GNU_CONFIGURE= yes
CONFIGURE_ENV= PERL=${PERL} LIBDIR=${PREFIX}/share/foomatic/ \
diff --git a/print/libgnomecups/Makefile b/print/libgnomecups/Makefile
index 424ec38c3293..40b99b1ff136 100644
--- a/print/libgnomecups/Makefile
+++ b/print/libgnomecups/Makefile
@@ -14,7 +14,7 @@ COMMENT= Support library for gnome cups administration
LIB_DEPENDS= libcups.so:print/cups
-USES= pkgconfig pathfix gettext gmake libtool:keepla tar:bzip2
+USES= gettext gmake gnome libtool:keepla pathfix pkgconfig tar:bzip2
GNU_CONFIGURE= yes
USE_GNOME= intlhack glib20
USE_LDCONFIG= yes
diff --git a/print/libgnomeprint/Makefile b/print/libgnomeprint/Makefile
index d0abac45c9dc..dbc843851c6e 100644
--- a/print/libgnomeprint/Makefile
+++ b/print/libgnomeprint/Makefile
@@ -19,7 +19,7 @@ USES= tar:bzip2
LIB_DEPENDS= libfontconfig.so:x11-fonts/fontconfig
GNU_CONFIGURE= yes
-USES+= bison gettext gmake libtool:keepla pathfix pkgconfig
+USES+= bison gettext gmake gnome libtool:keepla pathfix pkgconfig
USE_GNOME= gnomeprefix intlhack glib20 pango libxml2 libartlgpl2
USE_LDCONFIG= yes
CPPFLAGS+= -I${LOCALBASE}/include
diff --git a/print/libgnomeprintmm/Makefile b/print/libgnomeprintmm/Makefile
index 6edeb4739a38..9bce3974fac0 100644
--- a/print/libgnomeprintmm/Makefile
+++ b/print/libgnomeprintmm/Makefile
@@ -14,7 +14,8 @@ COMMENT= C++ bindings for the GNOME print support library
LIB_DEPENDS= libgtkmm-2.4.so:x11-toolkits/gtkmm24
BUILD_DEPENDS= gm4:devel/m4
-USES= compiler:c++11-lang gmake libtool pathfix pkgconfig tar:bzip2
+USES= compiler:c++11-lang gmake gnome libtool pathfix pkgconfig \
+ tar:bzip2
USE_CXXSTD= c++11
USE_GNOME= gnomeprefix libgnomeprint
USE_LDCONFIG= yes
diff --git a/print/libspectre/Makefile b/print/libspectre/Makefile
index e47f6bb7c285..7a932f4dedd6 100644
--- a/print/libspectre/Makefile
+++ b/print/libspectre/Makefile
@@ -12,7 +12,7 @@ COMMENT= Small library for rendering Postscript documents
LICENSE= GPLv2
-USES= gmake libtool localbase pathfix pkgconfig ghostscript
+USES= ghostscript gmake gnome libtool localbase pathfix pkgconfig
USE_LDCONFIG= yes
USE_GNOME= cairo
GNU_CONFIGURE= yes
diff --git a/print/lilypond-devel/Makefile b/print/lilypond-devel/Makefile
index 1ae8f0c8e86a..d34d98aa3606 100644
--- a/print/lilypond-devel/Makefile
+++ b/print/lilypond-devel/Makefile
@@ -45,8 +45,8 @@ INFO= internals \
lilypond-web \
music-glossary
-USES= bison:build gettext ghostscript gmake pkgconfig perl5 \
- compiler:gcc-c++11-lib python:2.7
+USES= bison:build compiler:gcc-c++11-lib gettext ghostscript gmake \
+ gnome perl5 pkgconfig python:2.7
USE_CXXSTD= c++11
USE_TEX= latex texmf
USE_PERL5= build
diff --git a/print/paps/Makefile b/print/paps/Makefile
index 0d941402cd86..3bd4d3b559df 100644
--- a/print/paps/Makefile
+++ b/print/paps/Makefile
@@ -15,6 +15,6 @@ PLIST_FILES= bin/paps lib/libpaps.a include/libpaps.h \
GNU_CONFIGURE= yes
USE_GNOME= pango
-USES= pkgconfig
+USES= gnome pkgconfig
.include <bsd.port.mk>
diff --git a/print/system-config-printer/Makefile b/print/system-config-printer/Makefile
index 18ae03fd2b2c..6fa21d01ee12 100644
--- a/print/system-config-printer/Makefile
+++ b/print/system-config-printer/Makefile
@@ -21,8 +21,8 @@ RUN_DEPENDS= ${PYTHON_PKGNAMEPREFIX}pycups>=0:print/py-pycups@${PY_FLAVOR} \
PORTSCOUT= limitw:1,even
GNU_CONFIGURE= yes
-USES= desktop-file-utils gettext gmake pathfix pkgconfig python:2.7 \
- shebangfix tar:xz
+USES= desktop-file-utils gettext gmake gnome pathfix pkgconfig \
+ python:2.7 shebangfix tar:xz
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
USE_GNOME= intlhack pygobject3