aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorsobomax <sobomax@FreeBSD.org>2002-03-14 19:16:45 +0800
committersobomax <sobomax@FreeBSD.org>2002-03-14 19:16:45 +0800
commit2afa682dfaff5aacfa000d819c170a88d58ebd00 (patch)
tree4bc499a7118b337f272e102e7049d1a157a17452 /print
parent78839d23eba90e7948c9bd6e8ce5c4d6e145ef97 (diff)
downloadfreebsd-ports-gnome-2afa682dfaff5aacfa000d819c170a88d58ebd00.tar.gz
freebsd-ports-gnome-2afa682dfaff5aacfa000d819c170a88d58ebd00.tar.zst
freebsd-ports-gnome-2afa682dfaff5aacfa000d819c170a88d58ebd00.zip
Adjust in accordance with the new location of freetype1 includes
(${PREFIX}/include/freetype1/freetype, not ${PREFIX}/include/freetype).
Diffstat (limited to 'print')
-rw-r--r--print/gfontview/Makefile3
-rw-r--r--print/perlftlib/files/patch-ac2
-rw-r--r--print/py-freetype/files/patch-Setup.w322
-rw-r--r--print/ttftot42/Makefile2
4 files changed, 5 insertions, 4 deletions
diff --git a/print/gfontview/Makefile b/print/gfontview/Makefile
index 74b08eaa9654..a48edf0b00c8 100644
--- a/print/gfontview/Makefile
+++ b/print/gfontview/Makefile
@@ -21,7 +21,8 @@ USE_X_PREFIX= yes
USE_GNOME= yes
USE_FREETYPE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include/freetype1 \
+ -I${LOCALBASE}/include" \
SPOOLER="/usr/bin/lpr" \
LIBS="-L${LOCALBASE}/lib"
CONFIGURE_ARGS= --with-fontdir="${LOCALBASE}/share/ghostscript/fonts" \
diff --git a/print/perlftlib/files/patch-ac b/print/perlftlib/files/patch-ac
index 293d170b8567..9ff7ad62040c 100644
--- a/print/perlftlib/files/patch-ac
+++ b/print/perlftlib/files/patch-ac
@@ -5,6 +5,6 @@
'LIBS' => ['-L/usr/local/lib -lttf'], # e.g., '-lm'
'DEFINE' => '', # e.g., '-DHAVE_SOMETHING'
- 'INC' => '-I/usr/local/include', # e.g., '-I/usr/include/other'
-+ 'INC' => '-I/usr/local/include/freetype', # e.g., '-I/usr/include/other'
++ 'INC' => '-I/usr/local/include/freetype1/freetype', # e.g., '-I/usr/include/other'
);
diff --git a/print/py-freetype/files/patch-Setup.w32 b/print/py-freetype/files/patch-Setup.w32
index 1aab0ed61418..dc2126f30f9f 100644
--- a/print/py-freetype/files/patch-Setup.w32
+++ b/print/py-freetype/files/patch-Setup.w32
@@ -7,4 +7,4 @@ $FreeBSD$
#[MGW32]swig_options.extend(['-shadow', '-docstring'])
-freetypec freetype_wrap.c -I../../lib -I../../lib/extend -L../../lib -lttf.dll
+*shared*
-+freetypec freetype_wrap.c -I${LOCALBASE}/include/freetype -L${LOCALBASE}/lib -lttf
++freetypec freetype_wrap.c -I${LOCALBASE}/include/freetype1/freetype -L${LOCALBASE}/lib -lttf
diff --git a/print/ttftot42/Makefile b/print/ttftot42/Makefile
index 06400acfc811..d5b19f96eca8 100644
--- a/print/ttftot42/Makefile
+++ b/print/ttftot42/Makefile
@@ -14,6 +14,6 @@ MAINTAINER= nakai@FreeBSD.org
USE_FREETYPE= yes
GNU_CONFIGURE= yes
-CONFIGURE_ENV= "CFLAGS=-I${LOCALBASE}/include/freetype"
+CONFIGURE_ENV= "CFLAGS=-I${LOCALBASE}/include/freetype1/freetype"
.include <bsd.port.mk>