aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorjohans <johans@FreeBSD.org>2006-06-26 01:04:49 +0800
committerjohans <johans@FreeBSD.org>2006-06-26 01:04:49 +0800
commit964e1d32b02264bc3a3e6ae1951feda02c181854 (patch)
tree11eb95581896ef06e95407e88cbc40ccd8a5f74c /print
parent7530b7b88ec35f9202b71efb9951c6acb3424dae (diff)
downloadfreebsd-ports-gnome-964e1d32b02264bc3a3e6ae1951feda02c181854.tar.gz
freebsd-ports-gnome-964e1d32b02264bc3a3e6ae1951feda02c181854.tar.zst
freebsd-ports-gnome-964e1d32b02264bc3a3e6ae1951feda02c181854.zip
- Unbreak on 6.x (with a patch to please gcc)
PR: 95228 Submitted by: Kay Lehmann Approved by: Jaap Boender (maintainer), flz (mentor)
Diffstat (limited to 'print')
-rw-r--r--print/kaspaliste/Makefile4
-rw-r--r--print/kaspaliste/files/patch-kaspaliste_klib_kaspabase.cpp23
2 files changed, 23 insertions, 4 deletions
diff --git a/print/kaspaliste/Makefile b/print/kaspaliste/Makefile
index f4759c47dfa2..c06fbee77274 100644
--- a/print/kaspaliste/Makefile
+++ b/print/kaspaliste/Makefile
@@ -28,10 +28,6 @@ PKGMESSAGE= ${WRKDIR}/pkg-message
.include <bsd.port.pre.mk>
-.if ${OSVERSION} >= 600031
-BROKEN= "Does not compile on FreeBSD >= 6.0"
-.endif
-
pre-configure:
@${RM} ${WRKSRC}/config.cache
diff --git a/print/kaspaliste/files/patch-kaspaliste_klib_kaspabase.cpp b/print/kaspaliste/files/patch-kaspaliste_klib_kaspabase.cpp
new file mode 100644
index 000000000000..bce8c9bfa000
--- /dev/null
+++ b/print/kaspaliste/files/patch-kaspaliste_klib_kaspabase.cpp
@@ -0,0 +1,23 @@
+--- kaspaliste/klib/kaspabase.cpp.orig Sat Feb 7 10:54:32 2004
++++ kaspaliste/klib/kaspabase.cpp Sun Mar 19 12:34:42 2006
+@@ -184,7 +184,19 @@
+ LockTableItem *KaspaBase::locktable=0L;
+
+ Oid KaspaBase::getNo(Str tab, Oid o) {
+- exec("select no from "+tab+" where oid="+oid2str(o));
++ char* cdummy1 = "select no from ";
++ char* cdummy2 = " where oid=";
++
++ Str sdummy1, sdummy2, sdummy_all;
++ sdummy1 = cdummy1;
++ sdummy2 = cdummy2;
++ sdummy_all = sdummy1;
++ sdummy_all += tab;
++ sdummy_all += sdummy2;
++ sdummy_all += oid2str(o);
++
++ const char* cdummy_all = sdummy_all.data();
++ exec(cdummy_all);
+ if(tuples())
+ return str2oid(getValue(0, "no"));
+ else