aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorandreas <andreas@FreeBSD.org>2001-12-18 02:47:36 +0800
committerandreas <andreas@FreeBSD.org>2001-12-18 02:47:36 +0800
commitae46e8fc20d906a7902271efb5c1c45c94c0852b (patch)
tree68d5d775fafa8ee15076597a90f43910c832b61e /print
parent0237254ae99618c9f25edaf03d720d305d2dcea5 (diff)
downloadfreebsd-ports-gnome-ae46e8fc20d906a7902271efb5c1c45c94c0852b.tar.gz
freebsd-ports-gnome-ae46e8fc20d906a7902271efb5c1c45c94c0852b.tar.zst
freebsd-ports-gnome-ae46e8fc20d906a7902271efb5c1c45c94c0852b.zip
Unluckily FreeBSD's shell isn't able to read from/write to /dev/stdin
and stdout. Therefore we have to use bash as shell for /usr/local/bin/aps2file program. Arrange things with patch and pre-configure command, so that this port stays prefix-clean. The patch inserts !!PREFIX!!/bin/bash and configure configures in the current PREFIX settings. I'd whish somebody could fix our shell to remove the dependency from bash.
Diffstat (limited to 'print')
-rw-r--r--print/apsfilter/Makefile3
-rw-r--r--print/apsfilter/files/patch-bin::aps2file8
-rw-r--r--print/apsfilter/scripts/pre-configure5
3 files changed, 16 insertions, 0 deletions
diff --git a/print/apsfilter/Makefile b/print/apsfilter/Makefile
index d6b206652d89..794c8daaff5d 100644
--- a/print/apsfilter/Makefile
+++ b/print/apsfilter/Makefile
@@ -87,6 +87,9 @@ RUN_DEPENDS+= a2ps:${PORTSDIR}/print/a2ps-letter
RUN_DEPENDS+= psnup:${PORTSDIR}/print/psutils-letter
.endif
+# needed for aps2file :-/
+RUN_DEPENDS+= bash:${PORTSDIR}/shells/bash2
+
MAN1= apsfilter.1
MAN5= apsfilterrc.5
diff --git a/print/apsfilter/files/patch-bin::aps2file b/print/apsfilter/files/patch-bin::aps2file
new file mode 100644
index 000000000000..e614c8cb38e5
--- /dev/null
+++ b/print/apsfilter/files/patch-bin::aps2file
@@ -0,0 +1,8 @@
+--- bin/aps2file.orig Mon Dec 17 19:35:50 2001
++++ bin/aps2file Mon Dec 17 19:36:33 2001
+@@ -1,4 +1,4 @@
+-#!/bin/sh
++#! !!PREFIX!!/bin/bash
+ #
+ # $ApsCVS: src/apsfilter/bin/aps2file,v 1.1 2001/11/17 15:21:52 andreas Exp $
+ #
diff --git a/print/apsfilter/scripts/pre-configure b/print/apsfilter/scripts/pre-configure
new file mode 100644
index 000000000000..35c8ac22508d
--- /dev/null
+++ b/print/apsfilter/scripts/pre-configure
@@ -0,0 +1,5 @@
+#! /bin/sh
+
+perl -pi -e "s|!!PREFIX!!|$PREFIX|" ${WRKSRC}/bin/aps2file
+
+exit 0