aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorahze <ahze@FreeBSD.org>2009-12-14 09:19:55 +0800
committerahze <ahze@FreeBSD.org>2009-12-14 09:19:55 +0800
commitb91384281169f00a2f3d8c8d26a25d908302cd90 (patch)
tree8e75a1748642e126ccfc2b5b2b08fd9fe7943f4f /print
parent18727f21be0b5f2ccdc5e3d9deb3174229d8ff68 (diff)
downloadfreebsd-ports-gnome-b91384281169f00a2f3d8c8d26a25d908302cd90.tar.gz
freebsd-ports-gnome-b91384281169f00a2f3d8c8d26a25d908302cd90.tar.zst
freebsd-ports-gnome-b91384281169f00a2f3d8c8d26a25d908302cd90.zip
Make x11 optional
PR: ports/139888 Submitted by: Marcin Wisnicki <mwisnicki+freebsd@gmail.com>
Diffstat (limited to 'print')
-rw-r--r--print/cupsddk/Makefile17
-rw-r--r--print/cupsddk/files/patch-configure.in27
-rw-r--r--print/cupsddk/pkg-plist1
3 files changed, 41 insertions, 4 deletions
diff --git a/print/cupsddk/Makefile b/print/cupsddk/Makefile
index 723b7c25f859..ba92f06e41c7 100644
--- a/print/cupsddk/Makefile
+++ b/print/cupsddk/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cupsddk
PORTVERSION= 1.2.3
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES= print devel
MASTER_SITES= EASYSW
MASTER_SITE_SUBDIR= ${PORTNAME}/${DISTVERSION}
@@ -16,21 +16,30 @@ DISTNAME= ${PORTNAME}-${DISTVERSION}-source
MAINTAINER= ahze@FreeBSD.org
COMMENT= CUPS Driver Development Kit
-LIB_DEPENDS= fltk.1:${PORTSDIR}/x11-toolkits/fltk \
- cupsimage.2:${PORTSDIR}/print/cups-image
+LIB_DEPENDS= cupsimage.2:${PORTSDIR}/print/cups-image
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
GNU_CONFIGURE= yes
+USE_AUTOTOOLS= autoconf:262
USE_GMAKE= yes
+OPTIONS= X11 "built with FLTK gui" on
+
MAN1= commandtoescpx.1 commandtopclx.1 cupsprofile.1 ppdc.1 ppdhtml.1 \
ppdi.1 ppdmerge.1 ppdpo.1 rastertoescpx.1 rastertopclx.1
MAN5= ppdcfile.5
+.include <bsd.port.pre.mk>
+
.if defined(WITH_DEBUG)
CONFIGURE_ARGS+= --enable-debug
.endif
+.if defined(WITH_X11)
+LIB_DEPENDS+= fltk.1:${PORTSDIR}/x11-toolkits/fltk
+CONFIGURE_ARGS+= --with-fltk
+.endif
+
post-patch:
@${REINPLACE_CMD} -e 's|/cupsprofile.ppm|${DATADIR:S,${PREFIX}/share,,}/cupsprofile.ppm|' \
${WRKSRC}/cups/cupsprofile.c
@@ -40,4 +49,4 @@ post-patch:
post-install:
@${INSTALL_DATA} ${WRKSRC}/cups/cupsprofile.ppm ${DATADIR}
-.include <bsd.port.mk>
+.include <bsd.port.post.mk>
diff --git a/print/cupsddk/files/patch-configure.in b/print/cupsddk/files/patch-configure.in
new file mode 100644
index 000000000000..5807497bbe36
--- /dev/null
+++ b/print/cupsddk/files/patch-configure.in
@@ -0,0 +1,27 @@
+diff -urN configure.in configure.in
+--- configure.in 2007-10-05 22:42:17.000000000 +0200
++++ configure.in 2007-10-14 20:19:40.000000000 +0200
+@@ -155,14 +155,16 @@
+ AC_CHECK_HEADER(cups/cups.h,,AC_MSG_ERROR(CUPS headers are not installed!))
+
+ dnl Check for FLTK...
+-AC_PATH_PROG(FLTKCONFIG,fltk-config)
++AC_ARG_WITH([fltk], AS_HELP_STRING([--with-fltk], [Build with fltk library GUI (default: disabled)]))
+
+-if test "x$FLTKCONFIG" = x; then
+-# AC_MSG_ERROR([Sorry, the CUPS DDK requires FLTK 1.1.x.])
+- GUILIBS=""
+-else
+- CXXFLAGS="`$FLTKCONFIG --cflags` $CXXFLAGS"
+- GUILIBS="`$FLTKCONFIG --use-images --ldstaticflags`"
++if test "x$with_fltk" == "xyes"; then
++ AC_PATH_PROG(FLTKCONFIG,fltk-config)
++ if test "x$FLTKCONFIG" = x; then
++ AC_MSG_ERROR([Sorry, the CUPS DDK GUI requires FLTK 1.1.x.])
++ else
++ CXXFLAGS="`$FLTKCONFIG --cflags` $CXXFLAGS"
++ GUILIBS="`$FLTKCONFIG --use-images --ldstaticflags`"
++ fi
+ fi
+
+ AC_SUBST(FLTKCONFIG)
diff --git a/print/cupsddk/pkg-plist b/print/cupsddk/pkg-plist
index 970c44da5cbc..ef323a121b82 100644
--- a/print/cupsddk/pkg-plist
+++ b/print/cupsddk/pkg-plist
@@ -57,6 +57,7 @@ share/doc/cups/help/ref-ppdcfile.html
@dirrmtry share/cups/drv
@dirrmtry share/cups
@dirrmtry share/doc/cups/help
+@dirrmtry share/doc/cups/examples
@dirrmtry share/doc/cups
@dirrmtry libexec/cups/driver
@dirrmtry libexec/cups