aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorandreas <andreas@FreeBSD.org>2000-03-07 06:16:28 +0800
committerandreas <andreas@FreeBSD.org>2000-03-07 06:16:28 +0800
commitbdc3b9240e3d410958d6c483dd717b4e3d39fcf8 (patch)
tree8e48f01c0bcbbed64de5d69e2b002ae4a03655ca /print
parent20a8adb7264038337a4b79f2b30d1deacc976a8f (diff)
downloadfreebsd-ports-gnome-bdc3b9240e3d410958d6c483dd717b4e3d39fcf8.tar.gz
freebsd-ports-gnome-bdc3b9240e3d410958d6c483dd717b4e3d39fcf8.tar.zst
freebsd-ports-gnome-bdc3b9240e3d410958d6c483dd717b4e3d39fcf8.zip
apsfilter depends now on samba
make Windows Remote Printer support via smbclient an option in the dialogue config script. When running in batch mode it's included automatically
Diffstat (limited to 'print')
-rw-r--r--print/apsfilter/Makefile1
-rw-r--r--print/apsfilter/scripts/configure4
-rw-r--r--print/apsfilter6/Makefile1
-rw-r--r--print/apsfilter6/scripts/configure4
4 files changed, 10 insertions, 0 deletions
diff --git a/print/apsfilter/Makefile b/print/apsfilter/Makefile
index 1fb2841ef1f5..79f9eff76be1 100644
--- a/print/apsfilter/Makefile
+++ b/print/apsfilter/Makefile
@@ -22,6 +22,7 @@ RUN_DEPENDS+= anytopnm:${PORTSDIR}/graphics/netpbm
RUN_DEPENDS+= bunzip2:${PORTSDIR}/archivers/bzip2
RUN_DEPENDS+= a2ps:${PORTSDIR}/print/a2ps-letter
RUN_DEPENDS+= psnup:${PORTSDIR}/print/psutils-letter
+RUN_DEPENDS+= smbclient:${PORTSDIR}/net/samba
.endif
USE_BZIP2= yes
diff --git a/print/apsfilter/scripts/configure b/print/apsfilter/scripts/configure
index 1e8caebc3b08..5af845d04344 100644
--- a/print/apsfilter/scripts/configure
+++ b/print/apsfilter/scripts/configure
@@ -15,6 +15,7 @@ LETTER "LETTER printing" OFF \
LETTERDJ "LETTERDJ printing" ON \
A4 "A4 printing" OFF \
PS "Postscript and PDF files" ON \
+SAMBA "Windows Remote-Print Support" ON \
ENCRYPTED_PDF "Encrypted PDF files" ON \
ASCII "ASCII/English Text/Scripts" ON \
MAIL "Mail/News articles" ON \
@@ -65,6 +66,9 @@ while [ "$1" ]; do
\"PS\")
echo RUN_DEPENDS+=gs:${PORTSDIR}/print/ghostscript55
;;
+ \"SAMBA\")
+ echo RUN_DEPENDS+=smbclient:${PORTSDIR}/net/samba
+ ;;
\"ENCRYPTED_PDF\")
echo RUN_DEPENDS+=gs:${PORTSDIR}/print/ghostscript55
echo PDFENCRYPT=YES
diff --git a/print/apsfilter6/Makefile b/print/apsfilter6/Makefile
index 1fb2841ef1f5..79f9eff76be1 100644
--- a/print/apsfilter6/Makefile
+++ b/print/apsfilter6/Makefile
@@ -22,6 +22,7 @@ RUN_DEPENDS+= anytopnm:${PORTSDIR}/graphics/netpbm
RUN_DEPENDS+= bunzip2:${PORTSDIR}/archivers/bzip2
RUN_DEPENDS+= a2ps:${PORTSDIR}/print/a2ps-letter
RUN_DEPENDS+= psnup:${PORTSDIR}/print/psutils-letter
+RUN_DEPENDS+= smbclient:${PORTSDIR}/net/samba
.endif
USE_BZIP2= yes
diff --git a/print/apsfilter6/scripts/configure b/print/apsfilter6/scripts/configure
index 1e8caebc3b08..5af845d04344 100644
--- a/print/apsfilter6/scripts/configure
+++ b/print/apsfilter6/scripts/configure
@@ -15,6 +15,7 @@ LETTER "LETTER printing" OFF \
LETTERDJ "LETTERDJ printing" ON \
A4 "A4 printing" OFF \
PS "Postscript and PDF files" ON \
+SAMBA "Windows Remote-Print Support" ON \
ENCRYPTED_PDF "Encrypted PDF files" ON \
ASCII "ASCII/English Text/Scripts" ON \
MAIL "Mail/News articles" ON \
@@ -65,6 +66,9 @@ while [ "$1" ]; do
\"PS\")
echo RUN_DEPENDS+=gs:${PORTSDIR}/print/ghostscript55
;;
+ \"SAMBA\")
+ echo RUN_DEPENDS+=smbclient:${PORTSDIR}/net/samba
+ ;;
\"ENCRYPTED_PDF\")
echo RUN_DEPENDS+=gs:${PORTSDIR}/print/ghostscript55
echo PDFENCRYPT=YES