aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorbsam <bsam@FreeBSD.org>2014-04-05 03:27:51 +0800
committerbsam <bsam@FreeBSD.org>2014-04-05 03:27:51 +0800
commitd8c026559b8acfb93bcd58f700500ab355fd3256 (patch)
tree58d3ddb93500e63c8cc03119725be09b7b638e68 /print
parenteac8b0c3eaceb5ba2c85eef3ea0e09c576511807 (diff)
downloadfreebsd-ports-gnome-d8c026559b8acfb93bcd58f700500ab355fd3256.tar.gz
freebsd-ports-gnome-d8c026559b8acfb93bcd58f700500ab355fd3256.tar.zst
freebsd-ports-gnome-d8c026559b8acfb93bcd58f700500ab355fd3256.zip
Use CFLAGS+=-fno-blocks to unbreak systems with default gcc compiler.
This is a band-aid that should be reworked for systems with blocks and libdispatch support. Reported by: Anton Shterenlikht <mexas@bris.ac.uk> Discussed at: freebsd-ports@ MFH: 2014Q2
Diffstat (limited to 'print')
-rw-r--r--print/cups-base/Makefile10
1 files changed, 9 insertions, 1 deletions
diff --git a/print/cups-base/Makefile b/print/cups-base/Makefile
index 34f3872b1768..271384f5d581 100644
--- a/print/cups-base/Makefile
+++ b/print/cups-base/Makefile
@@ -299,4 +299,12 @@ post-install:
${INSTALL_SCRIPT} ${WRKDIR}/ulpt-cupsd.sh ${STAGEDIR}${PREFIX}/sbin/
.endif
-.include <bsd.port.mk>
+# This is just a band-aid to unbreak print/cups-client at systems with default gcc compiler,
+# should be reworked to build with blocks and libdispatch support (via options).
+#
+.include <bsd.port.pre.mk>
+.if defined(CUPS_CLIENT) && ${OPSYS} == "FreeBSD" && ${OSVERSION} > 1000000
+CFLAGS+= -fno-blocks
+.endif
+
+.include <bsd.port.post.mk>