aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1997-01-14 17:13:16 +0800
committerasami <asami@FreeBSD.org>1997-01-14 17:13:16 +0800
commitf13d94e747f5b4c8dd2c99dfe6c269f3860a889b (patch)
treee00b705613ff044b3ed77f5129ea816d34918146 /print
parent8e3ead4e2a247e63adddfd5b5f513c6a3ae8912d (diff)
downloadfreebsd-ports-gnome-f13d94e747f5b4c8dd2c99dfe6c269f3860a889b.tar.gz
freebsd-ports-gnome-f13d94e747f5b4c8dd2c99dfe6c269f3860a889b.tar.zst
freebsd-ports-gnome-f13d94e747f5b4c8dd2c99dfe6c269f3860a889b.zip
Remove RUN_DEPENDS to gs, there are too many versions around (3
English and 3 Japanese) and we don't want the package to have a @pkgdep on a particular version.
Diffstat (limited to 'print')
-rw-r--r--print/ghostview/Makefile7
-rw-r--r--print/ghostview/pkg-install9
-rw-r--r--print/gv/Makefile7
-rw-r--r--print/gv/pkg-install9
4 files changed, 26 insertions, 6 deletions
diff --git a/print/ghostview/Makefile b/print/ghostview/Makefile
index a382ce53c293..e4362a31ecf1 100644
--- a/print/ghostview/Makefile
+++ b/print/ghostview/Makefile
@@ -3,7 +3,7 @@
# Date created: 21 October 1994
# Whom: jkh
#
-# $Id: Makefile,v 1.7 1996/11/17 08:44:40 obrien Exp $
+# $Id: Makefile,v 1.8 1996/11/18 10:25:35 asami Exp $
#
DISTNAME= ghostview-1.5
@@ -12,8 +12,9 @@ MASTER_SITES= ${MASTER_SITE_GNU}
MAINTAINER= ports@FreeBSD.org
-RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript
-
USE_IMAKE= yes
+post-install:
+ @/bin/sh ${PKGDIR}/INSTALL ${PKGNAME} POST-INSTALL
+
.include <bsd.port.mk>
diff --git a/print/ghostview/pkg-install b/print/ghostview/pkg-install
new file mode 100644
index 000000000000..2d7c72fb0528
--- /dev/null
+++ b/print/ghostview/pkg-install
@@ -0,0 +1,9 @@
+#!/bin/sh
+if [ "$2" != "POST-INSTALL" ]; then
+ exit 0
+fi
+if ! which gs >/dev/null; then
+ echo "I can't find ghostscript (gs) in your search path."
+ echo "Please install your favorite version of ghostscript,"
+ echo "otherwise this program is useless."
+fi
diff --git a/print/gv/Makefile b/print/gv/Makefile
index 28783886e6c7..2b1bac236b51 100644
--- a/print/gv/Makefile
+++ b/print/gv/Makefile
@@ -3,7 +3,7 @@
# Date created: 16 Apr 1996
# Whom: thomas@ghpc8.ihf.rwth-aachen.de
#
-# $Id: Makefile,v 1.3 1996/08/27 07:25:43 tg Exp $
+# $Id: Makefile,v 1.4 1996/11/12 07:06:28 tg Exp $
#
DISTNAME= gv_2_7_6
@@ -14,11 +14,12 @@ MASTER_SITES= ftp://iphthf.physik.uni-mainz.de/pub/gv/unix/
MAINTAINER= tg@freebsd.org
LIB_DEPENDS= Xaw3d\\.6\\.:${PORTSDIR}/x11/Xaw3d
-RUN_DEPENDS= gs:${PORTSDIR}/print/ghostscript4
PATCH_STRIP= -p1
WRKSRC= ${WRKDIR}/gv
USE_IMAKE= yes
-.include <bsd.port.mk>
+post-install:
+ @/bin/sh ${PKGDIR}/INSTALL ${PKGNAME} POST-INSTALL
+.include <bsd.port.mk>
diff --git a/print/gv/pkg-install b/print/gv/pkg-install
new file mode 100644
index 000000000000..2d7c72fb0528
--- /dev/null
+++ b/print/gv/pkg-install
@@ -0,0 +1,9 @@
+#!/bin/sh
+if [ "$2" != "POST-INSTALL" ]; then
+ exit 0
+fi
+if ! which gs >/dev/null; then
+ echo "I can't find ghostscript (gs) in your search path."
+ echo "Please install your favorite version of ghostscript,"
+ echo "otherwise this program is useless."
+fi