aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorpgollucci <pgollucci@FreeBSD.org>2010-06-07 03:25:10 +0800
committerpgollucci <pgollucci@FreeBSD.org>2010-06-07 03:25:10 +0800
commit3ce7d09e6cb23f7c5b6ed1696276c8217b89b269 (patch)
treec83099a1416420b251b7dff34f02f34558b886bf /print
parent9e6b05898aa0f314786d557f8d5442836ca2c060 (diff)
downloadfreebsd-ports-gnome-3ce7d09e6cb23f7c5b6ed1696276c8217b89b269.tar.gz
freebsd-ports-gnome-3ce7d09e6cb23f7c5b6ed1696276c8217b89b269.tar.zst
freebsd-ports-gnome-3ce7d09e6cb23f7c5b6ed1696276c8217b89b269.zip
- GEMS are always RUN_DEPENDS of other GEMS
- Bump PORTREVISION when something other then BUILD_DEPENDS changes - Some minor verticle whitespace in some ports for consistency with the rest PR: ports/147551 Submitted by: pgollucci@ (myself) Reviewed by: portmgr (pav) With Hat: ruby
Diffstat (limited to 'print')
-rw-r--r--print/rubygem-color/Makefile3
-rw-r--r--print/rubygem-pdfwriter/Makefile6
-rw-r--r--print/rubygem-prawn-format/Makefile3
-rw-r--r--print/rubygem-prawn/Makefile3
4 files changed, 6 insertions, 9 deletions
diff --git a/print/rubygem-color/Makefile b/print/rubygem-color/Makefile
index 0ccd9ecd3d50..5483c63b6dc2 100644
--- a/print/rubygem-color/Makefile
+++ b/print/rubygem-color/Makefile
@@ -14,9 +14,8 @@ DISTNAME= color-${PORTVERSION}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= Provides colour space definition and manpiulation
-BUILD_DEPENDS= rubygem-archive-tar-minitar>=0.5.1:${PORTSDIR}/archivers/rubygem-archive-tar-minitar \
+RUN_DEPENDS= rubygem-archive-tar-minitar>=0.5.1:${PORTSDIR}/archivers/rubygem-archive-tar-minitar \
rubygem-hoe>=1.3.0:${PORTSDIR}/devel/rubygem-hoe
-RUN_DEPENDS= ${BUILD_DEPENDS}
USE_RUBY= yes
USE_RUBYGEMS= yes
diff --git a/print/rubygem-pdfwriter/Makefile b/print/rubygem-pdfwriter/Makefile
index 0637ab1309a6..f8c29996da7d 100644
--- a/print/rubygem-pdfwriter/Makefile
+++ b/print/rubygem-pdfwriter/Makefile
@@ -14,13 +14,13 @@ DISTNAME= pdf-writer-${PORTVERSION}
MAINTAINER= dinoex@FreeBSD.org
COMMENT= A pure Ruby PDF document creation library
-BUILD_DEPENDS= rubygem-color>=1.4.0:${PORTSDIR}/print/rubygem-color \
+RUN_DEPENDS= rubygem-color>=1.4.0:${PORTSDIR}/print/rubygem-color \
rubygem-transactionsimple>=1.4.0:${PORTSDIR}/devel/rubygem-transactionsimple
-RUN_DEPENDS= ${BUILD_DEPENDS}
+
+GEM_NAME= ${DISTNAME}
USE_RUBY= yes
USE_RUBYGEMS= yes
-GEM_NAME= ${DISTNAME}
RUBYGEM_AUTOPLIST= yes
PLIST_FILES= bin/techbook
diff --git a/print/rubygem-prawn-format/Makefile b/print/rubygem-prawn-format/Makefile
index e3bdf4881b08..682b567d78da 100644
--- a/print/rubygem-prawn-format/Makefile
+++ b/print/rubygem-prawn-format/Makefile
@@ -12,8 +12,7 @@ MASTER_SITES= RF/prawn
MAINTAINER= wen@FreeBSD.org
COMMENT= An extension of Prawn that allows inline formatting
-BUILD_DEPENDS= rubygem-prawn-core>=0:${PORTSDIR}/print/rubygem-prawn-core
-RUN_DEPENDS= ${BUILD_DEPENDS}
+RUN_DEPENDS= rubygem-prawn-core>=0:${PORTSDIR}/print/rubygem-prawn-core
USE_RUBY= yes
USE_RUBYGEMS= yes
diff --git a/print/rubygem-prawn/Makefile b/print/rubygem-prawn/Makefile
index b0b689501399..d73bad164651 100644
--- a/print/rubygem-prawn/Makefile
+++ b/print/rubygem-prawn/Makefile
@@ -12,11 +12,10 @@ MASTER_SITES= RF/prawn
MAINTAINER= wen@FreeBSD.org
COMMENT= Fast pure Ruby PDF generator
-BUILD_DEPENDS= rubygem-prawn-layout>=0.3.1:${PORTSDIR}/print/rubygem-prawn-layout \
+RUN_DEPENDS= rubygem-prawn-layout>=0.3.1:${PORTSDIR}/print/rubygem-prawn-layout \
rubygem-prawn-format>=0.2.2:${PORTSDIR}/print/rubygem-prawn-format \
rubygem-prawn-security>=0.1.1:${PORTSDIR}/print/rubygem-prawn-security \
rubygem-prawn-core>=0.6.1:${PORTSDIR}/print/rubygem-prawn-core
-RUN_DEPENDS= ${BUILD_DEPENDS}
USE_RUBY= yes
USE_RUBYGEMS= yes