aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2006-04-30 00:16:56 +0800
committerpav <pav@FreeBSD.org>2006-04-30 00:16:56 +0800
commita91edddee8c3871417b75b6b25710d0e9ce90e57 (patch)
tree087e15990177e730775485074b209f3dfed2a5d5 /print
parent57458233d2356131339355694b9863d68dbd02b9 (diff)
downloadfreebsd-ports-gnome-a91edddee8c3871417b75b6b25710d0e9ce90e57.tar.gz
freebsd-ports-gnome-a91edddee8c3871417b75b6b25710d0e9ce90e57.tar.zst
freebsd-ports-gnome-a91edddee8c3871417b75b6b25710d0e9ce90e57.zip
PyScript is a python module for producing high quality postscript
graphics. Rather than use a GUI to draw a picture, the picture is programmed using python and the PyScript objects. Some of the key features are: * All scripting is done in python, which is a high level, easy to learn, well-developed scripting language. * All the objects can be translated, scaled, rotated, ... in fact any affine transformation. * Plain text is automatically kerned. * You can place arbitrary LaTeX expressions on your figures. * You can create your own figure objects, and develop a library of figure primitives. * Output is publication quality. Author: Alexei Gilchrist, Paul Cochrane <aalexei@users.sourceforge.net> WWW: http://pyscript.sourceforge.net/ PR: ports/96482 Submitted by: Nicola Vitale <nivit@email.it>
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/py-pyscript/Makefile48
-rw-r--r--print/py-pyscript/distinfo3
-rw-r--r--print/py-pyscript/pkg-descr18
-rw-r--r--print/py-pyscript/pkg-plist127
5 files changed, 197 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index 049736b56112..0b04975cdbdc 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -255,6 +255,7 @@
SUBDIR += pup
SUBDIR += py-fonttools
SUBDIR += py-freetype
+ SUBDIR += py-pyscript
SUBDIR += py-reportlab
SUBDIR += py-rtf
SUBDIR += rlpr
diff --git a/print/py-pyscript/Makefile b/print/py-pyscript/Makefile
new file mode 100644
index 000000000000..b406c74aecc3
--- /dev/null
+++ b/print/py-pyscript/Makefile
@@ -0,0 +1,48 @@
+# New ports collection makefile for: py-script
+# Date created: 2006-04-28
+# Whom: Nicola Vitale <nivit@email.it>
+#
+# $FreeBSD$
+#
+
+PORTNAME= pyscript
+PORTVERSION= 0.6
+CATEGORIES= print graphics
+MASTER_SITES= ${MASTER_SITE_SOURCEFORGE}
+MASTER_SITE_SUBDIR= ${PORTNAME}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= nivit@email.it
+COMMENT= Python module for producing high quality PostScript graphics
+
+RUN_DEPENDS= latex:${PORTSDIR}/print/teTeX-base \
+ dvips:${PORTSDIR}/print/dvipsk-tetex
+
+USE_PYTHON= yes
+USE_PYDISTUTILS= yes
+
+DATADIR= ${PYTHON_SITELIBDIR}/${PORTNAME}
+
+PYSCRIPT_EXAMPLES= doc/examples/*.py
+PYSCRIPT_MANUAL= doc/manual/pyscript.pdf
+
+.if defined(WITHOUT_EXAMPLES)
+PORTEXAMPLES= "@comment "
+.else
+PORTEXAMPLES= ""
+.endif
+PLIST_SUB+= PORTEXAMPLES=${PORTEXAMPLES}
+
+post-install:
+
+.if !defined(WITHOUT_EXAMPLES)
+ ${MKDIR} ${EXAMPLESDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PYSCRIPT_EXAMPLES} ${EXAMPLESDIR}
+.endif
+
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/${PYSCRIPT_MANUAL} ${DOCSDIR}
+.endif
+
+.include <bsd.port.mk>
diff --git a/print/py-pyscript/distinfo b/print/py-pyscript/distinfo
new file mode 100644
index 000000000000..4a876e48daae
--- /dev/null
+++ b/print/py-pyscript/distinfo
@@ -0,0 +1,3 @@
+MD5 (pyscript-0.6.tar.gz) = 8b4945fda4318abdcd77f1573996b9da
+SHA256 (pyscript-0.6.tar.gz) = 8ade2acbc2d46978f09931b160a1618c5fb028496830f0c14169021f5c5f3081
+SIZE (pyscript-0.6.tar.gz) = 398220
diff --git a/print/py-pyscript/pkg-descr b/print/py-pyscript/pkg-descr
new file mode 100644
index 000000000000..414e169ffe0d
--- /dev/null
+++ b/print/py-pyscript/pkg-descr
@@ -0,0 +1,18 @@
+PyScript is a python module for producing high quality postscript
+graphics. Rather than use a GUI to draw a picture, the picture is
+programmed using python and the PyScript objects.
+
+Some of the key features are:
+
+ * All scripting is done in python, which is a high level, easy
+ to learn, well-developed scripting language.
+ * All the objects can be translated, scaled, rotated, ... in fact
+ any affine transformation.
+ * Plain text is automatically kerned.
+ * You can place arbitrary LaTeX expressions on your figures.
+ * You can create your own figure objects, and develop a library
+ of figure primitives.
+ * Output is publication quality.
+
+Author: Alexei Gilchrist, Paul Cochrane <aalexei@users.sourceforge.net>
+WWW: http://pyscript.sourceforge.net/
diff --git a/print/py-pyscript/pkg-plist b/print/py-pyscript/pkg-plist
new file mode 100644
index 000000000000..008917a7982e
--- /dev/null
+++ b/print/py-pyscript/pkg-plist
@@ -0,0 +1,127 @@
+@comment $FreeBSD$
+bin/pyscript
+%%DATADIR%%/__init__.py
+%%DATADIR%%/__init__.pyc
+%%DATADIR%%/__init__.pyo
+%%DATADIR%%/afm.py
+%%DATADIR%%/afm.pyc
+%%DATADIR%%/afm.pyo
+%%DATADIR%%/arrowheads.py
+%%DATADIR%%/arrowheads.pyc
+%%DATADIR%%/arrowheads.pyo
+%%DATADIR%%/base.py
+%%DATADIR%%/base.pyc
+%%DATADIR%%/base.pyo
+%%DATADIR%%/defaults.py
+%%DATADIR%%/defaults.pyc
+%%DATADIR%%/defaults.pyo
+%%DATADIR%%/fonts/__init__.py
+%%DATADIR%%/fonts/__init__.pyc
+%%DATADIR%%/fonts/__init__.pyo
+%%DATADIR%%/fonts/courier.py
+%%DATADIR%%/fonts/courier.pyc
+%%DATADIR%%/fonts/courier.pyo
+%%DATADIR%%/fonts/courier_bold.py
+%%DATADIR%%/fonts/courier_bold.pyc
+%%DATADIR%%/fonts/courier_bold.pyo
+%%DATADIR%%/fonts/courier_boldoblique.py
+%%DATADIR%%/fonts/courier_boldoblique.pyc
+%%DATADIR%%/fonts/courier_boldoblique.pyo
+%%DATADIR%%/fonts/courier_oblique.py
+%%DATADIR%%/fonts/courier_oblique.pyc
+%%DATADIR%%/fonts/courier_oblique.pyo
+%%DATADIR%%/fonts/helvetica.py
+%%DATADIR%%/fonts/helvetica.pyc
+%%DATADIR%%/fonts/helvetica.pyo
+%%DATADIR%%/fonts/helvetica_bold.py
+%%DATADIR%%/fonts/helvetica_bold.pyc
+%%DATADIR%%/fonts/helvetica_bold.pyo
+%%DATADIR%%/fonts/helvetica_boldoblique.py
+%%DATADIR%%/fonts/helvetica_boldoblique.pyc
+%%DATADIR%%/fonts/helvetica_boldoblique.pyo
+%%DATADIR%%/fonts/helvetica_oblique.py
+%%DATADIR%%/fonts/helvetica_oblique.pyc
+%%DATADIR%%/fonts/helvetica_oblique.pyo
+%%DATADIR%%/fonts/symbol.py
+%%DATADIR%%/fonts/symbol.pyc
+%%DATADIR%%/fonts/symbol.pyo
+%%DATADIR%%/fonts/times_bold.py
+%%DATADIR%%/fonts/times_bold.pyc
+%%DATADIR%%/fonts/times_bold.pyo
+%%DATADIR%%/fonts/times_bolditalic.py
+%%DATADIR%%/fonts/times_bolditalic.pyc
+%%DATADIR%%/fonts/times_bolditalic.pyo
+%%DATADIR%%/fonts/times_italic.py
+%%DATADIR%%/fonts/times_italic.pyc
+%%DATADIR%%/fonts/times_italic.pyo
+%%DATADIR%%/fonts/times_roman.py
+%%DATADIR%%/fonts/times_roman.pyc
+%%DATADIR%%/fonts/times_roman.pyo
+%%DATADIR%%/fonts/zapfdingbats.py
+%%DATADIR%%/fonts/zapfdingbats.pyc
+%%DATADIR%%/fonts/zapfdingbats.pyo
+%%DATADIR%%/groups.py
+%%DATADIR%%/groups.pyc
+%%DATADIR%%/groups.pyo
+%%DATADIR%%/lib/__init__.py
+%%DATADIR%%/lib/__init__.pyc
+%%DATADIR%%/lib/__init__.pyo
+%%DATADIR%%/lib/electronics.py
+%%DATADIR%%/lib/electronics.pyc
+%%DATADIR%%/lib/electronics.pyo
+%%DATADIR%%/lib/optics.py
+%%DATADIR%%/lib/optics.pyc
+%%DATADIR%%/lib/optics.pyo
+%%DATADIR%%/lib/present.py
+%%DATADIR%%/lib/present.pyc
+%%DATADIR%%/lib/present.pyo
+%%DATADIR%%/lib/presentation.py
+%%DATADIR%%/lib/presentation.pyc
+%%DATADIR%%/lib/presentation.pyo
+%%DATADIR%%/lib/qi.py
+%%DATADIR%%/lib/qi.pyc
+%%DATADIR%%/lib/qi.pyo
+%%DATADIR%%/lib/quantumcircuits.py
+%%DATADIR%%/lib/quantumcircuits.pyc
+%%DATADIR%%/lib/quantumcircuits.pyo
+%%DATADIR%%/objects.py
+%%DATADIR%%/objects.pyc
+%%DATADIR%%/objects.pyo
+%%DATADIR%%/path.py
+%%DATADIR%%/path.pyc
+%%DATADIR%%/path.pyo
+%%DATADIR%%/render.py
+%%DATADIR%%/render.pyc
+%%DATADIR%%/render.pyo
+%%DATADIR%%/vectors.py
+%%DATADIR%%/vectors.pyc
+%%DATADIR%%/vectors.pyo
+%%DATADIR%%/version.py
+%%DATADIR%%/version.pyc
+%%DATADIR%%/version.pyo
+%%PORTDOCS%%%%DOCSDIR%%/pyscript.pdf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/align.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/align2.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/atom.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/bifurcate.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ccp2004_poster.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/detector.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/distribute.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/div_con.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/fabry-perot_pdh.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/flower_algorithm.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/mach-zehnder.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/michelson-morely.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/qcirc.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sagnac.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/sphere.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/stateSwap.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/teleport.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tex.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/tutorial.py
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/twoqubitQST.py
+@dirrm %%DATADIR%%/fonts
+@dirrm %%DATADIR%%/lib
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%