aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorhrs <hrs@FreeBSD.org>2015-11-12 11:29:10 +0800
committerhrs <hrs@FreeBSD.org>2015-11-12 11:29:10 +0800
commitb99903fb8e06446642bc16ce99ee2e31feaaea54 (patch)
treed6759481507afac2dc0dee83efdb57d8ff2b9068 /print
parentcf8bf357d57dd521e39f2bb310b460657b3359fe (diff)
downloadfreebsd-ports-gnome-b99903fb8e06446642bc16ce99ee2e31feaaea54.tar.gz
freebsd-ports-gnome-b99903fb8e06446642bc16ce99ee2e31feaaea54.tar.zst
freebsd-ports-gnome-b99903fb8e06446642bc16ce99ee2e31feaaea54.zip
Update to 1.6.1 and add patches to fix issues reported
in PR 203637. Submitted by: Tatsuki Makino (maintainer) PR: 204250
Diffstat (limited to 'print')
-rw-r--r--print/epson-inkjet-printer-escpr/Makefile5
-rw-r--r--print/epson-inkjet-printer-escpr/distinfo4
-rw-r--r--print/epson-inkjet-printer-escpr/files/patch-configure.ac2
-rw-r--r--print/epson-inkjet-printer-escpr/files/patch-lib-epson-escpr-api-private.h2
-rw-r--r--print/epson-inkjet-printer-escpr/files/patch-lib_epson-usb.c11
-rw-r--r--print/epson-inkjet-printer-escpr/files/patch-src-filter.c95
-rw-r--r--print/epson-inkjet-printer-escpr/files/pkg-message.in22
-rw-r--r--print/epson-inkjet-printer-escpr/pkg-plist3
8 files changed, 137 insertions, 7 deletions
diff --git a/print/epson-inkjet-printer-escpr/Makefile b/print/epson-inkjet-printer-escpr/Makefile
index 310d7352934b..27216a6a6d1e 100644
--- a/print/epson-inkjet-printer-escpr/Makefile
+++ b/print/epson-inkjet-printer-escpr/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= epson-inkjet-printer-escpr
-PORTVERSION= 1.6.0
+PORTVERSION= 1.6.1
DISTVERSIONSUFFIX= -1lsb3.2
CATEGORIES= print
MASTER_SITES= LOCAL/hrs
@@ -15,11 +15,12 @@ BUILD_DEPENDS= cups-config:${PORTSDIR}/print/cups-client
LIB_DEPENDS= libcups.so:${PORTSDIR}/print/cups-client\
libcupsimage.so:${PORTSDIR}/print/cups-image
-USES= autoreconf gmake libtool
+USES= autoreconf dos2unix gmake libtool
USE_LDCONFIG= yes
WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
GNU_CONFIGURE= yes
INSTALL_TARGET= install-strip
+SUB_FILES= pkg-message
PORTDOCS= AUTHORS COPYING NEWS README README.ja
OPTIONS_DEFINE= DOCS
diff --git a/print/epson-inkjet-printer-escpr/distinfo b/print/epson-inkjet-printer-escpr/distinfo
index bcdf0f8b999f..7d92302e2e79 100644
--- a/print/epson-inkjet-printer-escpr/distinfo
+++ b/print/epson-inkjet-printer-escpr/distinfo
@@ -1,2 +1,2 @@
-SHA256 (epson-inkjet-printer-escpr-1.6.0-1lsb3.2.tar.gz) = 745aa837edfca269800d3c5fd2b81b40f4e3e9a316bc0c1a3e265260e3184f95
-SIZE (epson-inkjet-printer-escpr-1.6.0-1lsb3.2.tar.gz) = 3005609
+SHA256 (epson-inkjet-printer-escpr-1.6.1-1lsb3.2.tar.gz) = bb7dea7439c571662db9cf7a8834cb87ed69fa249a7945218403187c6097c76f
+SIZE (epson-inkjet-printer-escpr-1.6.1-1lsb3.2.tar.gz) = 3044091
diff --git a/print/epson-inkjet-printer-escpr/files/patch-configure.ac b/print/epson-inkjet-printer-escpr/files/patch-configure.ac
index 5e91f7ba7f67..b7d6cef81f99 100644
--- a/print/epson-inkjet-printer-escpr/files/patch-configure.ac
+++ b/print/epson-inkjet-printer-escpr/files/patch-configure.ac
@@ -1,4 +1,4 @@
---- configure.ac.orig 2015-08-31 23:48:56 UTC
+--- configure.ac.orig 2015-10-23 06:30:33 UTC
+++ configure.ac
@@ -58,9 +58,9 @@ AC_ARG_WITH([cupsfilterdir],
if test "xno" = "x${with_cupsfilterdir}"; then
diff --git a/print/epson-inkjet-printer-escpr/files/patch-lib-epson-escpr-api-private.h b/print/epson-inkjet-printer-escpr/files/patch-lib-epson-escpr-api-private.h
index 89b1a717c684..804f5803b492 100644
--- a/print/epson-inkjet-printer-escpr/files/patch-lib-epson-escpr-api-private.h
+++ b/print/epson-inkjet-printer-escpr/files/patch-lib-epson-escpr-api-private.h
@@ -1,4 +1,4 @@
---- lib/epson-escpr-api-private.h.orig 2015-10-01 04:30:19 UTC
+--- lib/epson-escpr-api-private.h.orig 1970-01-01 00:00:00 UTC
+++ lib/epson-escpr-api-private.h
@@ -0,0 +1,3 @@
+EPS_ERR_CODE SetupJobAttrib(const EPS_JOB_ATTRIB*);
diff --git a/print/epson-inkjet-printer-escpr/files/patch-lib_epson-usb.c b/print/epson-inkjet-printer-escpr/files/patch-lib_epson-usb.c
new file mode 100644
index 000000000000..75933a97f197
--- /dev/null
+++ b/print/epson-inkjet-printer-escpr/files/patch-lib_epson-usb.c
@@ -0,0 +1,11 @@
+--- lib/epson-usb.c.orig 2014-08-19 02:29:44 UTC
++++ lib/epson-usb.c
+@@ -2325,7 +2325,7 @@ static EPS_ERR_CODE GetSerialNumber (
+ EPS_RETURN( ret );
+ }
+
+- tmpBuff = (EPS_INT8*)EPS_ALLOC(tmpBuffSize);
++ tmpBuff = (EPS_UINT8*)EPS_ALLOC(tmpBuffSize);
+ if (tmpBuff == NULL) {
+ EPS_RETURN( EPS_ERR_MEMORY_ALLOCATION );
+ }
diff --git a/print/epson-inkjet-printer-escpr/files/patch-src-filter.c b/print/epson-inkjet-printer-escpr/files/patch-src-filter.c
index d2735b472576..6960eaf68a3c 100644
--- a/print/epson-inkjet-printer-escpr/files/patch-src-filter.c
+++ b/print/epson-inkjet-printer-escpr/files/patch-src-filter.c
@@ -1,10 +1,103 @@
--- src/filter.c.orig 2015-09-02 06:47:47 UTC
+++ src/filter.c
-@@ -35,6 +35,7 @@
+@@ -35,8 +35,10 @@
#include "epson-escpr-media.h"
#include "epson-protocol.h"
#include "epson-escpr-api.h"
+#include "epson-escpr-api-private.h"
#include "epson-escpr-services.h"
#include "epson-escpr-mem.h"
++#include "epson-escpage.h"
+ #include "err.h"
+ #include "mem.h"
+@@ -45,6 +47,7 @@
+ #include "libprtX.h"
+ #include "optBase.h"
+ #include "linux_cmn.h"
++#include "xfifo.h"
+
+ #define WIDTH_BYTES(bits) (((bits) + 31) / 32 * 4)
+
+@@ -385,7 +388,7 @@ main (int argc, char *argv[])
+ }
+
+ printJob.jobStatus = EPS_STATUS_ESTABLISHED;
+- int printHeight = 0;
++ EPS_UINT32 printHeight = 0;
+ ///////////////////////////////////////////////////////////////////////////////////////////////////////////
+
+ print_area_x = printJob.printableAreaWidth;
+@@ -416,7 +419,7 @@ main (int argc, char *argv[])
+ while ((read_page_no = read (STDIN_FILENO, &page_num, 1)) > 0) // 最初に page番号を読み込み
+ {
+ long x_count, y_count;
+- int band_line_count;
++ EPS_UINT32 band_line_count;
+ y_count = 0;
+ band_line_count = 0;
+
+@@ -504,7 +507,11 @@ main (int argc, char *argv[])
+ pagebuf+= bandBmp.widthBytes;
+ posbuf+=bandBmp.widthBytes;
+
++ if (band_line_count > printHeight) {
+ band_line_count -= printHeight;
++ } else {
++ band_line_count = 0;
++ }
+ bandBmp.bits += band_line_count;
+
+ }
+@@ -515,13 +522,17 @@ main (int argc, char *argv[])
+ memcpy(pagebuf, bandBmp.bits, bandBmp.widthBytes);
+ pagebuf+= bandBmp.widthBytes;
+ posbuf+= bandBmp.widthBytes;
++ if (band_line_count > printHeight) {
+ band_line_count -= printHeight;
++ } else {
++ band_line_count = 0;
++ }
+ bandBmp.bits += band_line_count;
+ }
+
+ int revert = 0;
+ int pos = posbuf - bandBmp.widthBytes ;
+- char *rever_buf = malloc(bandBmp.widthBytes + 1000);
++ EPS_UINT8 *rever_buf = (EPS_UINT8 *)malloc(bandBmp.widthBytes + 1000);
+ for (revert = print_area_y; revert > 0; revert--)
+ {
+ if (3 != byte_par_pixel)
+@@ -665,7 +676,11 @@ main (int argc, char *argv[])
+ #endif
+ debug_msg("printHeight = %d\n", printHeight);
+ debug_msg("widthByte = %d\n", bandBmp.widthBytes);
++ if (band_line_count > printHeight) {
+ band_line_count -= printHeight;
++ } else {
++ band_line_count = 0;
++ }
+ bandBmp.bits += band_line_count;
+ }
+
+@@ -687,7 +702,11 @@ main (int argc, char *argv[])
+ fprintf(fp, "\n");
+ fclose(fp);
+ #endif
++ if (band_line_count > printHeight) {
+ band_line_count -= printHeight;
++ } else {
++ band_line_count = 0;
++ }
+ bandBmp.bits += band_line_count;
+ }
+
+@@ -886,7 +905,7 @@ EPS_INT32 print_spool_fnc(void* hParam,
+
+ // fwrite (pBuf, cbBuf, 1, outfp);
+
+- XFIFOWrite(context, pBuf, cbBuf);
++ XFIFOWrite(context, (char *)pBuf, cbBuf);
+
+ return 1;
+ }
diff --git a/print/epson-inkjet-printer-escpr/files/pkg-message.in b/print/epson-inkjet-printer-escpr/files/pkg-message.in
new file mode 100644
index 000000000000..88036303679e
--- /dev/null
+++ b/print/epson-inkjet-printer-escpr/files/pkg-message.in
@@ -0,0 +1,22 @@
+
+Examples to add printer for EP-803AW
+
+# The printer connected with USB cable (using ulpt0)
+
+chown :cups /dev/ulpt0
+chmod g+rw /dev/ulpt0
+lpadmin -p EPSON_EP-803AW -m "`lpinfo --make-and-model 'EPSON EP-803A' -m | cut -f 1 -d ' '`" -v 'usb:/dev/ulpt0' -D 'EPSON EP-803AW (ulpt0)' -E
+
+# The printer connected with USB cable (using unlpt0)
+
+chown :cups /dev/unlpt0
+chmod g+rw /dev/unlpt0
+lpadmin -p EPSON_EP-803AW -m "`lpinfo --make-and-model 'EPSON EP-803A' -m | cut -f 1 -d ' '`" -v 'usb:/dev/unlpt0' -D 'EPSON EP-803AW (unlpt0)' -E
+
+# The printer joined network (using LPD port)
+
+lpadmin -p EPSON_EP-803AW -m "`lpinfo --make-and-model 'EPSON EP-803A' -m | cut -f 1 -d ' '`" -v 'lpd://192.0.2.100:515/PASSTHRU' -D 'EPSON EP-803AW (LPR)' -E
+
+# The printer joined network (using port 9100)
+
+lpadmin -p EPSON_EP-803AW -m "`lpinfo --make-and-model 'EPSON EP-803A' -m | cut -f 1 -d ' '`" -v 'socket://192.0.2.100:9100' -D 'EPSON EP-803AW (RAW)' -E
diff --git a/print/epson-inkjet-printer-escpr/pkg-plist b/print/epson-inkjet-printer-escpr/pkg-plist
index 8c590888b02e..76747ef442df 100644
--- a/print/epson-inkjet-printer-escpr/pkg-plist
+++ b/print/epson-inkjet-printer-escpr/pkg-plist
@@ -79,6 +79,7 @@ share/cups/model/epson-inkjet-printer-escpr/Epson-K300-epson-escpr-en.ppd
share/cups/model/epson-inkjet-printer-escpr/Epson-L455_Series-epson-escpr-en.ppd
share/cups/model/epson-inkjet-printer-escpr/Epson-L565_Series-epson-escpr-en.ppd
share/cups/model/epson-inkjet-printer-escpr/Epson-L655_Series-epson-escpr-en.ppd
+share/cups/model/epson-inkjet-printer-escpr/Epson-L805_Series-epson-escpr-en.ppd
share/cups/model/epson-inkjet-printer-escpr/Epson-L810_Series-epson-escpr-en.ppd
share/cups/model/epson-inkjet-printer-escpr/Epson-L850_Series-epson-escpr-en.ppd
share/cups/model/epson-inkjet-printer-escpr/Epson-M200_Series-epson-escpr-en.ppd
@@ -103,6 +104,7 @@ share/cups/model/epson-inkjet-printer-escpr/Epson-NX230_TX230-epson-escpr-en.ppd
share/cups/model/epson-inkjet-printer-escpr/Epson-NX430_TX435-epson-escpr-en.ppd
share/cups/model/epson-inkjet-printer-escpr/Epson-PF-70_Series-epson-escpr-en.ppd
share/cups/model/epson-inkjet-printer-escpr/Epson-PF-81_Series-epson-escpr-en.ppd
+share/cups/model/epson-inkjet-printer-escpr/Epson-PM-400_Series-epson-escpr-en.ppd
share/cups/model/epson-inkjet-printer-escpr/Epson-PM-A750-epson-escpr-en.ppd
share/cups/model/epson-inkjet-printer-escpr/Epson-PM-A820-epson-escpr-en.ppd
share/cups/model/epson-inkjet-printer-escpr/Epson-PM-A840-epson-escpr-en.ppd
@@ -357,6 +359,7 @@ share/cups/model/epson-inkjet-printer-escpr/Epson-WF-5190_Series-epson-escpr-en.
share/cups/model/epson-inkjet-printer-escpr/Epson-WF-5620_Series-epson-escpr-en.ppd
share/cups/model/epson-inkjet-printer-escpr/Epson-WF-5690_Series-epson-escpr-en.ppd
share/cups/model/epson-inkjet-printer-escpr/Epson-WF-6090_Series-epson-escpr-en.ppd
+share/cups/model/epson-inkjet-printer-escpr/Epson-WF-6530-epson-escpr-en.ppd
share/cups/model/epson-inkjet-printer-escpr/Epson-WF-6590_Series-epson-escpr-en.ppd
share/cups/model/epson-inkjet-printer-escpr/Epson-WF-7110_Series-epson-escpr-en.ppd
share/cups/model/epson-inkjet-printer-escpr/Epson-WF-7510_Series-epson-escpr-en.ppd