aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorbapt <bapt@FreeBSD.org>2013-06-28 19:51:05 +0800
committerbapt <bapt@FreeBSD.org>2013-06-28 19:51:05 +0800
commitba5181b4c873c984e4559cfddf3b6ce79362a9a2 (patch)
tree5182ef394eeef9bff78abf27f4a3a05f7fb8ff43 /print
parent39c24b55b95207275ceec7228fd4470225c94152 (diff)
downloadfreebsd-ports-gnome-ba5181b4c873c984e4559cfddf3b6ce79362a9a2.tar.gz
freebsd-ports-gnome-ba5181b4c873c984e4559cfddf3b6ce79362a9a2.tar.zst
freebsd-ports-gnome-ba5181b4c873c984e4559cfddf3b6ce79362a9a2.zip
New USES imake to handle the dependency on imake.
This uses accept 'env' as an argument for ports that do use their own or a different do-configure target. Modify xmkmf so it accept IMAKECPPFLAGS as default flags for imake and pass it to the called imake. Modify xorg-cf-files (the FreeBSD.cf configuration file) to allow CppCmd to be overwritten. Pass CppCmd CcCmd and CplusplusCmd via command line to each call of imake via IMAKECPPFLAGS Pass IMAKE_DEFINE with the above arguments to MAKE_ARGS so that imake spawned from Makefile generated by a previous imake also inherit the defined CppCmd CcCmd and CplusplusCmd. Make imake use devel/tradcpp all the time, so that when buidling with clang we do not depend on gcc's cpp. Make imake respect CC and CXX Make imake respect USE_GCC (if set imake will use gcc's cpp). While here: - Remove a couple of indefinite articles from comments - Trim headers - Fix a couple of ports to build with clang or use: USE_GCC=any - Fix a now useless redefinition of the extraction chain - Fix a typo in japanese/Wnn7-lib bundled imake template definitions - Fix some XMKMF execution with no env specified - Use options helper in x11/xautolock to simplify the port
Diffstat (limited to 'print')
-rw-r--r--print/bibview/Makefile8
-rw-r--r--print/ghostview/Makefile2
-rw-r--r--print/transfig/Makefile10
3 files changed, 6 insertions, 14 deletions
diff --git a/print/bibview/Makefile b/print/bibview/Makefile
index 02adfd6f5b28..d7d21b4b6455 100644
--- a/print/bibview/Makefile
+++ b/print/bibview/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: bibview
-# Date created: 21 July 1997
-# Whom: dbader@eece.unm.edu
-#
+# Created by: dbader@eece.unm.edu
# $FreeBSD$
-#
PORTNAME= bibview
PORTVERSION= 2.2
@@ -17,7 +13,7 @@ COMMENT= Graphical interface for manipulating BibTeX bibliography databases
MAKE_JOBS_SAFE= yes
-USE_IMAKE= yes
+USES= imake
USE_XORG= ice sm x11 xaw xext xmu xt
WRKSRC= ${WRKDIR}/bibview-${PORTVERSION}
MAN1= bibview.1
diff --git a/print/ghostview/Makefile b/print/ghostview/Makefile
index 10c7b4aa3549..ca6d460602fe 100644
--- a/print/ghostview/Makefile
+++ b/print/ghostview/Makefile
@@ -13,7 +13,7 @@ COMMENT= X11 front-end for ghostscript, the GNU postscript previewer
LICENSE= GPLv2 # (or later)
-USE_IMAKE= yes
+USES= imake
USE_XORG= xbitmaps xaw
USE_GHOSTSCRIPT_RUN= yes
MAKE_JOBS_SAFE= yes
diff --git a/print/transfig/Makefile b/print/transfig/Makefile
index 9c0f81142d25..44faaa53e186 100644
--- a/print/transfig/Makefile
+++ b/print/transfig/Makefile
@@ -1,9 +1,5 @@
-# New ports collection makefile for: transfig
-# Date created: 9 August 1996
-# Whom: chuckr@freebsd.org
-#
+# Created by: chuckr@freebsd.org
# $FreeBSD$
-#
PORTNAME= transfig
PORTVERSION= 3.2.5d
@@ -20,9 +16,9 @@ LIB_DEPENDS= png15:${PORTSDIR}/graphics/png
MAKE_JOBS_SAFE= yes
-USE_GCC= any
+USES= imake
+CFLAGS+= -Wno-return-type
USE_GHOSTSCRIPT_RUN= yes
-USE_IMAKE= yes
USE_XORG= xpm
MAN1= fig2dev.1 fig2ps2tex.1 pic2tpic.1 transfig.1