aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authornivit <nivit@FreeBSD.org>2013-04-26 05:33:55 +0800
committernivit <nivit@FreeBSD.org>2013-04-26 05:33:55 +0800
commitd401208217ff2e465b2862d431705caa01601f9e (patch)
tree93f03abe9e8aeee6d90603cc885f50aabcbd6e4d /print
parent9981e4729046725852c72df3bd06e39c0d3d267c (diff)
downloadfreebsd-ports-gnome-d401208217ff2e465b2862d431705caa01601f9e.tar.gz
freebsd-ports-gnome-d401208217ff2e465b2862d431705caa01601f9e.tar.zst
freebsd-ports-gnome-d401208217ff2e465b2862d431705caa01601f9e.zip
Foxit Reader is a free PDF document viewer for the Linux platform, with a new
streamlined interface, user-customized toolbar, incredibly small size, breezing-fast launch speed and rich features. This empowers PDF document users with Zoom function, Navigation function, Bookmarks, Thumbnails, Text Selection Tool, Snapshot, and Full Screen capabilities. Foxit Reader for Desktop Linux is provided by Foxit Corporation free for non-commercial use. WWW: http://www.foxitsoftware.com/pdf/desklinux/
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/foxitreader/Makefile61
-rw-r--r--print/foxitreader/distinfo4
-rw-r--r--print/foxitreader/pkg-descr8
-rw-r--r--print/foxitreader/pkg-plist13
5 files changed, 87 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index 65d3ef1edef7..667d0557767c 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -72,6 +72,7 @@
SUBDIR += foomatic-db-engine
SUBDIR += foomatic-db-hpijs
SUBDIR += foomatic-filters
+ SUBDIR += foxitreader
SUBDIR += fpdf
SUBDIR += freetype
SUBDIR += freetype-tools
diff --git a/print/foxitreader/Makefile b/print/foxitreader/Makefile
new file mode 100644
index 000000000000..ca58d8f2f81c
--- /dev/null
+++ b/print/foxitreader/Makefile
@@ -0,0 +1,61 @@
+# Created by: Nicola Vitale <nivit@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= foxitreader
+PORTVERSION= 1.1.0
+#PORTREVISION= 0
+CATEGORIES= print
+MASTER_SITES= http://cdn04.foxitsoftware.com/pub/foxit/%SUBDIR%/:reader,manual
+MASTER_SITE_SUBDIR= reader/desktop/linux/1.x/${PORTVERSION:R}/enu/:reader \
+ manual/enu/:manual
+DISTFILES= FoxitReader-${PORTVERSION}.tar.bz2:reader
+EXTRACT_ONLY= FoxitReader-${PORTVERSION}.tar.bz2
+
+MAINTAINER= nivit@FreeBSD.org
+COMMENT= Free PDF document viewer for desktop Linux
+
+LICENSE_NAME= EULA
+LICENSE_PERMS= dist-mirror dist-sell pkg-mirror pkg-sell
+LICENSE_TEXT= http://www.foxitsoftware.com/pdf/desklinux/eula.htm
+
+NO_BUILD= yes
+
+PLIST_SUB= NLS="${NLS}"
+
+USE_BZIP2= yes
+USE_GETTEXT= yes
+USE_LINUX= yes
+USE_LINUX_APPS= cups-libs gtk2
+
+WRKSRC= ${WRKDIR}/${PORTVERSION:R}-release
+
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOCS}
+DISTFILES+=FoxitReader${PORTVERSION:R}ForLinux_Manual.pdf:doc
+.endif
+.if ${PORT_OPTIONS:MNLS}
+NLS= ""
+.else
+NLS= "@comment "
+.endif
+
+do-install:
+ cd ${WRKSRC} && ${MKDIR} ${DATADIR} && \
+ ${INSTALL_DATA} fpdfcjk.bin fum.fhd ${DATADIR} && \
+ ${INSTALL_PROGRAM} FoxitReader ${DATADIR} && \
+ ${LN} -s ${DATADIR}/FoxitReader ${PREFIX}/bin/FoxitReader
+.if ${PORT_OPTIONS:MNLS}
+.for locale in de fr ja zh_CN zh_TW
+ ${INSTALL_DATA} ${WRKSRC}/po/${locale}/FoxitReader.mo ${PREFIX}/share/locale/${locale}/LC_MESSAGES/
+.endfor
+.endif
+.if ${PORT_OPTIONS:MDOCS}
+ ${MKDIR} ${DOCSDIR} && \
+ ${INSTALL_DATA} ${DISTDIR}/FoxitReader${PORTVERSION:R}ForLinux_Manual.pdf ${DOCSDIR}
+.endif
+
+post-install:
+ ${CAT} ${PKGMESSAGE}
+
+.include <bsd.port.mk>
diff --git a/print/foxitreader/distinfo b/print/foxitreader/distinfo
new file mode 100644
index 000000000000..3c6f8aca5c4e
--- /dev/null
+++ b/print/foxitreader/distinfo
@@ -0,0 +1,4 @@
+SHA256 (FoxitReader-1.1.0.tar.bz2) = 02f1ad5ad2fd516754254f349c94b8e81b57b9eb2a0315f30debdc5d7fb8dbf4
+SIZE (FoxitReader-1.1.0.tar.bz2) = 3787587
+SHA256 (FoxitReader1.1ForLinux_Manual.pdf) = 0882173090a66f1525d3f2a3c430f34204992a78d556f6f935d0383f5a0e8591
+SIZE (FoxitReader1.1ForLinux_Manual.pdf) = 2662827
diff --git a/print/foxitreader/pkg-descr b/print/foxitreader/pkg-descr
new file mode 100644
index 000000000000..69f79b013bcd
--- /dev/null
+++ b/print/foxitreader/pkg-descr
@@ -0,0 +1,8 @@
+Foxit Reader is a free PDF document viewer for the Linux platform, with a new
+streamlined interface, user-customized toolbar, incredibly small size,
+breezing-fast launch speed and rich features. This empowers PDF document users
+with Zoom function, Navigation function, Bookmarks, Thumbnails, Text Selection
+Tool, Snapshot, and Full Screen capabilities. Foxit Reader for Desktop Linux
+is provided by Foxit Corporation free for non-commercial use.
+
+WWW: http://www.foxitsoftware.com/pdf/desklinux/
diff --git a/print/foxitreader/pkg-plist b/print/foxitreader/pkg-plist
new file mode 100644
index 000000000000..09ed00e8d726
--- /dev/null
+++ b/print/foxitreader/pkg-plist
@@ -0,0 +1,13 @@
+@comment $FreeBSD$
+bin/FoxitReader
+%%PORTDOCS%%%%DOCSDIR%%/FoxitReader1.1ForLinux_Manual.pdf
+%%DATADIR%%/FoxitReader
+%%DATADIR%%/fpdfcjk.bin
+%%DATADIR%%/fum.fhd
+%%NLS%%share/locale/de/LC_MESSAGES/FoxitReader.mo
+%%NLS%%share/locale/fr/LC_MESSAGES/FoxitReader.mo
+%%NLS%%share/locale/ja/LC_MESSAGES/FoxitReader.mo
+%%NLS%%share/locale/zh_CN/LC_MESSAGES/FoxitReader.mo
+%%NLS%%share/locale/zh_TW/LC_MESSAGES/FoxitReader.mo
+@dirrm %%DATADIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%