aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authormat <mat@FreeBSD.org>2013-08-03 02:52:07 +0800
committermat <mat@FreeBSD.org>2013-08-03 02:52:07 +0800
commitf47f83f9c8923b3b0f740482331aab0d0aa669e9 (patch)
treea4a613f80a0e443c044c2319e43ce75e14c50813 /print
parent16bdaae92136c316b9043fffbf5fb4438dce004e (diff)
downloadfreebsd-ports-gnome-f47f83f9c8923b3b0f740482331aab0d0aa669e9.tar.gz
freebsd-ports-gnome-f47f83f9c8923b3b0f740482331aab0d0aa669e9.tar.zst
freebsd-ports-gnome-f47f83f9c8923b3b0f740482331aab0d0aa669e9.zip
- Convert to new perl framework
- Trim Makefile header - Remove MAKE_JOBS_SAFE=yes, it's the default.
Diffstat (limited to 'print')
-rw-r--r--print/p5-PDFLib/Makefile8
-rw-r--r--print/p5-PostScript-Simple/Makefile8
-rw-r--r--print/p5-PostScript/Makefile8
3 files changed, 9 insertions, 15 deletions
diff --git a/print/p5-PDFLib/Makefile b/print/p5-PDFLib/Makefile
index 94f9fb7fafa7..a352328281f7 100644
--- a/print/p5-PDFLib/Makefile
+++ b/print/p5-PDFLib/Makefile
@@ -1,10 +1,7 @@
# ex:ts=8
# Ports collection makefile for: p5-PDFLib
-# Date created: May 13, 2002
-# Whom: ijliao
-#
+# Created by: ijliao
# $FreeBSD$
-#
PORTNAME= PDFLib
PORTVERSION= 0.14
@@ -18,7 +15,8 @@ COMMENT= More OO interface to pdflib_pl.pm
BUILD_DEPENDS= pdflib-perl>=0:${PORTSDIR}/print/pdflib-perl
RUN_DEPENDS:= ${BUILD_DEPENDS}
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
NO_BUILD= yes
MAN3= PDFLib.3
diff --git a/print/p5-PostScript-Simple/Makefile b/print/p5-PostScript-Simple/Makefile
index 63d9a3ebaeac..112ba0eae1bb 100644
--- a/print/p5-PostScript-Simple/Makefile
+++ b/print/p5-PostScript-Simple/Makefile
@@ -1,9 +1,6 @@
# Ports collection makefile for: p5-PostScript-Simple
-# Date created: Feb 03, 2003
-# Whom: tobez
-#
+# Created by: tobez
# $FreeBSD$
-#
PORTNAME= PostScript-Simple
PORTVERSION= 0.07
@@ -14,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= PostScript::Simple - Produce PostScript files from Perl
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= PostScript::Simple.3 PostScript::Simple::EPS.3
diff --git a/print/p5-PostScript/Makefile b/print/p5-PostScript/Makefile
index 607dea83df65..5579aa139163 100644
--- a/print/p5-PostScript/Makefile
+++ b/print/p5-PostScript/Makefile
@@ -1,9 +1,6 @@
# Ports collection makefile for: p5-PostScript
-# Date created: 10.Jun.2008
-# Whom: Fernan Aguero <fernan.aguero@gmail.com>
-#
+# Created by: Fernan Aguero <fernan.aguero@gmail.com>
# $FreeBSD$
-#
PORTNAME= PostScript
PORTVERSION= 0.06
@@ -14,7 +11,8 @@ PKGNAMEPREFIX= p5-
MAINTAINER= perl@FreeBSD.org
COMMENT= PostScript - Produce PostScript files from Perl
-PERL_CONFIGURE= yes
+USES= perl5
+USE_PERL5= configure
MAN3= PostScript::TextBlock.3 PostScript::Elements.3 PostScript::Metrics.3