aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorrene <rene@FreeBSD.org>2013-04-30 00:43:05 +0800
committerrene <rene@FreeBSD.org>2013-04-30 00:43:05 +0800
commit4474a0cc08c5d35a6a333ccf61e822717d7440fa (patch)
treea101ccfbdb487a4c9c92a67d6d88ac8775e3362a /print
parent6d3249226ec6077a65ecc9129a6a4a11b61b2d09 (diff)
downloadfreebsd-ports-gnome-4474a0cc08c5d35a6a333ccf61e822717d7440fa.tar.gz
freebsd-ports-gnome-4474a0cc08c5d35a6a333ccf61e822717d7440fa.tar.zst
freebsd-ports-gnome-4474a0cc08c5d35a6a333ccf61e822717d7440fa.zip
In preparation of removing devel/libusb (expires 2013-04-30), remove it
from these ports. Other changes: - convert Makefile header - convert to optionsNG - remove indefinite article from comment - drop support for FreeBSD < 8.0 - pet portlint (leave library ABI versions in LIB_DEPENDS) - net-mgmt/spectools: change option name from GTK to GTK2 to use default description from bsd.options.desc.mk Approved by: portmgr (bapt)
Diffstat (limited to 'print')
-rw-r--r--print/cups-base/Makefile16
-rw-r--r--print/hplip/Makefile9
2 files changed, 7 insertions, 18 deletions
diff --git a/print/cups-base/Makefile b/print/cups-base/Makefile
index 836ccf2281ec..232e340d3f72 100644
--- a/print/cups-base/Makefile
+++ b/print/cups-base/Makefile
@@ -7,14 +7,16 @@ DISTVERSIONSUFFIX= -source
CATEGORIES= print
MASTER_SITES= EASYSW/${PORTNAME}/${DISTVERSION}
PKGNAMESUFFIX= ${CUPS_SUFFIX}${PKGNAMESUFFIX2}
-UNIQUENAME= ${PORTNAME}${PKGNAMESUFFIX}
MAINTAINER= c.petrik.sosa@gmail.com
COMMENT= Common UNIX Printing System: ${COMMENT2}
LICENSE= GPLv2
+
CONFLICTS= LPRng-[0-9]*
+UNIQUENAME= ${PORTNAME}${PKGNAMESUFFIX}
+
USE_BZIP2= yes
USE_GMAKE= yes
GNU_CONFIGURE= yes
@@ -122,7 +124,7 @@ CONFIGURE_ARGS+= --with-printcap=/etc/printcap
PLIST_SUB+= OVERWRITE="@comment "
CONFIGURE_ARGS+= --with-printcap=${PREFIX}/etc/printcap
.endif
-
+
.if ${PORT_OPTIONS:MGNUTLS}
CONFIGURE_ARGS+= --disable-openssl --enable-gnutls
LIB_DEPENDS+= gcrypt:${PORTSDIR}/security/libgcrypt
@@ -146,7 +148,7 @@ PLIST_SUB+= PHP="@comment "
.if !defined(CUPS_CLIENT) && !defined(CUPS_IMAGE) && ${PORT_OPTIONS:MGHOSTSCRIPT}
.if ${PORT_OPTIONS:MXPDF}
-IGNORE= You must select one and only one option to build pdftops
+IGNORE= you must select one and only one option to build pdftops
.endif
USE_GHOSTSCRIPT= yes
CONFIGURE_ARGS+= --enable-pdftops --with-pdftops=${LOCALBASE}/bin/gs
@@ -173,7 +175,7 @@ LIB_DEPENDS+= paper:${PORTSDIR}/print/libpaper
.if !defined(CUPS_CLIENT) && !defined(CUPS_IMAGE) && ${PORT_OPTIONS:MMDNSRESPONDER}
.if ${PORT_OPTIONS:MAVAHI}
-IGNORE= You must select one and only one option to build for Zeroconf
+IGNORE= you must select one and only one option to build for Zeroconf
.endif
LIB_DEPENDS+= dns_sd:${PORTSDIR}/net/mDNSResponder
CONFIGURE_ARGS+= --with-dnssd-includes=${LOCALBASE}/include
@@ -217,17 +219,13 @@ PLIST_SUB+= WITH_DBUS="@comment "
RUN_DEPENDS+= xdg-open:${PORTSDIR}/devel/xdg-utils
.endif
-.if !defined(CUPS_CLIENT) && !defined(CUPS_IMAGE) && ${PORT_OPTIONS:MLIBUSB} && ${OSVERSION}>800062
+.if !defined(CUPS_CLIENT) && !defined(CUPS_IMAGE) && ${PORT_OPTIONS:MLIBUSB}
CPPFLAGS+= -I/usr/include
LDFLAGS+= -L/usr/lib
-.elif !defined(CUPS_CLIENT) && !defined(CUPS_IMAGE) && ${PORT_OPTIONS:MLIBUSB} && ${OSVERSION}<800063
-LIB_DEPENDS+= usb:${PORTSDIR}/devel/libusb
.else
CONFIGURE_ARGS+= --disable-libusb
.endif
-.if ${OSVERSION} >= 800000
CONFIGURE_ARGS+= LIBS="-lssp_nonshared"
-.endif
.if defined(CUPS_CLIENT)
MAN1= cups-config.1
diff --git a/print/hplip/Makefile b/print/hplip/Makefile
index 8027193162df..c0f440632161 100644
--- a/print/hplip/Makefile
+++ b/print/hplip/Makefile
@@ -85,16 +85,7 @@ XSANE_DESC= Install XSane for scanning (requires SCAN)
.include <bsd.port.options.mk>
-.if ${OSVERSION} < 800067
-EXTRA_PATCHES+= ${PATCHDIR}/extrapatch-strnlen
-.endif
-
-.if ${OSVERSION} < 800069
-LIB_DEPENDS+= usb:${PORTSDIR}/devel/libusb
-USB_INCLUDE= ${LOCALBASE}/include
-.else
USB_INCLUDE= /usr/include
-.endif
.if ${PORT_OPTIONS:MQT}
RUN_DEPENDS+= ${PYTHON_SITELIBDIR}/PyQt4/QtGui.so:${PORTSDIR}/x11-toolkits/py-qt4-gui \