aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorasami <asami@FreeBSD.org>1997-08-05 14:37:19 +0800
committerasami <asami@FreeBSD.org>1997-08-05 14:37:19 +0800
commit553c714dbe3946b887bf12330d403a9bb7be1d50 (patch)
treedae694c7b556d1422698cf180327ca1543fec865 /print
parentc46940aaea689e47404bd805a0a434925db22f72 (diff)
downloadfreebsd-ports-gnome-553c714dbe3946b887bf12330d403a9bb7be1d50.tar.gz
freebsd-ports-gnome-553c714dbe3946b887bf12330d403a9bb7be1d50.tar.zst
freebsd-ports-gnome-553c714dbe3946b887bf12330d403a9bb7be1d50.zip
No need to define DISTFILES, the default is already correct. Change
"?=" to "=" for MAKE_FLAGS, bsd.port.mk is read later anyway. Change "/usr/local" to "${PREFIX}" and "/usr/bin/false" to ${FALSE}. Remove spurious empty lines. Many of the above found by: portlint
Diffstat (limited to 'print')
-rw-r--r--print/enscript-letter/Makefile12
1 files changed, 4 insertions, 8 deletions
diff --git a/print/enscript-letter/Makefile b/print/enscript-letter/Makefile
index f1bdd12078f2..139b7d8bc46c 100644
--- a/print/enscript-letter/Makefile
+++ b/print/enscript-letter/Makefile
@@ -3,21 +3,20 @@
# Date created: 24 Jul, 1997
# Whom: kline
#
-# $Id: Makefile,v 1.25 1997/06/25 05:24:43 torstenb Exp $
+# $Id: Makefile,v 1.1.1.1 1997/07/27 03:31:33 chuckr Exp $
#
DISTNAME= enscript-1.5.0
PKGNAME= enscript-${PAPERSIZE}-1.5.0
CATEGORIES= print
MASTER_SITES= ${MASTER_SITE_GNU}
-DISTFILES= enscript-1.5.0.tar.gz
MAINTAINER= kline@thought.org
GNU_CONFIGURE= yes
USE_GMAKE= yes
CONFIGURE_ARGS= --disable-nls
-MAKE_FLAGS?= WIDTH=${WIDTH} HEIGHT=${HEIGHT} A4_PAPERSIZE=${A4_PAPERSIZE} -f
+MAKE_FLAGS= WIDTH=${WIDTH} HEIGHT=${HEIGHT} A4_PAPERSIZE=${A4_PAPERSIZE} -f
MAN1= enscript.1 sliceprint.1 states.1
STRIP=
@@ -65,7 +64,7 @@ pre-fetch:
.elif defined(PAPERSIZE_INVALID)
@echo "Error: invalid value for PAPERSIZE: \"${PAPERSIZE}\""
@echo "Possible values are: A4 (default) or letter"
- @/usr/bin/false
+ @${FALSE}
.endif
letter::
${MAKE} PAPERSIZE=Letter
@@ -103,12 +102,9 @@ a4-install::
A4-install::
${MAKE} PAPERSIZE=a4 install
-
-
-
post-install:
.for file in enscript mkafmmap states
- strip /usr/local/bin/${file}
+ strip ${PREFIX}/bin/${file}
.endfor
.include <bsd.port.mk>