aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authoralane <alane@FreeBSD.org>2002-09-11 23:12:34 +0800
committeralane <alane@FreeBSD.org>2002-09-11 23:12:34 +0800
commit56c1dc533b0028b5d393478b73e0989a98ebd16b (patch)
tree72a43c46d29f45da7bb7c3c123cb4f3eee3090fb /print
parentb521ca540cde81a7024463452858464681da925e (diff)
downloadfreebsd-ports-gnome-56c1dc533b0028b5d393478b73e0989a98ebd16b.tar.gz
freebsd-ports-gnome-56c1dc533b0028b5d393478b73e0989a98ebd16b.tar.zst
freebsd-ports-gnome-56c1dc533b0028b5d393478b73e0989a98ebd16b.zip
Bug fix for non-PS octet-stream print failures. Patch taken from CVS.
Diffstat (limited to 'print')
-rw-r--r--print/cups-base/Makefile2
-rw-r--r--print/cups-base/patch-scheduler-mime.c-1.1.1652
2 files changed, 53 insertions, 1 deletions
diff --git a/print/cups-base/Makefile b/print/cups-base/Makefile
index 0045985c55c5..d2ae1c1a35c5 100644
--- a/print/cups-base/Makefile
+++ b/print/cups-base/Makefile
@@ -7,7 +7,7 @@
PORTNAME= cups-base
PORTVERSION= ${CUPS_PORTVER}
-PORTREVISION= 3
+PORTREVISION= 4
CATEGORIES?= print
MAINTAINER= ports@geeksrus.net
diff --git a/print/cups-base/patch-scheduler-mime.c-1.1.16 b/print/cups-base/patch-scheduler-mime.c-1.1.16
new file mode 100644
index 000000000000..d0c02367a605
--- /dev/null
+++ b/print/cups-base/patch-scheduler-mime.c-1.1.16
@@ -0,0 +1,52 @@
+Index: mime.c
+===================================================================
+RCS file: /home/anoncvs/cups/scheduler/mime.c,v
+retrieving revision 1.12
+retrieving revision 1.14
+diff -u -3 -r1.12 -r1.14
+--- mime.c 2002/05/16 13:45:02 1.12
++++ mime.c 2002/08/23 01:33:46 1.14
+@@ -1,5 +1,5 @@
+ /*
+- * "$Id: mime.c,v 1.12 2002/05/16 13:45:02 mike Exp $"
++ * "$Id: mime.c,v 1.14 2002/08/23 01:33:46 mike Exp $"
+ *
+ * MIME database file routines for the Common UNIX Printing System (CUPS).
+ *
+@@ -502,17 +502,20 @@
+ filter = lineptr;
+
+ #ifndef WIN32
+- /*
+- * Verify that the filter exists and is executable...
+- */
++ if (strcmp(filter, "-") != 0)
++ {
++ /*
++ * Verify that the filter exists and is executable...
++ */
+
+- if (filter[0] == '/')
+- strlcpy(filterprog, filter, sizeof(filterprog));
+- else
+- snprintf(filterprog, sizeof(filterprog), "%s/%s", filterpath, filter);
++ if (filter[0] == '/')
++ strlcpy(filterprog, filter, sizeof(filterprog));
++ else
++ snprintf(filterprog, sizeof(filterprog), "%s/%s", filterpath, filter);
+
+- if (access(filterprog, X_OK))
+- continue;
++ if (access(filterprog, X_OK))
++ continue;
++ }
+ #endif /* !WIN32 */
+
+ /*
+@@ -593,5 +596,5 @@
+
+
+ /*
+- * End of "$Id: mime.c,v 1.12 2002/05/16 13:45:02 mike Exp $".
++ * End of "$Id: mime.c,v 1.14 2002/08/23 01:33:46 mike Exp $".
+ */