aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorkris <kris@FreeBSD.org>2002-05-11 16:23:24 +0800
committerkris <kris@FreeBSD.org>2002-05-11 16:23:24 +0800
commit619332c4619df10d18006aaf6177bf35fa52360a (patch)
treee6cbde9667e546593db6555a37f5963744d0b4c9 /print
parent599151bfffe557d0a282ba39f82d10927d4820bf (diff)
downloadfreebsd-ports-gnome-619332c4619df10d18006aaf6177bf35fa52360a.tar.gz
freebsd-ports-gnome-619332c4619df10d18006aaf6177bf35fa52360a.tar.zst
freebsd-ports-gnome-619332c4619df10d18006aaf6177bf35fa52360a.zip
Unbreak the build by putting back the do-build and do-install targets
which were mysteriously removed in the previous revision. Pointy hat to: ijliao
Diffstat (limited to 'print')
-rw-r--r--print/py-reportlab/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/print/py-reportlab/Makefile b/print/py-reportlab/Makefile
index a093274f3e23..1a58357fd797 100644
--- a/print/py-reportlab/Makefile
+++ b/print/py-reportlab/Makefile
@@ -31,6 +31,14 @@ EXAMPLEDIR= ${PREFIX}/share/examples/reportlab
post-patch:
${MV} ${WRKSRC}/lib/setup.py ${WRKDIR}
+do-build:
+ @(cd ${WRKDIR}; \
+ ${PYTHON_CMD} setup.py build)
+
+do-install:
+ @(cd ${WRKDIR}; \
+ ${PYTHON_CMD} setup.py install -c -O1 --prefix="${PREFIX}")
+
post-install:
${MKDIR} ${REPORTLABDIR}/fonts
.for fontfile in LeERC___.AFM LeERC___.PFB