aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authormarcus <marcus@FreeBSD.org>2003-11-22 12:28:12 +0800
committermarcus <marcus@FreeBSD.org>2003-11-22 12:28:12 +0800
commit62b0a27bb8c3c46792f15a67cb5c984f94f567a4 (patch)
treee1859953206bff3b8c49a43e1c17916f9789c339 /print
parentcbf296c551130c6e1d7c7fbd545b58b2395534ae (diff)
downloadfreebsd-ports-gnome-62b0a27bb8c3c46792f15a67cb5c984f94f567a4.tar.gz
freebsd-ports-gnome-62b0a27bb8c3c46792f15a67cb5c984f94f567a4.tar.zst
freebsd-ports-gnome-62b0a27bb8c3c46792f15a67cb5c984f94f567a4.zip
Fix printing due to badly generated XML files. This has been reported to
the libgnomeprint developers, but it's not clear whether or not it will be fixed in time for thr freeze.
Diffstat (limited to 'print')
-rw-r--r--print/libgnomeprint/Makefile26
-rw-r--r--print/libgnomeprint/distinfo1
2 files changed, 25 insertions, 2 deletions
diff --git a/print/libgnomeprint/Makefile b/print/libgnomeprint/Makefile
index 9a38c4cced68..ffb74daba2a2 100644
--- a/print/libgnomeprint/Makefile
+++ b/print/libgnomeprint/Makefile
@@ -7,9 +7,15 @@
PORTNAME= libgnomeprint
PORTVERSION= 2.4.1
+PORTREVISION= 1
CATEGORIES= print gnome
-MASTER_SITES= ${MASTER_SITE_GNOME}
-MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.4
+MASTER_SITES= ${MASTER_SITE_GNOME} \
+ ${MASTER_SITE_LOCAL:S/$/:local/} \
+ http://people.FreeBSD.org/~marcus/:local
+MASTER_SITE_SUBDIR= sources/${PORTNAME}/2.4 \
+ marcus/:local
+DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
+ gpa-xml-${PORTVERSION}${EXTRACT_SUFX}:local
DIST_SUBDIR= gnome2
MAINTAINER= gnome@FreeBSD.org
@@ -27,6 +33,10 @@ CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
PLIST_SUB= VERSION=${PORTVERSION}
+GPA_XML= globals.xml
+GPA_PRINTERS= GENERIC.xml META.xml PDF-WRITER.xml
+GPA_MODELS= GNOME-GENERIC-PS.xml GNOME-META.xml GNOME-PDF-WRITER.xml
+
.include <bsd.port.pre.mk>
.if exists(${LOCALBASE}/lib/libcups.so)
@@ -50,5 +60,17 @@ post-patch:
post-install:
@${MKDIR} ${PREFIX}/etc/gnome/libgnomeprint-2.0/fonts
@${TOUCH} ${PREFIX}/etc/gnome/libgnomeprint-2.0/fonts/gnome-print.fontmap
+.for xml in ${GPA_XML}
+ ${INSTALL_DATA} ${WRKDIR}/gpa-xml-${PORTVERSION}/${xml} \
+ ${PREFIX}/share/gnome/${PORTNAME}/${PORTVERSION}
+.endfor
+.for printer in ${GPA_PRINTERS}
+ ${INSTALL_DATA} ${WRKDIR}/gpa-xml-${PORTVERSION}/${printer} \
+ ${PREFIX}/share/gnome/${PORTNAME}/${PORTVERSION}/printers
+.endfor
+.for model in ${GPA_MODELS}
+ ${INSTALL_DATA} ${WRKDIR}/gpa-xml-${PORTVERSION}/${model} \
+ ${PREFIX}/share/gnome/${PORTNAME}/${PORTVERSION}/models
+.endfor
.include <bsd.port.post.mk>
diff --git a/print/libgnomeprint/distinfo b/print/libgnomeprint/distinfo
index f351ee1b514e..935528dc8463 100644
--- a/print/libgnomeprint/distinfo
+++ b/print/libgnomeprint/distinfo
@@ -1 +1,2 @@
MD5 (gnome2/libgnomeprint-2.4.1.tar.bz2) = ac7cbe45379b6bc14308cdcca8175757
+MD5 (gnome2/gpa-xml-2.4.1.tar.bz2) = 7128cbbb8a4fdc179c90dcc2a5b31e34