aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorpav <pav@FreeBSD.org>2007-03-09 22:53:05 +0800
committerpav <pav@FreeBSD.org>2007-03-09 22:53:05 +0800
commit6b8706a2aea5c8648ead8b8dd5fd5442ca250356 (patch)
tree1d9b3b92f2fa9de263488a5cfe7a0bce9cec9f09 /print
parent6107c20ecb5042969c797fb656fabae2efececdc (diff)
downloadfreebsd-ports-gnome-6b8706a2aea5c8648ead8b8dd5fd5442ca250356.tar.gz
freebsd-ports-gnome-6b8706a2aea5c8648ead8b8dd5fd5442ca250356.tar.zst
freebsd-ports-gnome-6b8706a2aea5c8648ead8b8dd5fd5442ca250356.zip
- Fix runtime crash on amd64 on certain input files
PR: ports/110039 Submitted by: Ingo Schroeck <schroeck@internet-xs.de> Obtained from: debian bug tracking system
Diffstat (limited to 'print')
-rw-r--r--print/ghostscript-afpl/Makefile.inc2
-rw-r--r--print/ghostscript-afpl/files/patch-src-gxfcopy.c11
2 files changed, 12 insertions, 1 deletions
diff --git a/print/ghostscript-afpl/Makefile.inc b/print/ghostscript-afpl/Makefile.inc
index c6660fd17f75..1d2f1aec7b8c 100644
--- a/print/ghostscript-afpl/Makefile.inc
+++ b/print/ghostscript-afpl/Makefile.inc
@@ -1,5 +1,5 @@
# $FreeBSD$
GS_VERSION= 8.54
-GS_REVISION= 0
+GS_REVISION= 1
GS_EPOCH= 1
diff --git a/print/ghostscript-afpl/files/patch-src-gxfcopy.c b/print/ghostscript-afpl/files/patch-src-gxfcopy.c
new file mode 100644
index 000000000000..a33419126b19
--- /dev/null
+++ b/print/ghostscript-afpl/files/patch-src-gxfcopy.c
@@ -0,0 +1,11 @@
+--- src/gxfcopy.c.orig Thu Mar 23 13:39:23 2006
++++ src/gxfcopy.c Fri Mar 9 15:13:31 2007
+@@ -2391,7 +2391,7 @@
+ a[j++] = &cfdata->names[i];
+ }
+ }
+- qsort(a, cfdata->num_glyphs, sizeof(int), compare_glyph_names);
++ qsort(a, cfdata->num_glyphs, sizeof(gs_copied_glyph_name_t*), compare_glyph_names);
+ for (; j >= 0; j--)
+ cfdata->glyphs[j].order_index = a[j] - cfdata->names;
+ gs_free_object(memory, a, "order_font_data");