aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorjhale <jhale@FreeBSD.org>2014-07-02 03:15:35 +0800
committerjhale <jhale@FreeBSD.org>2014-07-02 03:15:35 +0800
commitbab3812daa0d8d937c292562065a3c2b71a4a5f3 (patch)
treee288dbdf2be84eeaca000ddc334638234035eef6 /print
parent65a3d674081fb678e70fb7e35872a620bbccd9d2 (diff)
downloadfreebsd-ports-gnome-bab3812daa0d8d937c292562065a3c2b71a4a5f3.tar.gz
freebsd-ports-gnome-bab3812daa0d8d937c292562065a3c2b71a4a5f3.tar.zst
freebsd-ports-gnome-bab3812daa0d8d937c292562065a3c2b71a4a5f3.zip
- Update to 1.7.3
- Add DOCS option - PHP option no longer installs a PHP module (it was eliminated in 1.6) - Add options for other interpreters - Add OPENSSL option to make it clearer that it is enabled instead of GNUTLS - Fix build when ZEROCONF is disabled - Fix detection of libusb on FreeBSD < 10 as they do not have .pc files for it - Use @sample directive in pkg-plist - Remove some old cruft
Diffstat (limited to 'print')
-rw-r--r--print/cups-base/Makefile80
-rw-r--r--print/cups-base/distinfo4
-rw-r--r--print/cups-base/files/patch-configure38
-rw-r--r--print/cups-base/files/patch-scheduler__dirsvc.c41
-rw-r--r--print/cups-base/pkg-plist137
-rw-r--r--print/cups/Makefile2
6 files changed, 210 insertions, 92 deletions
diff --git a/print/cups-base/Makefile b/print/cups-base/Makefile
index 49c77b11e043..24eb810735ab 100644
--- a/print/cups-base/Makefile
+++ b/print/cups-base/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= cups
-PORTVERSION= 1.7.2
+PORTVERSION= 1.7.3
DISTVERSIONSUFFIX= -source
#PORTREVISION= defined further
CATEGORIES= print
@@ -54,23 +54,37 @@ USERS= cups
PORTREVISION= 0
LICENSE= LGPL21
CUPS_SUFFIX= -client
-OPTIONS_DEFINE= GNUTLS
+OPTIONS_SINGLE= SSL
+OPTIONS_SINGLE_SSL= GNUTLS OPENSSL
+OPTIONS_DEFAULT= OPENSSL
+OPTIONS_SUB= yes
.elif defined(CUPS_IMAGE)
PORTREVISION= 0
CUPS_SUFFIX= -image
LICENSE= LGPL21
-OPTIONS_DEFINE= GNUTLS
+OPTIONS_SINGLE= SSL
+OPTIONS_SINGLE_SSL= GNUTLS OPENSSL
+OPTIONS_DEFAULT= OPENSSL
+OPTIONS_SUB= yes
.else
-PORTREVISION= 2
+PORTREVISION= 0
CUPS_SUFFIX= -base
-OPTIONS_DEFINE= GNUTLS LIBPAPER PHP PYTHON PAM DBUS LIBUSB XDG_OPEN AVAHI MDNSRESPONDER ICONS
-OPTIONS_DEFAULT= LIBPAPER MDNSRESPONDER ICONS
-NO_OPTIONS_SORT= yes
+OPTIONS_DEFINE= DOCS DBUS ICONS LIBPAPER LIBUSB PAM XDG_OPEN
+OPTIONS_GROUP= WEB
+OPTIONS_GROUP_WEB= JAVA PERL PHP PYTHON
+OPTIONS_SINGLE= SSL
+OPTIONS_SINGLE_SSL= GNUTLS OPENSSL
+OPTIONS_RADIO= ZEROCONF
+OPTIONS_RADIO_ZEROCONF= AVAHI MDNSRESPONDER
+OPTIONS_DEFAULT= LIBPAPER MDNSRESPONDER OPENSSL ICONS
+OPTIONS_SUB= yes
.endif
ICONS_DESC= Desktop icons
LIBUSB_DESC= USB support
+WEB_DESC= Interpreters for web interfaces
XDG_OPEN_DESC= Build with XDG_OPEN as browser
+ZEROCONF_DESC= Zeroconf support
.include <bsd.port.options.mk>
@@ -105,9 +119,7 @@ BUILD_DEPENDS+= cups-image${PKGNAMESUFFIX2}>=${PORTVERSION}:${PORTSDIR}/${PKGCAT
COMMENT2= Server
USE_RC_SUBR= cupsd
PLIST_SUB+= CACHEDIR="${CUPS_CACHEDIR}"
-.if ${ARCH} == "ia64"
-BROKEN= stack-protector not supported on ia64
-.endif
+BROKEN_ia64= stack-protector not supported on ia64
.endif
.if defined(CUPS_OVERWRITE_BASE)
@@ -122,26 +134,35 @@ CONFIGURE_ARGS+= --with-printcap=${PREFIX}/etc/printcap
CONFIGURE_ARGS+= --disable-openssl --enable-gnutls
LIB_DEPENDS+= libgcrypt.so:${PORTSDIR}/security/libgcrypt \
libgnutls.so:${PORTSDIR}/security/gnutls
-.else
+.endif
+
+.if ${PORT_OPTIONS:MOPENSSL}
+USE_OPENSSL= yes
CONFIGURE_ARGS+= --disable-gnutls --enable-openssl
-WITH_OPENSSL_HACK7= yes
-.include "${PORTSDIR}/Mk/bsd.openssl.mk"
+.endif
+
+# Don't use CONFIGURE_ARGS+=--without-* to disable web interpreters because it
+# will set the path of the interpreter to "no" and set it's existence to TRUE.
+.if !defined(CUPS_CLIENT) && !defined(CUPS_IMAGE) && ${PORT_OPTIONS:MJAVA}
+CONFIGURE_ARGS+= --with-java=${JAVA}
+USE_JAVA= yes
+.endif
+
+.if !defined(CUPS_CLIENT) && !defined(CUPS_IMAGE) && ${PORT_OPTIONS:MPERL}
+CONFIGURE_ARGS+= --with-perl=${PERL}
+USES+= perl5
.endif
.if !defined(CUPS_CLIENT) && !defined(CUPS_IMAGE) && ${PORT_OPTIONS:MPHP}
-CONFIGURE_ARGS+= --with-php
+CONFIGURE_ARGS+= --with-php=${LOCALBASE}/bin/php-cgi
USE_PHP= yes
USE_PHP_BUILD= yes
-PLIST_SUB+= PHP=""
-.else
-CONFIGURE_ARGS+= --without-php
-PLIST_SUB+= PHP="@comment "
+WANT_PHP_CGI= yes
.endif
.if !defined(CUPS_CLIENT) && !defined(CUPS_IMAGE) && ${PORT_OPTIONS:MPYTHON}
-CONFIGURE_ARGS+= --with-python
+CONFIGURE_ARGS+= --with-python=${PYTHON_CMD}
USE_PYTHON= yes
-.include "${PORTSDIR}/Mk/bsd.python.mk"
.endif
.if !defined(CUPS_CLIENT) && !defined(CUPS_IMAGE) && ${PORT_OPTIONS:MLIBPAPER}
@@ -150,37 +171,27 @@ LIB_DEPENDS+= libpaper.so:${PORTSDIR}/print/libpaper
.endif
.if !defined(CUPS_CLIENT) && !defined(CUPS_IMAGE) && ${PORT_OPTIONS:MMDNSRESPONDER}
-.if ${PORT_OPTIONS:MAVAHI}
-IGNORE= You must select one and only one option to build for Zeroconf
-.endif
LIB_DEPENDS+= libdns_sd.so:${PORTSDIR}/net/mDNSResponder
CONFIGURE_ARGS+= --with-dnssd-includes=${LOCALBASE}/include
-PLIST_SUB+= MDNSRESPONDER="" DNSSD="@comment "
.elif !defined(CUPS_CLIENT) && !defined(CUPS_IMAGE) && ${PORT_OPTIONS:MAVAHI}
CONFIGURE_ARGS+= --enable-avahi
LIB_DEPENDS+= libavahi-client.so:${PORTSDIR}/net/avahi-app
-PLIST_SUB+= MDNSRESPONDER="@comment " DNSSD=""
.else
CONFIGURE_ARGS+= --disable-dnssd
CONFIGURE_ARGS+= --disable-avahi
-PLIST_SUB+= MDNSRESPONDER="@comment " DNSSD="@comment "
.endif
.if !defined(CUPS_CLIENT) && !defined(CUPS_IMAGE) && ${PORT_OPTIONS:MPAM}
CONFIGURE_ARGS+= --enable-pam
-PLIST_SUB+= WITH_PAMD=""
.else
CONFIGURE_ARGS+= --disable-pam
-PLIST_SUB+= WITH_PAMD="@comment "
.endif
.if !defined(CUPS_CLIENT) && !defined(CUPS_IMAGE) && ${PORT_OPTIONS:MDBUS}
LIB_DEPENDS+= libdbus-1.so:${PORTSDIR}/devel/dbus
CONFIGURE_ARGS+= --enable-dbus
-PLIST_SUB+= WITH_DBUS=""
.else
CONFIGURE_ARGS+= --disable-dbus
-PLIST_SUB+= WITH_DBUS="@comment "
.endif
.if !defined(CUPS_CLIENT) && !defined(CUPS_IMAGE) && ${PORT_OPTIONS:MXDG_OPEN}
@@ -196,9 +207,6 @@ CONFIGURE_ARGS+= --disable-libusb
.if !defined(CUPS_CLIENT) && !defined(CUPS_IMAGE) && ${PORT_OPTIONS:MICONS}
INSTALLS_ICONS= yes
CONFIGURE_ARGS+= --with-icondir=${PREFIX}/share/icons
-PLIST_SUB+= WITH_ICONS=""
-.else
-PLIST_SUB+= WITH_ICONS="@comment "
.endif
.if ${OSVERSION} < 1000036 && ${ARCH} == i386
@@ -251,9 +259,6 @@ post-patch:
-e 's|cups-config.$$.MAN1EXT. ||' \
${WRKSRC}/man/Makefile
.endif
-.if ! ${PORT_OPTIONS:MLIBUSB}
- @${REINPLACE_CMD} -e 's|xyes -o $$uname != Darwin||' ${WRKSRC}/configure
-.endif
post-configure:
.if defined(CUPS_CLIENT)
@@ -292,9 +297,6 @@ post-install:
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libcupscgi.so.1
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libcupsppdc.so.1
${STRIP_CMD} ${STAGEDIR}${PREFIX}/lib/libcupsmime.so.1
-.if ${PORT_OPTIONS:MGHOSTSCRIPT} || ${PORT_OPTIONS:MXPDF}
- ${INSTALL_PROGRAM} ${WRKSRC}/filter/pdftops ${STAGEDIR}${PREFIX}/libexec/cups/filter/
-.endif
${LN} -sf lpr ${STAGEDIR}${PREFIX}/bin/lpr-cups
${MKDIR} ${STAGEDIR}${ETCDIR}/
.for f in cupsd.conf mime.convs mime.types snmp.conf
diff --git a/print/cups-base/distinfo b/print/cups-base/distinfo
index 9f847ea161ce..5e54e68992f5 100644
--- a/print/cups-base/distinfo
+++ b/print/cups-base/distinfo
@@ -1,2 +1,2 @@
-SHA256 (cups-1.7.2-source.tar.bz2) = 315cdff436924c4efe04cb110b145fb1a6e038e2eed8445359052f86e9e95676
-SIZE (cups-1.7.2-source.tar.bz2) = 8754601
+SHA256 (cups-1.7.3-source.tar.bz2) = fa989f856d1499169dc442fb2311053ea42fe455ca2721693ba5a9fe4b333e31
+SIZE (cups-1.7.3-source.tar.bz2) = 8792641
diff --git a/print/cups-base/files/patch-configure b/print/cups-base/files/patch-configure
index 874d195f4e42..c007a2967311 100644
--- a/print/cups-base/files/patch-configure
+++ b/print/cups-base/files/patch-configure
@@ -1,5 +1,5 @@
---- configure.orig 2012-07-27 22:57:23.000000000 +0200
-+++ configure 2012-11-05 20:13:13.000000000 +0100
+--- ./configure.orig 2014-05-27 14:33:29.000000000 -0400
++++ ./configure 2014-07-01 13:49:23.000000000 -0400
@@ -566,6 +566,7 @@
# Factoring default headers for most tests.
ac_includes_default="\
@@ -8,7 +8,30 @@
#ifdef HAVE_SYS_TYPES_H
# include <sys/types.h>
#endif
-@@ -5660,7 +5661,7 @@
+@@ -5238,7 +5239,7 @@
+
+
+ if test "x$PKGCONFIG" != x; then
+- if test x$enable_libusb = xyes -o $uname != Darwin; then
++ if test x$enable_libusb = xyes; then
+ { $as_echo "$as_me:${as_lineno-$LINENO}: checking for libusb-1.0" >&5
+ $as_echo_n "checking for libusb-1.0... " >&6; }
+ if $PKGCONFIG --exists libusb-1.0; then
+@@ -5249,6 +5250,13 @@
+ CFLAGS="$CFLAGS `$PKGCONFIG --cflags libusb-1.0`"
+ LIBUSB="`$PKGCONFIG --libs libusb-1.0`"
+ USBQUIRKS="\$(DATADIR)/usb"
++ elif test -f /usr/lib/libusb.so; then
++ { $as_echo "$as_me:${as_lineno-$LINENO}: result: yes" >&5
++$as_echo "yes" >&6; }
++ $as_echo "#define HAVE_LIBUSB 1" >>confdefs.h
++
++ LIBUSB="-lusb"
++ USBQUIRKS="\$(DATADIR)/usb"
+ else
+ { $as_echo "$as_me:${as_lineno-$LINENO}: result: no" >&5
+ $as_echo "no" >&6; }
+@@ -5527,7 +5535,7 @@
CFLAGS="$CFLAGS `$PKGCONFIG --cflags dbus-1` -DDBUS_API_SUBJECT_TO_CHANGE"
SERVERLIBS="$SERVERLIBS `$PKGCONFIG --libs dbus-1`"
DBUS_NOTIFIER="dbus"
@@ -17,12 +40,3 @@
SAVELIBS="$LIBS"
LIBS="$LIBS $DBUS_NOTIFIERLIBS"
ac_fn_c_check_func "$LINENO" "dbus_message_iter_init_append" "ac_cv_func_dbus_message_iter_init_append"
-@@ -8302,7 +8303,7 @@
-
-
- if test x$ac_cv_header_pthread_h = xyes; then
-- for flag in -lpthreads -lpthread -pthread; do
-+ for flag in -pthread; do
- { $as_echo "$as_me:${as_lineno-$LINENO}: checking for pthread_create using $flag" >&5
- $as_echo_n "checking for pthread_create using $flag... " >&6; }
- SAVELIBS="$LIBS"
diff --git a/print/cups-base/files/patch-scheduler__dirsvc.c b/print/cups-base/files/patch-scheduler__dirsvc.c
new file mode 100644
index 000000000000..d32f7af253aa
--- /dev/null
+++ b/print/cups-base/files/patch-scheduler__dirsvc.c
@@ -0,0 +1,41 @@
+--- ./scheduler/dirsvc.c.orig 2014-03-05 16:11:32.000000000 -0500
++++ ./scheduler/dirsvc.c 2014-06-30 11:02:48.000000000 -0400
+@@ -237,11 +237,13 @@
+ if (BrowseLocalProtocols & BROWSE_SMB)
+ update_smb(1);
+
++#if defined(HAVE_DNSSD) || defined(HAVE_AVAHI)
+ /*
+ * Register the individual printers
+ */
+
+ dnssdRegisterAllPrinters(0);
++#endif /* HAVE_DNSSD || HAVE_AVAHI */
+ }
+
+
+@@ -255,6 +257,7 @@
+ if (!Browsing || !BrowseLocalProtocols)
+ return;
+
++#if defined(HAVE_DNSSD) || defined(HAVE_AVAHI)
+ /*
+ * De-register the individual printers
+ */
+@@ -265,7 +268,6 @@
+ * Shut down browsing sockets...
+ */
+
+-#if defined(HAVE_DNSSD) || defined(HAVE_AVAHI)
+ if ((BrowseLocalProtocols & BROWSE_DNSSD) && DNSSDMaster)
+ dnssdStop();
+ #endif /* HAVE_DNSSD || HAVE_AVAHI */
+@@ -1548,7 +1550,7 @@
+ if (i)
+ *bufptr++ = ',';
+
+- strlcpy(bufptr, p->auth_info_required[i], bufsize - (bufptr - buffer));
++ strlcpy(bufptr, p->auth_info_required[i], bufsize - (size_t)(bufptr - buffer));
+ bufptr += strlen(bufptr);
+ }
+
diff --git a/print/cups-base/pkg-plist b/print/cups-base/pkg-plist
index c255b0c137ac..dee65fab2277 100644
--- a/print/cups-base/pkg-plist
+++ b/print/cups-base/pkg-plist
@@ -25,26 +25,15 @@
%%OVERWRITE%%@unexec if test -e /usr/bin/lpr; then chmod -h 06555 /usr/bin/lpr; fi
%%OVERWRITE%%@unexec if test -e /usr/bin/lprm; then chmod -h 06555 /usr/bin/lprm; fi
%%OVERWRITE%%@unexec if test -e /usr/sbin/lpc; then chmod -h 02555 /usr/sbin/lpc; fi
-@unexec if cmp -s %D/etc/cups/cups-files.conf.sample %D/etc/cups/cups-files.conf; then rm -f %D/etc/cups/cups-files.conf; fi
-@comment %%ETCDIR%%/cups-files.conf.sample
-%%ETCDIR%%/cups-files.conf.sample
-@exec if test ! -f %D/etc/cups/cups-files.conf; then cp -p %D/etc/cups/cups-files.conf.sample %D/etc/cups/cups-files.conf; fi
-@unexec if cmp -s %D/etc/cups/cupsd.conf.sample %D/etc/cups/cupsd.conf; then rm -f %D/etc/cups/cupsd.conf; fi
-%%ETCDIR%%/cupsd.conf.sample
-@exec if test ! -f %D/etc/cups/cupsd.conf; then cp -p %D/etc/cups/cupsd.conf.sample %D/etc/cups/cupsd.conf; fi
-@unexec if cmp -s %D/etc/cups/mime.convs.sample %D/etc/cups/mime.convs; then rm -f %D/etc/cups/mime.convs; fi
-%%ETCDIR%%/mime.convs.sample
-@exec if test ! -f %D/etc/cups/mime.convs; then cp -p %D/etc/cups/mime.convs.sample %D/etc/cups/mime.convs; fi
-@unexec if cmp -s %D/etc/cups/mime.types.sample %D/etc/cups/mime.types; then rm -f %D/etc/cups/mime.types; fi
-%%ETCDIR%%/mime.types.sample
-@exec if test ! -f %D/etc/cups/mime.types; then cp -p %D/etc/cups/mime.types.sample %D/etc/cups/mime.types; fi
-@unexec if cmp -s %D/etc/cups/snmp.conf.sample %D/etc/cups/snmp.conf; then rm -f %D/etc/cups/snmp.conf; fi
-%%ETCDIR%%/snmp.conf.sample
-@exec if test ! -f %D/etc/cups/snmp.conf; then cp -p %D/etc/cups/snmp.conf.sample %D/etc/cups/snmp.conf; fi
+@sample %%ETCDIR%%/cups-files.conf.sample
+@sample %%ETCDIR%%/cupsd.conf.sample
+@sample %%ETCDIR%%/mime.convs.sample
+@sample %%ETCDIR%%/mime.types.sample
+@sample %%ETCDIR%%/snmp.conf.sample
@exec chgrp cups %D/etc/cups
-%%WITH_PAMD%%@unexec if cmp -s %D/etc/pam.d/cups.default %D/etc/pam.d/cups; then rm -f %D/etc/pam.d/cups ; fi
-%%WITH_PAMD%%etc/pam.d/cups.default
-%%WITH_PAMD%%@exec if [ ! -f %D/etc/pam.d/cups ] ; then cp -p %D/%F %B/cups; fi
+%%PAM%%@unexec if cmp -s %D/etc/pam.d/cups.default %D/etc/pam.d/cups; then rm -f %D/etc/pam.d/cups ; fi
+%%PAM%%etc/pam.d/cups.default
+%%PAM%%@exec if [ ! -f %D/etc/pam.d/cups ] ; then cp -p %D/%F %B/cups; fi
bin/cancel
bin/cupstestdsc
bin/cupstestppd
@@ -74,7 +63,6 @@ lib/libcupsmime.so
lib/libcupsmime.so.1
lib/libcupsppdc.so
lib/libcupsppdc.so.1
-%%PHP%%lib/php/%%PHP_EXT_DIR%%/phpcups.so
libexec/cups/backend/http
libexec/cups/backend/https
libexec/cups/backend/ipp
@@ -83,7 +71,7 @@ libexec/cups/backend/lpd
libexec/cups/backend/snmp
libexec/cups/backend/socket
libexec/cups/backend/usb
-%%DNSSD%%libexec/cups/backend/dnssd
+%%AVAHI%%libexec/cups/backend/dnssd
%%MDNSRESPONDER%%libexec/cups/backend/dnssd
%%MDNSRESPONDER%%libexec/cups/backend/mdns
libexec/cups/cgi-bin/admin.cgi
@@ -97,7 +85,7 @@ libexec/cups/daemon/cups-exec
libexec/cups/daemon/cups-lpd
libexec/cups/monitor/bcp
libexec/cups/monitor/tbcp
-%%WITH_DBUS%%libexec/cups/notifier/dbus
+%%DBUS%%libexec/cups/notifier/dbus
libexec/cups/notifier/mailto
libexec/cups/notifier/rss
man/man1/cancel.1.gz
@@ -764,6 +752,74 @@ sbin/ulpt-cupsd.sh
%%DATADIR%%/templates/printer.tmpl
%%DATADIR%%/templates/printers-header.tmpl
%%DATADIR%%/templates/printers.tmpl
+%%DATADIR%%/templates/pt_BR/add-class.tmpl
+%%DATADIR%%/templates/pt_BR/add-printer.tmpl
+%%DATADIR%%/templates/pt_BR/add-rss-subscription.tmpl
+%%DATADIR%%/templates/pt_BR/admin.tmpl
+%%DATADIR%%/templates/pt_BR/choose-device.tmpl
+%%DATADIR%%/templates/pt_BR/choose-make.tmpl
+%%DATADIR%%/templates/pt_BR/choose-model.tmpl
+%%DATADIR%%/templates/pt_BR/choose-serial.tmpl
+%%DATADIR%%/templates/pt_BR/choose-uri.tmpl
+%%DATADIR%%/templates/pt_BR/class-added.tmpl
+%%DATADIR%%/templates/pt_BR/class-confirm.tmpl
+%%DATADIR%%/templates/pt_BR/class-deleted.tmpl
+%%DATADIR%%/templates/pt_BR/class-jobs-header.tmpl
+%%DATADIR%%/templates/pt_BR/class-modified.tmpl
+%%DATADIR%%/templates/pt_BR/class.tmpl
+%%DATADIR%%/templates/pt_BR/classes-header.tmpl
+%%DATADIR%%/templates/pt_BR/classes.tmpl
+%%DATADIR%%/templates/pt_BR/command.tmpl
+%%DATADIR%%/templates/pt_BR/edit-config.tmpl
+%%DATADIR%%/templates/pt_BR/error-op.tmpl
+%%DATADIR%%/templates/pt_BR/error.tmpl
+%%DATADIR%%/templates/pt_BR/header.tmpl
+%%DATADIR%%/templates/pt_BR/help-header.tmpl
+%%DATADIR%%/templates/pt_BR/job-cancel.tmpl
+%%DATADIR%%/templates/pt_BR/job-hold.tmpl
+%%DATADIR%%/templates/pt_BR/job-move.tmpl
+%%DATADIR%%/templates/pt_BR/job-moved.tmpl
+%%DATADIR%%/templates/pt_BR/job-release.tmpl
+%%DATADIR%%/templates/pt_BR/job-restart.tmpl
+%%DATADIR%%/templates/pt_BR/jobs-header.tmpl
+%%DATADIR%%/templates/pt_BR/jobs.tmpl
+%%DATADIR%%/templates/pt_BR/list-available-printers.tmpl
+%%DATADIR%%/templates/pt_BR/modify-class.tmpl
+%%DATADIR%%/templates/pt_BR/modify-printer.tmpl
+%%DATADIR%%/templates/pt_BR/norestart.tmpl
+%%DATADIR%%/templates/pt_BR/option-boolean.tmpl
+%%DATADIR%%/templates/pt_BR/option-conflict.tmpl
+%%DATADIR%%/templates/pt_BR/option-header.tmpl
+%%DATADIR%%/templates/pt_BR/option-pickmany.tmpl
+%%DATADIR%%/templates/pt_BR/option-pickone.tmpl
+%%DATADIR%%/templates/pt_BR/option-trailer.tmpl
+%%DATADIR%%/templates/pt_BR/pager.tmpl
+%%DATADIR%%/templates/pt_BR/printer-accept.tmpl
+%%DATADIR%%/templates/pt_BR/printer-added.tmpl
+%%DATADIR%%/templates/pt_BR/printer-configured.tmpl
+%%DATADIR%%/templates/pt_BR/printer-confirm.tmpl
+%%DATADIR%%/templates/pt_BR/printer-default.tmpl
+%%DATADIR%%/templates/pt_BR/printer-deleted.tmpl
+%%DATADIR%%/templates/pt_BR/printer-jobs-header.tmpl
+%%DATADIR%%/templates/pt_BR/printer-modified.tmpl
+%%DATADIR%%/templates/pt_BR/printer-purge.tmpl
+%%DATADIR%%/templates/pt_BR/printer-reject.tmpl
+%%DATADIR%%/templates/pt_BR/printer-start.tmpl
+%%DATADIR%%/templates/pt_BR/printer-stop.tmpl
+%%DATADIR%%/templates/pt_BR/printer.tmpl
+%%DATADIR%%/templates/pt_BR/printers-header.tmpl
+%%DATADIR%%/templates/pt_BR/printers.tmpl
+%%DATADIR%%/templates/pt_BR/restart.tmpl
+%%DATADIR%%/templates/pt_BR/samba-export.tmpl
+%%DATADIR%%/templates/pt_BR/samba-exported.tmpl
+%%DATADIR%%/templates/pt_BR/search.tmpl
+%%DATADIR%%/templates/pt_BR/set-printer-options-header.tmpl
+%%DATADIR%%/templates/pt_BR/set-printer-options-trailer.tmpl
+%%DATADIR%%/templates/pt_BR/subscription-added.tmpl
+%%DATADIR%%/templates/pt_BR/subscription-canceled.tmpl
+%%DATADIR%%/templates/pt_BR/test-page.tmpl
+%%DATADIR%%/templates/pt_BR/trailer.tmpl
+%%DATADIR%%/templates/pt_BR/users.tmpl
%%DATADIR%%/templates/restart.tmpl
%%DATADIR%%/templates/ru/add-class.tmpl
%%DATADIR%%/templates/ru/add-printer.tmpl
@@ -845,6 +901,7 @@ sbin/ulpt-cupsd.sh
%%DATADIR%%/templates/test-page.tmpl
%%DATADIR%%/templates/trailer.tmpl
%%DATADIR%%/templates/users.tmpl
+%%LIBUSB%%%%DATADIR%%/usb/org.cups.usb-quirks
%%PORTDOCS%%%%DOCSDIR%%/ca/index.html
%%PORTDOCS%%%%DOCSDIR%%/cs/index.html
%%PORTDOCS%%%%DOCSDIR%%/cups-printable.css
@@ -954,14 +1011,15 @@ sbin/ulpt-cupsd.sh
%%PORTDOCS%%%%DOCSDIR%%/index.html
%%PORTDOCS%%%%DOCSDIR%%/it/index.html
%%PORTDOCS%%%%DOCSDIR%%/ja/index.html
+%%PORTDOCS%%%%DOCSDIR%%/pt_BR/index.html
%%PORTDOCS%%%%DOCSDIR%%/robots.txt
%%PORTDOCS%%%%DOCSDIR%%/ru/index.html
%%PORTEXAMPLES%%%%EXAMPLESDIR%%/ulpt-cupsd.conf
share/applications/cups.desktop
-%%WITH_ICONS%%share/icons/hicolor/128x128/apps/cups.png
-%%WITH_ICONS%%share/icons/hicolor/16x16/apps/cups.png
-%%WITH_ICONS%%share/icons/hicolor/32x32/apps/cups.png
-%%WITH_ICONS%%share/icons/hicolor/64x64/apps/cups.png
+%%ICONS%%share/icons/hicolor/128x128/apps/cups.png
+%%ICONS%%share/icons/hicolor/16x16/apps/cups.png
+%%ICONS%%share/icons/hicolor/32x32/apps/cups.png
+%%ICONS%%share/icons/hicolor/64x64/apps/cups.png
share/locale/ca/cups_ca.po
share/locale/cs/cups_cs.po
share/locale/de/cups_de.po
@@ -969,6 +1027,7 @@ share/locale/es/cups_es.po
share/locale/fr/cups_fr.po
share/locale/it/cups_it.po
share/locale/ja/cups_ja.po
+share/locale/pt_BR/cups_pt_BR.po
share/locale/ru/cups_ru.po
@unexec rmdir "/var/spool/cups/tmp" >/dev/null 2>&1 || :
@unexec rmdir "/var/spool/cups" >/dev/null 2>&1 || :
@@ -977,32 +1036,34 @@ share/locale/ru/cups_ru.po
@unexec rmdir "/var/log/cups" >/dev/null 2>&1 || :
@unexec rmdir "/var/db/cups/rss" >/dev/null 2>&1 || :
@unexec rmdir "/var/db/cups" >/dev/null 2>&1 || :
-%%WITH_ICONS%%@dirrmtry share/icons/hicolor/16x16/apps
-%%WITH_ICONS%%@dirrmtry share/icons/hicolor/16x16
-%%WITH_ICONS%%@dirrmtry share/icons/hicolor/32x32/apps
-%%WITH_ICONS%%@dirrmtry share/icons/hicolor/32x32
-%%WITH_ICONS%%@dirrmtry share/icons/hicolor/64x64/apps
-%%WITH_ICONS%%@dirrmtry share/icons/hicolor/64x64
-%%WITH_ICONS%%@dirrmtry share/icons/hicolor/128x128/apps
-%%WITH_ICONS%%@dirrmtry share/icons/hicolor/128x128
-%%WITH_ICONS%%@dirrmtry share/icons/hicolor
-%%WITH_ICONS%%@dirrmtry share/icons
+%%ICONS%%@dirrmtry share/icons/hicolor/16x16/apps
+%%ICONS%%@dirrmtry share/icons/hicolor/16x16
+%%ICONS%%@dirrmtry share/icons/hicolor/32x32/apps
+%%ICONS%%@dirrmtry share/icons/hicolor/32x32
+%%ICONS%%@dirrmtry share/icons/hicolor/64x64/apps
+%%ICONS%%@dirrmtry share/icons/hicolor/64x64
+%%ICONS%%@dirrmtry share/icons/hicolor/128x128/apps
+%%ICONS%%@dirrmtry share/icons/hicolor/128x128
+%%ICONS%%@dirrmtry share/icons/hicolor
+%%ICONS%%@dirrmtry share/icons
%%PORTDOCS%%@dirrm %%DOCSDIR%%/cs
%%PORTDOCS%%@dirrm %%DOCSDIR%%/ca
%%PORTDOCS%%@dirrm %%DOCSDIR%%/de
%%PORTDOCS%%@dirrm %%DOCSDIR%%/ru
+%%PORTDOCS%%@dirrm %%DOCSDIR%%/pt_BR
%%PORTDOCS%%@dirrm %%DOCSDIR%%/ja
%%PORTDOCS%%@dirrm %%DOCSDIR%%/it
-%%PORTDOCS%%@dirrm %%DATADIR%%/ipptool
%%PORTDOCS%%@dirrm %%DOCSDIR%%/images
%%PORTDOCS%%@dirrm %%DOCSDIR%%/help
%%PORTDOCS%%@dirrm %%DOCSDIR%%/es
%%PORTDOCS%%@dirrm %%DOCSDIR%%/fr
%%PORTDOCS%%@dirrm %%DOCSDIR%%
%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+%%LIBUSB%%@dirrm %%DATADIR%%/usb
@dirrm %%DATADIR%%/templates/cs
@dirrm %%DATADIR%%/templates/ca
@dirrm %%DATADIR%%/templates/ru
+@dirrm %%DATADIR%%/templates/pt_BR
@dirrm %%DATADIR%%/templates/ja
@dirrm %%DATADIR%%/templates/it
@dirrm %%DATADIR%%/templates/es
@@ -1015,6 +1076,7 @@ share/locale/ru/cups_ru.po
@exec mkdir -p %D/%%DATADIR%%/model
@dirrmtry %%DATADIR%%/model
@dirrm %%DATADIR%%/mime
+@dirrm %%DATADIR%%/ipptool
@dirrm %%DATADIR%%/examples
@dirrm %%DATADIR%%/drv
@dirrmtry %%DATADIR%%
@@ -1026,7 +1088,6 @@ share/locale/ru/cups_ru.po
@dirrmtry libexec/cups/cgi-bin
@dirrmtry libexec/cups/backend
@dirrmtry libexec/cups
-%%PHP%%@dirrmtry lib/php/%%PHP_EXT_DIR%%
@dirrmtry etc/cups/interfaces
@dirrmtry etc/cups/ppd
@dirrmtry etc/cups/ssl
diff --git a/print/cups/Makefile b/print/cups/Makefile
index f20ca4fc4739..89382232d723 100644
--- a/print/cups/Makefile
+++ b/print/cups/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= cups
-PORTVERSION= 1.7.2
+PORTVERSION= 1.7.3
CATEGORIES= print
MASTER_SITES= # empty
DISTFILES= # empty