aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authormiwi <miwi@FreeBSD.org>2009-11-26 22:28:22 +0800
committermiwi <miwi@FreeBSD.org>2009-11-26 22:28:22 +0800
commitbccce733ca061174f93869d3f7825ee241dd8c96 (patch)
tree1973bb07d0fc096560f7cc010440fa1159810fb0 /print
parent99b567cb618dec554e4ca387f71fbbe58e374e27 (diff)
downloadfreebsd-ports-gnome-bccce733ca061174f93869d3f7825ee241dd8c96.tar.gz
freebsd-ports-gnome-bccce733ca061174f93869d3f7825ee241dd8c96.tar.zst
freebsd-ports-gnome-bccce733ca061174f93869d3f7825ee241dd8c96.zip
Tiny RML2PDF is a component of the Open Report project. It can be used with the
Tiny Reporting Server to have a complete solution to render PDF file on the fly. WWW: http://tiny.be PR: ports/140781 Submitted by: Kevin Golding <ports at caomhin.org>
Diffstat (limited to 'print')
-rw-r--r--print/Makefile1
-rw-r--r--print/py-trml2pdf/Makefile43
-rw-r--r--print/py-trml2pdf/distinfo3
-rw-r--r--print/py-trml2pdf/pkg-descr5
-rw-r--r--print/py-trml2pdf/pkg-plist43
5 files changed, 95 insertions, 0 deletions
diff --git a/print/Makefile b/print/Makefile
index fcd31902bb3e..380de0dabe58 100644
--- a/print/Makefile
+++ b/print/Makefile
@@ -298,6 +298,7 @@
SUBDIR += py-reportlab
SUBDIR += py-reportlab2
SUBDIR += py-rtf
+ SUBDIR += py-trml2pdf
SUBDIR += rlpr
SUBDIR += rprint
SUBDIR += rtf2latex
diff --git a/print/py-trml2pdf/Makefile b/print/py-trml2pdf/Makefile
new file mode 100644
index 000000000000..51659638fb09
--- /dev/null
+++ b/print/py-trml2pdf/Makefile
@@ -0,0 +1,43 @@
+# New ports collection makefile for: py-trml2pdf
+# Date created: 22 November 2009
+# Whom: Kevin Golding <ports@caomhin.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= trml2pdf
+PORTVERSION= 1.2
+CATEGORIES= print python
+MASTER_SITES= SF/kraft/${PORTNAME}/${PORTVERSION}
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= ports@caomhin.org
+COMMENT= Tiny RML2PDF easily creates PDF documents.
+
+RUN_DEPENDS= ${LOCALBASE}/bin/pildriver.py:${PORTSDIR}/graphics/py-imaging \
+ ${PYTHON_SITELIBDIR}/reportlab/__init__.py:${PORTSDIR}/print/py-reportlab
+
+NO_BUILD= yes
+
+USE_BZIP2= yes
+USE_PYTHON= yes
+
+DOCSDIR= ${PREFIX}/share/doc/py-${PORTNAME}
+EXAMPLESDIR= ${PREFIX}/share/examples/py-${PORTNAME}
+
+do-install:
+ @${MKDIR} ${PYTHON_SITELIBDIR}/trml2pdf
+ @${INSTALL_SCRIPT} ${WRKSRC}/trml2pdf/* ${PYTHON_SITELIBDIR}/trml2pdf
+
+post-install:
+.if !defined(NOPORTDOCS)
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/README.txt ${DOCSDIR}
+.endif
+
+.if !defined(NOPORTEXAMPLES)
+ @${MKDIR} ${EXAMPLESDIR}
+ ${CP} -R ${WRKSRC}/rmls/ ${EXAMPLESDIR}/rmls
+.endif
+
+.include <bsd.port.mk>
diff --git a/print/py-trml2pdf/distinfo b/print/py-trml2pdf/distinfo
new file mode 100644
index 000000000000..170aacc75c01
--- /dev/null
+++ b/print/py-trml2pdf/distinfo
@@ -0,0 +1,3 @@
+MD5 (trml2pdf-1.2.tar.bz2) = de938aa7c34b7f2f33a18df743fb6828
+SHA256 (trml2pdf-1.2.tar.bz2) = 93e0b25169db398af6eec0a1716d6b5a0836fc711b318520c0d2109411d7dc6d
+SIZE (trml2pdf-1.2.tar.bz2) = 178541
diff --git a/print/py-trml2pdf/pkg-descr b/print/py-trml2pdf/pkg-descr
new file mode 100644
index 000000000000..82445d3cfcfe
--- /dev/null
+++ b/print/py-trml2pdf/pkg-descr
@@ -0,0 +1,5 @@
+Tiny RML2PDF is a component of the Open Report project. It can be used with the
+Tiny Reporting Server to have a complete solution to render PDF file on the
+fly.
+
+WWW: http://tiny.be
diff --git a/print/py-trml2pdf/pkg-plist b/print/py-trml2pdf/pkg-plist
new file mode 100644
index 000000000000..82de82b1af9f
--- /dev/null
+++ b/print/py-trml2pdf/pkg-plist
@@ -0,0 +1,43 @@
+%%PYTHON_SITELIBDIR%%/trml2pdf/__init__.py
+%%PYTHON_SITELIBDIR%%/trml2pdf/color.py
+%%PYTHON_SITELIBDIR%%/trml2pdf/trml2pdf.py
+%%PYTHON_SITELIBDIR%%/trml2pdf/utils.py
+%%PORTDOCS%%%%DOCSDIR%%/README.txt
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rmls/aie.pdf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rmls/aie.rml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rmls/devis.pdf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rmls/devis.rml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rmls/ex1.pdf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rmls/ex1.rml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rmls/ex10.pdf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rmls/ex10.rml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rmls/ex11.pdf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rmls/ex11.rml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rmls/ex12.pdf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rmls/ex12.rml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rmls/ex2.pdf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rmls/ex2.rml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rmls/ex3.pdf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rmls/ex3.rml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rmls/ex4.pdf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rmls/ex4.rml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rmls/ex5.pdf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rmls/ex5.rml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rmls/ex6.pdf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rmls/ex6.rml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rmls/ex7.pdf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rmls/ex7.rml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rmls/ex7b.pdf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rmls/ex7b.rml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rmls/ex9.pdf
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rmls/ex9.rml
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rmls/pict/devis_logo.jpg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rmls/pict/logo.png
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rmls/pict/replogo.gif
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rmls/pict/screenshot.jpg
+%%PORTEXAMPLES%%%%EXAMPLESDIR%%/rmls/pict/tiny_logo.png
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/rmls/pict
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%/rmls
+%%PORTEXAMPLES%%@dirrm %%EXAMPLESDIR%%
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+@dirrm %%PYTHON_SITELIBDIR%%/trml2pdf