aboutsummaryrefslogtreecommitdiffstats
path: root/print
diff options
context:
space:
mode:
authorlinimon <linimon@FreeBSD.org>2006-01-28 10:11:35 +0800
committerlinimon <linimon@FreeBSD.org>2006-01-28 10:11:35 +0800
commitd5c0be22d278a4a0e99c688ca731a18f82499a05 (patch)
tree8f50d0e1ecdb414504f99a9a61595746ca60bbb8 /print
parentb4c0d8c775298941581f53b8adadfe0ec671773b (diff)
downloadfreebsd-ports-gnome-d5c0be22d278a4a0e99c688ca731a18f82499a05.tar.gz
freebsd-ports-gnome-d5c0be22d278a4a0e99c688ca731a18f82499a05.tar.zst
freebsd-ports-gnome-d5c0be22d278a4a0e99c688ca731a18f82499a05.zip
- Fix possibility of "infinite make fork" when "Registering install for ..."
EMACS ports. [1] - Allow building a port as root using an NFS-mounted /usr/ports if the server maps root to a UID other than root. [2] - Make 'BROKEN' and 'IGNORED' ports exit their "make install" with a fail status rather than success. [3] - Improve behavior when dealing with versioned dependencies. [4] - Fix false positives in check-conflicts target. [5] - Remove obsolete bzip2 code. [6] - Add physical category net-p2p. [7] - Don't fetch INDEXFILE if not necessary; respect FETCH_ENV. [8], [11] - INDEX can now be moved outside of ports tree. [9] - Add ghostscript-gpl. [10] - Remove obsolete USE_MESA. [12] - Force pkg_install tools from ports on FreeBSD 4.10 and older. [13] - Document ALWAYS_KEEP_DISTFILES. [14] - Remove USE_REINPLACE from bsd.port.mk USE_DOS2UNIX patch. [15] PR: ports/37596 [1], ports/57259 [2], ports/63216 [3], ports/89448 [4], ports/89710 [5], ports/88996 [6], ports/89260 [7], ports/89363 [8], ports/89809 [9], ports/89853 [10], ports/91086 [11], ports/91710 [12], ports/91727 [13], ports/92111 [14], ports/92124 [15] Submitted by: Jay Sachs <jay at eziba dot com> [1], sem [1, 3, 8, 12], Andrew Heybey <ath at niksun dot com> [2], Jamie Jones <jamie at thompson dot bishopston dot net>, tobez [4], Mark Andrews <Mark_Andrews at isc dot org> [5], edwin [6, 11, 15], pav [7, 13], Peter Jeremy <PeterJeremy at optushome dot com dot au> [9], Ulrich Spoerlein <q at galgenberg dot net> [10], netchild [11], erwin [14] Reviewed by: kris, clement (partially)
Diffstat (limited to 'print')
-rw-r--r--print/auctex/Makefile1
-rw-r--r--print/yatex-mule/Makefile1
-rw-r--r--print/yatex-xemacs-mule/Makefile1
-rw-r--r--print/yatex-xemacs/Makefile1
-rw-r--r--print/yatex/Makefile1
5 files changed, 5 insertions, 0 deletions
diff --git a/print/auctex/Makefile b/print/auctex/Makefile
index 144ab837576f..75dbf0723a7c 100644
--- a/print/auctex/Makefile
+++ b/print/auctex/Makefile
@@ -24,6 +24,7 @@ CONFIGURE_ARGS= --with-lispdir=${PREFIX}/${LISPDIR} \
--with-auto-dir=${PREFIX}/${LISPDIR}/auctex/auto \
--with-texmf-dir=${PREFIX}/${TEXMFDIR}
+USE_EMACS= yes
EMACS_PORT_NAME?= emacs21
LISPDIR= ${EMACS_VERSION_SITE_LISPDIR}
diff --git a/print/yatex-mule/Makefile b/print/yatex-mule/Makefile
index f24d548aa015..1e3c66cbb906 100644
--- a/print/yatex-mule/Makefile
+++ b/print/yatex-mule/Makefile
@@ -10,6 +10,7 @@ PKGNAMESUFFIX= -mule
MASTERDIR= ${.CURDIR}/../yatex
COMMENT= Yet Another LaTeX mode and html mode on Emacs (for mule 2.3)
+USE_EMACS= yes
EMACS_PORT_NAME=mule
.include "${MASTERDIR}/Makefile"
diff --git a/print/yatex-xemacs-mule/Makefile b/print/yatex-xemacs-mule/Makefile
index 0a40fdf275ab..1c927b34c15e 100644
--- a/print/yatex-xemacs-mule/Makefile
+++ b/print/yatex-xemacs-mule/Makefile
@@ -10,6 +10,7 @@ PKGNAMESUFFIX= -xemacs-mule
MASTERDIR= ${.CURDIR}/../yatex
COMMENT= Yet Another LaTeX mode and html mode on Emacs (for XEmacs21-mule)
+USE_EMACS= yes
EMACS_PORT_NAME=xemacs21-mule
IGNORE= hangs during build
diff --git a/print/yatex-xemacs/Makefile b/print/yatex-xemacs/Makefile
index 0e4f35013136..76ef32c03456 100644
--- a/print/yatex-xemacs/Makefile
+++ b/print/yatex-xemacs/Makefile
@@ -10,6 +10,7 @@ PKGNAMESUFFIX= -xemacs
MASTERDIR= ${.CURDIR}/../yatex
COMMENT= Yet Another LaTeX mode and html mode on Emacs (for XEmacs21)
+USE_EMACS= yes
EMACS_PORT_NAME=xemacs21
.include "${MASTERDIR}/Makefile"
diff --git a/print/yatex/Makefile b/print/yatex/Makefile
index 69bcaee08226..6ec2888627a2 100644
--- a/print/yatex/Makefile
+++ b/print/yatex/Makefile
@@ -19,6 +19,7 @@ PKGDEINSTALL= ${WRKDIR}/DEINSTALL
PKGMESSAGE= ${WRKDIR}/MESSAGE
WRKSRC= ${WRKDIR}/${PORTNAME}${PORTVERSION}
+USE_EMACS= yes
EMACS_PORT_NAME?=emacs21
EMACS_NO_RUN_DEPENDS=YES
.if (${EMACS_PORT_NAME} != xemacs21-mule)